Modify

Opened 4 months ago

Closed 2 months ago

Last modified 2 months ago

#19825 closed defect (fixed)

Advanced preferences table is empty w/o search text on Java 8

Reported by: mdk Owned by: team
Priority: normal Milestone: 20.12
Component: Core Version:
Keywords: template_report regression javabug preferences filter Cc:

Description (last modified by GerdP)

What steps will reproduce the problem?

  1. Set Scaling in Advanced Preferences to 2.0 (Read Settings from file scale2.0.xml)
  2. Restart JOSM
  3. Open Preferences
  4. Scroll down (with the mouse wheel) on the left side to "Advanced Preferences"

What is the expected result?

See the table with the Advanced Preferences.

What happens instead?

Only the title is shown. The table is missing.

Please provide any additional information below. Attach a screenshot if possible.

This happns only the first time you try to show the Advanced Preferences. If you change the the preference tab and go back to Advanced Preferences, the table is visible. You could reset the behaviour by restarting JOSM.
I don't know if the reason for this is the scaling or that the Advanced Preferences Icon on the left side is not visible on opening the preferences and maybe the GUI for advanced preferences will be generated when the icon is shown. But selecting the preferences with the mouse wheel didn't trigger the generation of the GUI.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-19 20:27:13 +0200 (Sat, 19 Sep 2020)
Revision:17046
Build-Date:2020-09-20 01:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17046 en) Linux Ubuntu 20.04.1 LTS
Memory Usage: 442 MB / 1980 MB (146 MB allocated, but free)
Java version: 14.0.1+7-Ubuntu-1ubuntu1, Private Build, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 3840x2160 (scaling 1.0x1.0)
Maximum Screen Size: 3840x2160
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: ubuntu:GNOME
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
libcommons-compress-java: libcommons-compress-java:all-1.19-1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
VM arguments: [--add-modules=java.scripting,java.sql, -Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]

Plugins:
+ ColumbusCSV (35405)
+ FastDraw (35499)
+ HouseNumberTaggingTool (35508)
+ OpeningHoursEditor (35414)
+ RoadSigns (35510)
+ SimplifyArea (35405)
+ buildings_tools (35500)
+ contourmerge (v0.1.6)
+ imagery-xml-bounds (35546)
+ imagery_offset_db (35405)
+ pbf (35446)
+ poly (35248)
+ public_transport (35405)
+ reltoolbox (35529)
+ reverter (35499)
+ terracer (35499)
+ turnrestrictions (35515)
+ utilsplugin2 (35487)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1

Attachments (6)

scale2.0.xml (2.6 KB) - added by mdk 4 months ago.
AdvancedPreferences.png (70.1 KB) - added by mdk 4 months ago.
AdvancedPrefs.png (97.7 KB) - added by mdk 2 months ago.
Still the same Problem with #17323
EmtyPrefs.png (44.0 KB) - added by mdk 2 months ago.
NullPrefs.png (40.0 KB) - added by mdk 2 months ago.
2020-11-22-131822_798x777_scrot.png (38.3 KB) - added by simon04 2 months ago.

Download all attachments as: .zip

Change History (27)

Changed 4 months ago by mdk

Attachment: scale2.0.xml added

Changed 4 months ago by mdk

Attachment: AdvancedPreferences.png added

comment:1 Changed 4 months ago by mdk

Description: modified (diff)

comment:2 Changed 2 months ago by GerdP

Please can you check if this is fixed with latest version?

Changed 2 months ago by mdk

Attachment: AdvancedPrefs.png added

Still the same Problem with #17323

comment:3 Changed 2 months ago by GerdP

I cannot reproduce this on Windows, but I don't have a HiDPI screen.

comment:4 Changed 2 months ago by mdk

I tried a little bit and could reproduce this with all scale=1.0
The steps are:

  1. Start JOSM
  2. Open Preference window ("Display" tab is selected)
  3. Move the mouse over these Tabs and use the Mouse wheel to select "Advanced Preferences"
  4. The first time the Advanced Preferences are empty.

When I click on the "Advanced Preference" Tab, it will be shown at the first time.

I think the key action is selecting the Tab with the Mouse Wheel.

comment:5 Changed 2 months ago by GerdP

I also cannot reproduce this behaviour with r17323 or r17084.

comment:6 Changed 2 months ago by mdk

Ok the problem is the ColumbusCSV (35405) plugin. It results in an empty preference tab (see #20123).

When I select the "null" tab, it vanish and automatically select the the next tab "Advanced Preference". But somehow this way the "Advanced Preference" tab is not initialized correctly.

When I use the mouse wheel I select all tabs one after the other. When I reach the "null" tab, automatically "Advanced Preference" will be shown, but not correctly initialized.

When I uninstall the ColumbusCSV plugin, also this problem disappear.

Changed 2 months ago by mdk

Attachment: EmtyPrefs.png added

Changed 2 months ago by mdk

Attachment: NullPrefs.png added

comment:7 Changed 2 months ago by mdk

On a normal Windows installation (no HiDPI) with ColumbusCSV plugin, I can reproduce this problem (when activating the "null" tab):


But actually r17329 without the plugin, the "advanced Preference" have a table for the values, but the table is empty:


Last edited 2 months ago by GerdP (previous) (diff)

comment:8 Changed 2 months ago by GerdP

This "empty" list is normal on Windows with java 8, you have to enter a filter to see something.

comment:9 in reply to:  8 ; Changed 2 months ago by stoecker

Replying to GerdP:

This "empty" list is normal on Windows with java 8, you have to enter a filter to see something.

Why is this "normal". Without a filter all elements must be shown.

comment:10 Changed 2 months ago by mdk

May give the user a hint, that he had to enter a search string to get any content.

comment:11 in reply to:  9 Changed 2 months ago by GerdP

Replying to stoecker:

Replying to GerdP:

This "empty" list is normal on Windows with java 8, you have to enter a filter to see something.

Why is this "normal". Without a filter all elements must be shown.

Yes, I just wanted to point out that this is not a new problem. I only noticed it recently when I ran JOSM on a newer JRE because I was surprised that the dialog was not empty.

comment:12 Changed 2 months ago by GerdP

Description: modified (diff)

Changed 2 months ago by simon04

comment:13 Changed 2 months ago by simon04

Summary: Advanced Preferences are missing first time after start on HIDPI settingsAdvanced preferences table is empty w/o search text on Java 8


Java 8 only. Not related to Windows. Not related to HiDPI.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Linux Arch Linux
Memory Usage: 1899 MB / 6997 MB (1197 MB allocated, but free)
Java version: 1.8.0_265-b01, Oracle Corporation, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 3840x2160 (scaling 1.0x1.0)
Maximum Screen Size: 3840x2160
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: i3

comment:14 Changed 2 months ago by Don-vip

Keywords: regression added
Milestone: 20.11

Regression of r15779:

Pattern.compile("\\s+").splitAsStream("")

doesn't behave the same between Java 8 and Java 15.

comment:15 Changed 2 months ago by Don-vip

I guess we just hit javabug:8069325

comment:16 Changed 2 months ago by Don-vip

We should just display all data when filter is empty, and skip all the filtering logic.

comment:17 Changed 2 months ago by Don-vip

Keywords: javabug preferences filter added

comment:18 Changed 2 months ago by simon04

Milestone: 20.1120.12

comment:19 Changed 2 months ago by GerdP

Ticket #20136 has been marked as a duplicate of this ticket.

comment:20 Changed 2 months ago by GerdP

Resolution: fixed
Status: newclosed

In 17331/josm:

fix #19825: Advanced preferences table is empty w/o search text on Java 8

comment:21 Changed 2 months ago by simon04

Thank you for debugging and fixing this issue!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.