Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#20136 closed defect (duplicate)

Advanced Settings menu is empty

Reported by: Max1234-ITA Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: settings, advanced Cc:

Description

What steps will reproduce the problem?

  1. In JOSM v. 17329, open the Edit/Preferences menu
  2. Tick the Expert Mode checkbox
  3. Scroll the lsit down to the end; select Advanced Preferences item

What is the expected result?

Advanced Preferences are listed in the window

What happens instead?

The list remains empty

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Build-Date:2020-11-22 02:30:52
Revision:17329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17329 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2004 (19041)
Memory Usage: 761 MB / 1820 MB (297 MB allocated, but free)
Java version: 1.8.0_271-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ EasyPresets (1595741614)
+ FastDraw (35640)
+ FixAddresses (35640)
+ OpeningHoursEditor (35640)
+ RoadSigns (35640)
+ auto_tools (73)
+ buildings_tools (35640)
+ continuosDownload (91)
+ flatlaf (35568)
+ imagery_offset_db (35640)
+ measurement (35640)
+ print (35640)
+ reltoolbox (35640)
+ reverter (35640)
+ rex (53)
+ turnrestrictions (35640)
+ utilsplugin2 (35640)

Last errors/warnings:
- 00009.407 W: Update plugins - You updated your JOSM software. To prevent problems the plugins should be updated as well.  Update plugins now?
- 00030.469 W: Failed to delete outdated plugin '<josm.pref>\plugins\flatlaf.jar'.
- 00030.469 W: Failed to install already downloaded plugin 'flatlaf'. Skipping installation. JOSM is still going to load the old plugin version.
- 00283.231 E: Region [TMS_BLOCK_v2] : Failure getting from disk--IOException, key = OpenStreetMap Carto (Standard):https://{switch:a,b,c}.tile.openstreetmap.org/{zoom}/{x}/{y}.png/14/8611/5892
- 00531.960 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=875435518 version=1 MVDT nodes=[{Node id=8148524724 version=1 MVD lat=45.01669940076,lon=9.21712830529}, {Node id=8148524805 version=1 V lat=45.01671995079,lon=9.21716437043}, {Node id=8148524788 version=1 V lat=45.01672521378,lon=9.21710822488}]} (changed by the following commands: [Sequence: Connect existing way to node], [Delete 2 objects])
- 01587.162 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out

Attachments (1)

Untitled.jpg (1.3 MB) - added by Max1234-ITA 2 months ago.
Screenshot

Download all attachments as: .zip

Change History (5)

Changed 2 months ago by Max1234-ITA

Attachment: Untitled.jpg added

Screenshot

comment:1 Changed 2 months ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20123.

comment:2 Changed 2 months ago by mdk

It's more a duplicate of #19825.

comment:3 Changed 2 months ago by GerdP

Marked as duplicate of #19825.
yes, corrected

comment:4 in reply to:  description Changed 2 months ago by skyper

Replying to max1234ita@…:

Plugins:
+ flatlaf (35568)

Last errors/warnings:
- 00009.407 W: Update plugins - You updated your JOSM software. To prevent problems the plugins should be updated as well.  Update plugins now?
- 00030.469 W: Failed to delete outdated plugin '<josm.pref>\plugins\flatlaf.jar'.
- 00030.469 W: Failed to install already downloaded plugin 'flatlaf'. Skipping installation. JOSM is still going to load the old plugin version.

At least Windows has a problem with updating flatlaf plugin, see #19901.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.