Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#19255 closed enhancement (fixed)

History browser: add "position/index of member" column

Reported by: simon04 Owned by: simon04
Priority: normal Milestone: 20.05
Component: Core Version:
Keywords: history browser rownumber index position Cc: GerdP, yopaseopor, OttawaHiking

Description (last modified by simon04)

Suggested in ticket:19161#comment:13

Related: #15660 for an index column in the relation editor


Attachments (3)

2020-05-18-000851_1011x926_scrot.png (43.3 KB) - added by simon04 6 months ago.
2020-05-18-000854_1011x926_scrot.png (43.1 KB) - added by simon04 6 months ago.
josm_history_members_color.png (47.3 KB) - added by skyper 6 months ago.
small example of problem

Download all attachments as: .zip

Change History (19)

comment:1 Changed 6 months ago by simon04

Cc: OttawaHiking added

Changed 6 months ago by simon04

Changed 6 months ago by simon04

comment:2 in reply to:  description Changed 6 months ago by simon04

Description: modified (diff)
Milestone: 20.05
Owner: changed from team to simon04
Status: newassigned

What do you think of the drafted solution?

comment:3 Changed 6 months ago by GerdP

I think it's easier to understand. Before looking at #19161 I did not even notice that there are different shades of green and red with different meaning in the history dialogs.

comment:4 Changed 6 months ago by skyper

Much better +1

Note, I was stumbling as the screenshot on the right does not display all members of version "A". Are background colors only used on version "A" or does the example not show a case with colors on both versions?

comment:5 in reply to:  4 ; Changed 6 months ago by simon04

Replying to skyper:

Note, I was stumbling as the screenshot on the right does not display all members of version "A". Are background colors only used on version "A" or does the example not show a case with colors on both versions?

The currend tested r16239 has the same behaviour as illustrated in the screenshot.

comment:6 in reply to:  5 ; Changed 6 months ago by skyper

Replying to simon04:

Replying to skyper:

Note, I was stumbling as the screenshot on the right does not display all members of version "A". Are background colors only used on version "A" or does the example not show a case with colors on both versions?

The current tested r16239 has the same behaviour as illustrated in the screenshot.

  • On the left side version "A" has 34 members, on the right side version "A" has only 27 members.
  • With r16459 I have background colors on both sides and the example misses new members as show case which I expect to still have a green background.

comment:7 in reply to:  6 ; Changed 6 months ago by Klumbumbus

Replying to skyper:

  • On the left side version "A" has 34 members, on the right side version "A" has only 27 members.

Left compares version 9 with 10 and right 10 with "10 local edited".

comment:8 in reply to:  7 ; Changed 6 months ago by skyper

Replying to Klumbumbus:

Replying to skyper:

  • On the left side version "A" has 34 members, on the right side version "A" has only 27 members.

Left compares version 9 with 10 and right 10 with "10 local edited".

Ok, that's why I stumbled. The screenshots are not comparable.

comment:9 in reply to:  8 Changed 6 months ago by Klumbumbus

Replying to skyper:

The screenshots are not comparable.

Yes, they are not "before-after", but both "after", just different examples.

comment:10 Changed 6 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 16490/josm:

fix #19255 - History browser: add "index of node/member" column

comment:11 Changed 6 months ago by simon04

In 16497/josm:

see #19255 - Java 8: use Stream

comment:12 Changed 6 months ago by skyper

This influenced the background color highlighting which is now more confusing than before and broken. In fact, it turned #12548 and #13706 into defects.

comment:13 Changed 6 months ago by GerdP

@skyper: Can you give an example?

comment:14 Changed 6 months ago by GerdP

I see no changes in the code which would change the colouring, but #19253 looks like a good candidate.

comment:15 Changed 6 months ago by simon04

In 16526/josm:

see #19255 - Java 8: use Stream

Changed 6 months ago by skyper

small example of problem

comment:16 Changed 6 months ago by skyper

The problem is that the coloring is bounded to the rows and not the id, see my comment on #13706 (comment 4).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.