Modify

Opened 11 months ago

Closed 5 months ago

Last modified 5 months ago

#18586 closed enhancement (fixed)

Invert selection

Reported by: densyakun1128@… Owned by: team
Priority: normal Milestone: 20.06
Component: Core Version:
Keywords: selection invert Cc:

Description

(Translated)
Make sure the selection can be inverted.

(Original text)
選択範囲の反転ができるようにしてください。

Attachments (0)

Change History (17)

comment:1 in reply to:  description Changed 11 months ago by anonymous

(Translated)
Please add the ability to invert the selection.

(Original text)
選択範囲の反転ができる機能を追加してください。

comment:2 Changed 11 months ago by Klumbumbus

Resolution: worksforme
Status: newclosed

Use -selected in the search window. You can add a specific search as toolbar button too if needed, see wiki:/Help/Action/Search#SavesearchqueryinMaintoolbar

comment:3 Changed 11 months ago by Klumbumbus

Priority: majornormal

comment:4 Changed 11 months ago by skyper

could be added to the selection menu.

comment:5 Changed 11 months ago by Don-vip

Keywords: selection invert added
Resolution: worksforme
Status: closedreopened

Adding "Invert selection" to the selection menu sounds a reasonable enhancement. Probably limited to expert users though.

comment:6 Changed 11 months ago by simon04

comment:7 Changed 5 months ago by simon04

Resolution: fixed
Status: reopenedclosed

In 16701/josm:

fix #18586 - Add invert selection action for experts

comment:8 Changed 5 months ago by simon04

Milestone: 20.06

comment:9 Changed 5 months ago by skyper

no icon ? shortcut ?

comment:11 Changed 5 months ago by Klumbumbus

In 16704/josm:

see #18586 - Add icon for invert selection action (mix of selectall and unselectall icons, CC0 and PD licensed)

comment:12 Changed 5 months ago by Klumbumbus

We are basically out of shortcuts. Which shortcut do you suggest?

comment:13 Changed 5 months ago by Klumbumbus

Ticket #6779 has been marked as a duplicate of this ticket.

comment:14 Changed 5 months ago by Klumbumbus

Ticket #11199 has been marked as a duplicate of this ticket.

comment:15 Changed 5 months ago by skyper

According to the shortcuts list, Ctrl+BackSpace is still available.

comment:16 Changed 5 months ago by Klumbumbus

Sounds ok to me. Simon, what do you think?

comment:17 Changed 5 months ago by simon04

My opinion: Not every action needs a shortcut. Especially expert users can assign shortcuts themselves for the most used actions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.