List of shortcuts

The following tables contains a list of shortcuts automatically extracted from JOSM source. The third column contains links to the source of JOSM.

The list below contains 467 items (289 in JOSM core); Shortcuts page covers half of them, most system shortcuts are explained; uncovered shortcuts are from plug-ins.

groupdefault modifier

0 ALT+0 ALT subwindow:layers:toggleLayer10 Toggle visibility of layer: 10
0 ALT+SHIFT+0 ALT_SHIFT MapDust Toggle: Open MapDust
0 CMD+0, CTRL properties:recent:10 Choose recent tag 10
0 CMD+SHIFT+0 CTRL_SHIFT properties:recent:apply:10 Apply recent tag 10
0 CMD+SHIFT+0 CTRL_SHIFT properties:recent:shift:10 Apply recent tag 10
1 1 DIRECT view:zoomdata View: data
1 ALT+1 ALT subwindow:layers:toggleLayer1 Toggle visibility of layer: 1
1 ALT+SHIFT+1 ALT_SHIFT OsmInspector Toggle: Open OsmInspector
1 ALT+SHIFT+1 ALT_SHIFT edit:launchtageditor Launches the tag editor dialog
1 CMD+1, CTRL properties:recent:1 Choose recent tag 1
1 CMD+SHIFT+1 CTRL_SHIFT properties:recent:apply:1 Apply recent tag 1
1 CMD+SHIFT+1 CTRL_SHIFT properties:recent:shift:1 Apply recent tag 1
2 2 DIRECT view:zoomlayer View: layer
2 ALT+2 ALT subwindow:layers:toggleLayer2 Toggle visibility of layer: 2
2 ALT+SHIFT+2 ALT_SHIFT edit:turnlanestaggingeditor Tool: turn lanes tagging - editor
2 ALT+SHIFT+2 ALT_SHIFT tools:turnrestriction Tool: Create or edit a turn restriction.
2 CMD+2, CTRL properties:recent:2 Choose recent tag 2
2 CMD+SHIFT+2 CTRL_SHIFT properties:recent:apply:2 Apply recent tag 2
2 CMD+SHIFT+2 CTRL_SHIFT properties:recent:shift:2 Apply recent tag 2
3 3 DIRECT view:zoomselection View: selection
3 ALT+3 ALT subwindow:layers:toggleLayer3 Toggle visibility of layer: 3
3 CMD+3, CTRL properties:recent:3 Choose recent tag 3
3 CMD+SHIFT+3 CTRL_SHIFT properties:recent:apply:3 Apply recent tag 3
3 CMD+SHIFT+3 CTRL_SHIFT properties:recent:shift:3 Apply recent tag 3
3 CTRL+META+SHIFT+3 RESERVED(CTRL+META+SHIFT) apple-reserved-37 reserved
3 META+SHIFT+3 RESERVED(META+SHIFT) apple-reserved-36 reserved
4 4 DIRECT view:zoomconflict View: conflict
4 ALT+4 ALT subwindow:layers:toggleLayer4 Toggle visibility of layer: 4
4 CMD+4, CTRL properties:recent:4 Choose recent tag 4
4 CMD+SHIFT+4 CTRL_SHIFT properties:recent:apply:4 Apply recent tag 4
4 CMD+SHIFT+4 CTRL_SHIFT properties:recent:shift:4 Apply recent tag 4
4 CTRL+META+SHIFT+4 RESERVED(CTRL+META+SHIFT) apple-reserved-39 reserved
4 META+SHIFT+4 RESERVED(META+SHIFT) apple-reserved-38 reserved
5 5 DIRECT view:zoomdownload View: download
5 ALT+5 ALT subwindow:layers:toggleLayer5 Toggle visibility of layer: 5
5 CMD+5, CTRL properties:recent:5 Choose recent tag 5
5 CMD+SHIFT+5 CTRL_SHIFT properties:recent:apply:5 Apply recent tag 5
5 CMD+SHIFT+5 CTRL_SHIFT properties:recent:shift:5 Apply recent tag 5
6 6 DIRECT view:zoomproblem View: problem
6 ALT+6 ALT subwindow:layers:toggleLayer6 Toggle visibility of layer: 6
6 CMD+6, CTRL properties:recent:6 Choose recent tag 6
6 CMD+SHIFT+6 CTRL_SHIFT properties:recent:apply:6 Apply recent tag 6
6 CMD+SHIFT+6 CTRL_SHIFT properties:recent:shift:6 Apply recent tag 6
7 ALT+7 ALT subwindow:layers:toggleLayer7 Toggle visibility of layer: 7
7 CMD+7, CTRL properties:recent:7 Choose recent tag 7
7 CMD+SHIFT+7 CTRL_SHIFT properties:recent:apply:7 Apply recent tag 7
7 CMD+SHIFT+7 CTRL_SHIFT properties:recent:shift:7 Apply recent tag 7
8 8 DIRECT view:zoomprevious View: previous
8 ALT+8 ALT subwindow:layers:toggleLayer8 Toggle visibility of layer: 8
8 ALT+CTRL+META+8 RESERVED(ALT+CTRL+META) apple-reserved-41 reserved
8 ALT+META+8 RESERVED(ALT+META) apple-reserved-40 reserved
8 CMD+8, CTRL properties:recent:8 Choose recent tag 8
8 CMD+SHIFT+8 CTRL_SHIFT properties:recent:apply:8 Apply recent tag 8
8 CMD+SHIFT+8 CTRL_SHIFT properties:recent:shift:8 Apply recent tag 8
9 9 DIRECT view:zoomnext View: next
9 ALT+9 ALT subwindow:layers:toggleLayer9 Toggle visibility of layer: 9
9 CMD+9, CTRL properties:recent:9 Choose recent tag 9
9 CMD+SHIFT+9 CTRL_SHIFT properties:recent:apply:9 Apply recent tag 9
9 CMD+SHIFT+9 CTRL_SHIFT properties:recent:shift:9 Apply recent tag 9
9 NONE Mapillary changeset Open Mapillary changeset dialog
ADD ADD DIRECT view:zoominkeypad View: Zoom In (Keypad)
ADD META+ADD RESERVED(META) view:zoomin reserved
A A DIRECT mapmode:draw Mode: Draw
A ALT+A, ALT properties:add Add Tag
A ALT+CMD+A ALT_CTRL reltoolbox:multipolygon Relation Toolbox: Create multipolygon
A ALT+CMD+A ALT_CTRL tools:areaselector Tools: Area Selector
A ALT+CMD+SHIFT+A ALT_CTRL_SHIFT subwindow:opendata Toggle: OpenData
A ALT+SHIFT+A ALT_SHIFT subwindow:authors Toggle: Authors
A CMD+A CTRL system:selectall Edit: Select All
A CMD+SHIFT+A CTRL_SHIFT AutoTools:ReplaceBuilding AutoTools:ReplaceBuilding
A CMD+SHIFT+A CTRL_SHIFT Fetch Address Fetch Address
A CTRL+A RESERVED(CTRL) system:selectall reserved
A META+A RESERVED(META) system:selectall reserved
A SHIFT+A SHIFT core_multikey:activateLayer Multikey: Activate layer
BACK_SLASH BACK_SLASH DIRECT mapmode:infomode Mode: GPX info mode
BACK_SPACE BACK_SPACE, DIRECT mapmode:backspace Backspace in Add mode
B B DIRECT mapmode:buildings Mode: Draw buildings
B ALT+CMD+B ALT_CTRL edit:buildingsdialog Edit: Set buildings size
B ALT+CMD+B ALT_CTRL tools:tagbuilding Tools: Tag Building
B CMD+B CTRL tools:multipoly_create Tool: Create multipolygon
B CMD+SHIFT+B CTRL_SHIFT tools:multipoly_update Tool: Update multipolygon
B SHIFT+B SHIFT tools:distribute Tool: Distribute Nodes
CLOSE_BRACKET CLOSE_BRACKET DIRECT subwindow:todo:mark Mark element done
COMMA ALT+COMMA MNEMONIC menu:Public Transport Menu: Public Transport
COMMA CMD+COMMA CTRL view:zoominalternate Map: Zoom in
COMMA META+COMMA RESERVED(META) system:preferences reserved
COMMA SHIFT+COMMA SHIFT Mapillary Open Mapillary layer
C C DIRECT tools:combineway Tool: Combine Way
C ALT+CMD+C ALT_CTRL menu:windows:changesetdialog Toggle visibility of Changeset Manager window
C ALT+CMD+SHIFT+C ALT_CTRL_SHIFT geoimage:copypath Geoimage: Copy image path
C ALT+C MNEMONIC menu:Cadastre Menu: Cadastre
C ALT+SHIFT+C ALT_SHIFT subwindow:conflict Toggle: Conflict
C CMD+C CTRL system:copy Edit: Copy
C CMD+SHIFT+C CTRL_SHIFT copy:coordinates Edit: Copy Coordinates
C CTRL+C RESERVED(CTRL) system:copy reserved
C META+C RESERVED(META) system:copy reserved
C SHIFT+C SHIFT tools:createcurve Tool: Create a circle arc
DEAD_GRAVE META+DEAD_GRAVE RESERVED(META) apple-reserved-26 reserved
DELETE DELETE DIRECT system:delete Edit: Delete
DELETE ALT+DELETE ALT relationeditor:remove Relation Editor: Remove
DELETE CMD+DELETE CTRL mapmode:delete Mode: Delete
DELETE CMD+SHIFT+DELETE CTRL_SHIFT geoimage:deletefilefromdisk Geoimage: Delete File from disk
DELETE SHIFT+DELETE SHIFT geoimage:deleteimagefromlayer Geoimage: Remove photo from layer
DOWN ALT+DOWN ALT relationeditor:movedown Relation Editor: Move Down
DOWN CMD+DOWN CTRL system:movefocusdown Map: Move down
DOWN CMD+SHIFT+DOWN CTRL_SHIFT file:download File: Download data
DOWN CTRL+DOWN, RESERVED(CTRL) system:movefocusdown reserved
DOWN SHIFT+DOWN SHIFT core:movedown Move objects down
D ALT+CMD+D ALT_CTRL file:downloadreferrers File: Download parent ways/relations...
D ALT+CMD+SHIFT+D ALT_CTRL_SHIFT properties:delete Delete Tags
D ALT+D MNEMONIC menu:Data Menu: Data
D ALT+META+D RESERVED(ALT+META) apple-reserved-42 reserved
D ALT+SHIFT+D ALT_SHIFT continuosdownload:activate Toggle the continuous download on/off
D ALT+SHIFT+D ALT_SHIFT subwindow:select Toggle: Current Selected Bug Info
D ALT+SHIFT+D ALT_SHIFT tools:download_along Tool: Download Along
D CMD+D CTRL system:duplicate Edit: Duplicate
D CTRL+D RESERVED(CTRL) system:duplicate reserved
D CTRL+META+D RESERVED(CTRL+META) system:dictionarylookup reserved
D SHIFT+D SHIFT addnode Edit: Add Node...
END END DIRECT geoimage:last Geoimage: Show last Image
END ALT+END ALT relationeditor:sort Relation Editor: Sort
ENTER ENTER DIRECT mapmode:enter ConfirmMultipolygonSelection
ENTER ENTER DIRECT tool:commandline Tool: Command line
ENTER ALT+ENTER RESERVED(ALT) microsoft-reserved-31 reserved
EQUALS EQUALS DIRECT reltoolbox:addremove Relation Toolbox: Add/remove members from the chosen relation
EQUALS EQUALS DIRECT view:zoominter View: Zoom In
EQUALS ALT+META+EQUALS RESERVED(ALT+META) apple-reserved-35 reserved
EQUALS SHIFT+EQUALS SHIFT view:zoominbis View: Zoom In
ESCAPE ESCAPE DIRECT edit:unselectall Edit: Unselect All
ESCAPE ALT+ESCAPE RESERVED(ALT) microsoft-reserved-39 reserved
ESCAPE ALT+META+ESCAPE RESERVED(ALT+META) apple-reserved-11 reserved
ESCAPE CTRL+ESCAPE RESERVED(CTRL) microsoft-reserved-43 reserved
ESCAPE CTRL+SHIFT+ESCAPE RESERVED(CTRL+SHIFT) microsoft-reserved-50 reserved
ESCAPE META+ESCAPE RESERVED(META) apple-reserved-10 reserved
ESCAPE SHIFT+ESCAPE SHIFT relationeditor:editrecentrelation Relation Editor: Open recent relation
E E DIRECT mapmode:cadastre-fr-buildings Mode: CadastreFR - Buildings
E E DIRECT tools:adjnodes Tool: Adjacent nodes
E ALT+CMD+E ALT_CTRL core_multikey:enableFilter Multikey: Enable filter
E ALT+E MNEMONIC menu:Edit Menu: Edit
E ALT+SHIFT+E ALT_SHIFT tools:midnodes Tool: Middle nodes
E CMD+E CTRL file:exportgpx Export to GPX...
E CMD+SHIFT+E CTRL_SHIFT tools:adjwaysall Tool: All connected ways
E SHIFT+E SHIFT tools:adjways Tool: Adjacent ways
F10 F10 DIRECT cadastre:grab Cadastre: Download Image from French Cadastre WMS
F10 F10 RESERVED apple-reserved-23 reserved
F10 ALT+CTRL+F10 RESERVED(ALT+CTRL) screen:toogle10 reserved
F10 SHIFT+F10 RESERVED(SHIFT) microsoft-reserved-42 reserved
F11 F11 DIRECT menu:view:fullscreen Toggle fullscreen view
F11 F11 RESERVED apple-reserved-24 reserved
F11 ALT+CTRL+F11 RESERVED(ALT+CTRL) screen:toogle11 reserved
F12 F12 DIRECT system:preferences Preferences
F12 F12 RESERVED apple-reserved-25 reserved
F12 ALT+CTRL+F12 RESERVED(ALT+CTRL) screen:toogle12 reserved
F1 F1, DIRECT system:help Help
F1 ALT+CTRL+F1 RESERVED(ALT+CTRL) screen:toogle1 reserved
F1 CTRL+F1 RESERVED(CTRL) apple-reserved-12 reserved
F1 SHIFT+F1 SHIFT system:about About
F2 ALT+CTRL+F2 RESERVED(ALT+CTRL) screen:toogle2 reserved
F2 CTRL+F2 RESERVED(CTRL) apple-reserved-13 reserved
F3 F3 DIRECT preset:search Search presets
F3 ALT+CTRL+F3 RESERVED(ALT+CTRL) screen:toogle3 reserved
F3 CTRL+F3 RESERVED(CTRL) apple-reserved-14 reserved
F3 SHIFT+F3 SHIFT preset:search-objects Search for objects by preset
F4 F4 DIRECT audio:slower Audio: Slower
F4 ALT+CTRL+F4 RESERVED(ALT+CTRL) screen:toogle4 reserved
F4 ALT+F4 RESERVED(ALT) system:exit reserved
F4 CMD+F4 CTRL system:deletelayer File: Delete Layer
F4 CTRL+F4 RESERVED(CTRL) apple-reserved-15 reserved
F4 CTRL+SHIFT+F4 RESERVED(CTRL+SHIFT) apple-reserved-16 reserved
F5 F5 DIRECT audio:prev Audio: Previous Marker
F5 ALT+CTRL+F5 RESERVED(ALT+CTRL) screen:toogle5 reserved
F5 CTRL+F5 RESERVED(CTRL) apple-reserved-17 reserved
F5 META+F5 RESERVED(META) apple-reserved-18 reserved
F6 F6 DIRECT audio:back Audio: Back
F6 ALT+CTRL+F6 RESERVED(ALT+CTRL) screen:toogle6 reserved
F6 CTRL+F6 RESERVED(CTRL) apple-reserved-19 reserved
F6 CTRL+SHIFT+F6 RESERVED(CTRL+SHIFT) apple-reserved-20 reserved
F7 F7 DIRECT audio:forward Audio: Forward
F7 ALT+CTRL+F7 RESERVED(ALT+CTRL) screen:toogle7 reserved
F7 CTRL+F7 RESERVED(CTRL) apple-reserved-21 reserved
F8 F8 DIRECT audio:next Audio: Next Marker
F8 ALT+CTRL+F8 RESERVED(ALT+CTRL) screen:toogle8 reserved
F9 F9 DIRECT audio:faster Audio: Faster
F9 F9 RESERVED apple-reserved-22 reserved
F9 ALT+CTRL+F9 RESERVED(ALT+CTRL) screen:toogle9 reserved
F F DIRECT tools:followline Tool: Follow
F ALT+CMD+F ALT_CTRL conflation:replace Conflation: Replace
F ALT+CMD+F ALT_CTRL reltoolbox:find Relation Toolbox: Find a relation
F ALT+CMD+SHIFT+F ALT_CTRL_SHIFT tools:pdfimport Tool: Import PDF file
F ALT+F MNEMONIC menu:File Menu: File
F ALT+META+F RESERVED(ALT+META) system:search reserved
F ALT+SHIFT+F ALT_SHIFT subwindow:filter Toggle: Filter
F ALT+SHIFT+F ALT_SHIFT tofix:fixed tofix:Fixed item
F CMD+F CTRL system:find Search...
F CMD+SHIFT+F CTRL_SHIFT menu:view:viewportfollow Toggle Viewport Following
F META+F RESERVED(META) system:find reserved
F SHIFT+F SHIFT mapmode:fastdraw Mode: Fast drawing mode
G G DIRECT tools:unglue Tool: UnGlue Ways
G ALT+CMD+G ALT_CTRL menu:buildinggeneralization Menu: Building Generalization
G ALT+CMD+G ALT_CTRL menu:globalsatimport Menu: Globalsat Import
G ALT+CMD+G ALT_CTRL menu:sumoexport Menu: SUMO Export
G ALT+CMD+SHIFT+G ALT_CTRL_SHIFT subwindow:livegps Toggle: Live GPS
G ALT+SHIFT+G ALT_SHIFT tools:ungluerelation Tool: UnGlue Relations
G CMD+G CTRL tools:uploadtraces Tool: Upload Traces
G CMD+SHIFT+G CTRL_SHIFT tools:replacegeometry Tool: Replace Geometry
G SHIFT+G SHIFT tools:CreateGridOfWays Tool: Create grid of ways
HOME HOME DIRECT edit:centergps Edit: Center Once
HOME HOME DIRECT geoimage:first Geoimage: Show first Image
HOME ALT+HOME ALT relationeditor:downloadincomplete Relation Editor: Download Members
HOME CMD+HOME CTRL menu:livegps:autocenter Menu: Capture GPS Track
H ALT+CMD+H ALT_CTRL core_multikey:hidingFilter Multikey: Hide filter
H ALT+CMD+SHIFT+H ALT_CTRL_SHIFT tool:history Tool: Display objects history dialog
H ALT+H MNEMONIC menu:Help Menu: Help
H ALT+META+H RESERVED(ALT+META) system:hideothers reserved
H CMD+H CTRL core:historyinfo History
H CMD+SHIFT+H CTRL_SHIFT core:historyinfoweb History (web)
H META+H RESERVED(META) system:hide reserved
H SHIFT+H SHIFT tools:openurl Tool: Open custom URL
INSERT CMD+INSERT CTRL system:copy:cua Edit: Copy
INSERT SHIFT+INSERT SHIFT system:paste:cua Edit: Paste
I I DIRECT tools:intway Tool: Intersecting ways
I ALT+CMD+I ALT_CTRL imageryoffset:get Imagery: Get Imagery Offset...
I ALT+CMD+SHIFT+I ALT_CTRL_SHIFT osmObjInfo Toggle: OpenStreetMap obj info
I ALT+CMD+SHIFT+I ALT_CTRL_SHIFT tools:openvisible Menu: Open Visible...
I ALT+I MNEMONIC menu:Imagery Menu: Imagery
I ALT+SHIFT+I ALT_SHIFT tools:selinside Tool: All inside
I CMD+I CTRL core:info Advanced info
I CMD+SHIFT+I CTRL_SHIFT core:infoweb Advanced info (web)
I SHIFT+I SHIFT tools:addintersect Tool: Add nodes at intersections
J J DIRECT tools:joinnodeway Tool: Join Node to Way
J ALT+CMD+J ALT_CTRL core_multikey:nextMarker Multikey: Next marker
J ALT+CMD+SHIFT+J ALT_CTRL_SHIFT file:restart File: Restart
J ALT+J ALT tools:unjoinnodeway Tool: Disconnect Node from Way
J ALT+SHIFT+J ALT_SHIFT subwindow:junctionchecker Toggle: junctions
J ALT+SHIFT+J ALT_SHIFT tools:extnode Tool: Extract node
J CMD+J CTRL tools:jumpto Tool: Jump To Position
J CMD+SHIFT+J CTRL_SHIFT osmi:prev Prev OSMI bug
J SHIFT+J SHIFT tools:joinareas Tool: Join overlapping Areas
K K DIRECT edit:housenumbertaggingtool HouseNumberTaggingTool
K ALT+K ALT Edit Highlighted Relation Edit Highlighted Relation
K ALT+K MNEMONIC menu:Auto Tools Menu: Auto Tools
K ALT+K MNEMONIC menu:Task config Menu: Task config
K CMD+K CTRL mapmode:edge_selection Mode: Edge Selection
K CMD+SHIFT+K CTRL_SHIFT mapmode:stop_position Mode: Add stop position
K CMD+SHIFT+K CTRL_SHIFT osmi:next Next OSMI bug
LEFT CMD+LEFT CTRL system:movefocusleft Map: Move left
LEFT CTRL+LEFT, RESERVED(CTRL) system:movefocusleft reserved
LEFT META+LEFT RESERVED(META) apple-reserved-49 reserved
LEFT SHIFT+LEFT SHIFT core:moveleft Move objects left
L L DIRECT tools:alignline Tool: Align Nodes in Line
L ALT+CMD+SHIFT+L ALT_CTRL_SHIFT tools:lakewalker Tool: Lake Walker
L ALT+SHIFT+L ALT_SHIFT subwindow:layers Toggle: Layers
L CMD+L CTRL system:open_location File: Open Location...
L CMD+SHIFT+L CTRL_SHIFT latlon Edit: Lat Lon tool
L SHIFT+L SHIFT tools:alignwaynodes Tool: Align Way Nodes
MINUS MINUS DIRECT view:zoomout View: Zoom Out
MINUS ALT+META+MINUS RESERVED(ALT+META) apple-reserved-30 reserved
MINUS META+MINUS RESERVED(META) apple-reserved-29 reserved
MULTIPLY MULTIPLY DIRECT menu:irsrectify Update IRS adjustment layer
MULTIPLY CMD+MULTIPLY CTRL tools:intwayall Tool: All intersecting ways
M M DIRECT tools:mergenodes Tool: Merge Nodes
M ALT+CMD+M ALT_CTRL AutoTools:CLAbuildings AutoTools:CLAbuildings
M ALT+CMD+M ALT_CTRL file:updatemodified File: Update modified
M ALT+M MNEMONIC menu:More tools Menu: More tools
M ALT+SHIFT+M ALT_SHIFT subwindow:mappaint Toggle: MapPaint
M CMD+M CTRL system:merge Edit: Merge
M CMD+SHIFT+M CTRL_SHIFT system:mergeselection Edit: Merge selection
M SHIFT+M SHIFT tools:mirror Tool: Mirror
NUMPAD2 NUMPAD2 DIRECT videomapping:slower Video: Slower
NUMPAD4 NUMPAD4 DIRECT videomapping:backward Video: Backward
NUMPAD5 NUMPAD5 DIRECT videomapping:startstop Video: Play/Pause
NUMPAD6 NUMPAD6 DIRECT videomapping:forward Video: Forward
NUMPAD7 NUMPAD7 DIRECT videomapping:loop Video: Loop
NUMPAD8 NUMPAD8 DIRECT videomapping:faster Video: Faster
NUM_LOCK ALT+SHIFT+NUM_LOCK RESERVED(ALT+SHIFT) microsoft-reserved-02 reserved
N N DIRECT tools:movenodeontoway Tool: Move Node onto Way
N ALT+CMD+N ALT_CTRL reltoolbox:create Relation Toolbox: Create a new relation
N ALT+N MNEMONIC menu:Selection Menu: Selection
N ALT+SHIFT+N ALT_SHIFT tofix:noterror tofix:Not a Error item
N ALT+SHIFT+N ALT_SHIFT tools:michigan_left Tool: Michigan Left
N CMD+N CTRL system:new File: New Layer
N CMD+SHIFT+N CTRL_SHIFT tools:selectwaynodes Tool: Select Way Nodes
N META+N RESERVED(META) system:new reserved
N SHIFT+N SHIFT mapmode:alignways Mode: Align Ways
OPEN_BRACKET OPEN_BRACKET DIRECT subwindow:todo:pass Pass over element without marking it
O O DIRECT tools:aligncircle Tool: Align Nodes in Circle
O ALT+CMD+O ALT_CTRL importosmibugs Edit: Import Osm Inspector Bugs...
O ALT+CMD+O ALT_CTRL tools:mergeoverlap Tool: Merge overlap
O ALT+CMD+SHIFT+O ALT_CTRL_SHIFT tools:opening_hourseditor Tool: Edit opening hours
O ALT+O MNEMONIC menu:Commands Menu: Commands
O ALT+O MNEMONIC menu:Offset Menu: Offset
O ALT+O MNEMONIC menu:Routing Menu: Routing
O ALT+SHIFT+O ALT_SHIFT subwindow:commandstack Toggle: Command Stack
O CMD+O CTRL system:open File: Open...
O CMD+SHIFT+O CTRL_SHIFT system:download_primitive File: Download object...
O META+O RESERVED(META) system:open reserved
O SHIFT+O SHIFT tools:createcircle Tool: Create Circle
PAGE_DOWN PAGE_DOWN DIRECT geoimage:next Geoimage: Show next Image
PAGE_UP PAGE_UP DIRECT geoimage:previous Geoimage: Show previous Image
PERIOD PERIOD DIRECT audio:pause Audio: Play/Pause
PERIOD CMD+PERIOD CTRL view:zoomoutalternate Map: Zoom out
PERIOD SHIFT+PERIOD SHIFT Mapillary area Download Mapillary images in current view
PLUS PLUS DIRECT view:zoomin View: Zoom In
P P DIRECT tools:splitway Tool: Split Way
P ALT+CMD+P ALT_CTRL core_multikey:previousMarker Multikey: Previous marker
P ALT+CMD+SHIFT+P ALT_CTRL_SHIFT tools:splitonintersections Tool: Split adjacent ways
P ALT+P MNEMONIC menu:Presets Menu: Presets
P ALT+SHIFT+P, ALT_SHIFT subwindow:properties Toggle: Tags/Memberships
P CMD+P CTRL system:print File: Print...
P CMD+SHIFT+P CTRL_SHIFT system:purge Edit: Purge
P META+P RESERVED(META) system:print reserved
P SHIFT+P SHIFT mapmode:parallel Mode: Parallel
Q Q DIRECT tools:orthogonalize Tool: Orthogonalize Shape
Q ALT+CMD+Q ALT_CTRL system:closechangeset File: Closes open changesets
Q ALT+META+SHIFT+Q RESERVED(ALT+META+SHIFT) apple-reserved-44 reserved
Q ALT+Q MNEMONIC menu:Video Menu: Video
Q ALT+SHIFT+Q ALT_SHIFT plugin:roadsigns:dialog Roadsigns plugin: open dialog
Q CMD+Q CTRL system:menuexit Exit
Q META+Q RESERVED(META) system:menuexit reserved
Q META+SHIFT+Q RESERVED(META+SHIFT) apple-reserved-43 reserved
Q SHIFT+Q SHIFT tools:orthogonalizeUndo Tool: Orthogonalize Shape / Undo
RIGHT CMD+RIGHT CTRL system:movefocusright Map: Move right
RIGHT CTRL+RIGHT, RESERVED(CTRL) system:movefocusright reserved
RIGHT META+RIGHT RESERVED(META) apple-reserved-45 reserved
RIGHT SHIFT+RIGHT SHIFT core:moveright Move objects right
R R DIRECT tools:reverse Tool: Reverse Ways
R ALT+CMD+R ALT_CTRL reltoolbox:changerole Relation Toolbox: Enter role for selected members
R ALT+CMD+SHIFT+R ALT_CTRL_SHIFT subwindow:routing Toggle: Routing
R ALT+R ALT buildings_tools:rectangle Data: Set buildings shape to rectangle
R ALT+SHIFT+R ALT_SHIFT subwindow:relations Toggle: Relations
R CMD+R CTRL menu:livegps:capture Menu: Capture GPS Track
R CMD+SHIFT+R CTRL_SHIFT menu:rex Menu: Roundabout Expander
R CMD+SHIFT+R CTRL_SHIFT surveyor:open Tool: Surveyor...
R SHIFT+R SHIFT tools:tagbuffer Tool: Copy tags from previous selection
SHIFT ALT+SHIFT RESERVED(ALT) microsoft-reserved-51 reserved
SHIFT CTRL+SHIFT RESERVED(CTRL) microsoft-reserved-52 reserved
SLASH ALT+META+SLASH RESERVED(ALT+META) apple-reserved-33 reserved
SLASH SHIFT+SLASH SHIFT tools:selboundary Tool: Area boundary [testing]
SPACE SPACE DIRECT mapmode:space ConfirmObjectDrawing
SPACE ALT+META+SPACE RESERVED(ALT+META) apple-reserved-03 reserved
SPACE ALT+SPACE RESERVED(ALT) microsoft-reserved-33 reserved
SPACE CMD+SPACE CTRL help:search-items Search menu items
SPACE CTRL+META+SPACE RESERVED(CTRL+META) apple-reserved-04 reserved
SPACE META+SPACE RESERVED(META) apple-reserved-01 reserved
SPACE SHIFT+SPACE SHIFT tools:alignways Tool: Align Ways
SUBTRACT SUBTRACT DIRECT view:zoomoutkeypad View: Zoom Out (Keypad)
S S DIRECT mapmode:select Mode: Select
S ALT+CMD+SHIFT+S ALT_CTRL_SHIFT surveyor:autosave Tool: AutoSave LiveData
S ALT+CMD+S ALT_CTRL tools:sourcetag Tool: Add Source Tag
S ALT+SHIFT+S ALT_SHIFT tofix:skip tofix:Skip item
S ALT+SHIFT+S ALT_SHIFT tools:symmetry Tool: Symmetry
S ALT+S, ALT properties:edit Edit Tags
S CMD+SHIFT+S CTRL_SHIFT system:saveas File: Save As...
S CMD+SHIFT+S CTRL_SHIFT tools:replacecoastline Tool: Replace Geometry
S CMD+S CTRL system:save File: Save
S META+SHIFT+S RESERVED(META+SHIFT) system:saveas reserved
S META+S RESERVED(META) system:save reserved
S SHIFT+S SHIFT core_multikey:showHideLayer Multikey: Show/hide layer
TAB TAB DIRECT menu:view:dialogspanel Toggle dialogs panel
TAB ALT+CTRL+TAB RESERVED(ALT+CTRL) microsoft-reserved-36 reserved
TAB ALT+TAB RESERVED(ALT) microsoft-reserved-35 reserved
TAB CTRL+SHIFT+TAB RESERVED(CTRL+SHIFT) apple-reserved-09 reserved
TAB CTRL+TAB RESERVED(CTRL) apple-reserved-08 reserved
TAB META+SHIFT+TAB RESERVED(META+SHIFT) apple-reserved-07 reserved
TAB META+TAB RESERVED(META) apple-reserved-06 reserved
TAB SHIFT+TAB RESERVED(SHIFT) apple-reserved-05 reserved
T T DIRECT mapmode:KnifeTool Mode: Knife tool
T T DIRECT tools:tracer Tool: Tracer
T T DIRECT tools:tracer2 Tool: Tracer2
T T DIRECT touchscreenhelper:browse Mode: Browse map with left button
T ALT+CMD+SHIFT+T ALT_CTRL_SHIFT Tool:To-fix Toggle: Tool:To-fix
T ALT+CMD+SHIFT+T ALT_CTRL_SHIFT tools:taggingpresettester Tool: Tagging Preset Tester
T ALT+CMD+T ALT_CTRL subwindow:trustosm Toggle: Object signatures
T ALT+META+T RESERVED(ALT+META) system:toggletoolbar reserved
T ALT+SHIFT+T ALT_SHIFT subwindow:selection Toggle: Current Selection
T ALT+T MNEMONIC menu:Tools Menu: Tools
T CMD+SHIFT+T CTRL_SHIFT subwindow:todo Toggle: Todo list
T CMD+SHIFT+T CTRL_SHIFT tool:revert Tool: Revert changeset
T CMD+T CTRL gpg:download Download referenced osm objects...
T CMD+T CTRL multitag Edit: Tag multiple objects
T SHIFT+T SHIFT tools:Terracer Tool: Terrace a building
UNDEFINED NONE Export Mapillary Export Mapillary images
UNDEFINED NONE Import Mapillary Import pictures into Mapillary layer
UNDEFINED NONE Submit changeset to Mapillary Submit the current changeset to Mapillary
UNDEFINED NONE core:none No Shortcut
UNDEFINED NONE edit:mergeaddrpoints Edit: Merge address points
UNDEFINED NONE exttool:Tool name External Tool: Tool name
UNDEFINED NONE help:showstatusreport Help: Show Status Report
UNDEFINED NONE imagery:rectimg Imagery: Rectified Image...
UNDEFINED NONE mapmode:drawanglesnapping Mode: Draw Angle snapping
UNDEFINED NONE mapmode:enablewayaccuracyhelpers Mode: Enable way accuracy helpers
UNDEFINED NONE mapmode:extrudedualalign Mode: Extrude Dual alignment
UNDEFINED NONE mapmode:photoadjust Mode: Adjust photos
UNDEFINED NONE mapmode:zoom Mode: Zoom
UNDEFINED NONE opendata_open_preferences OpenData preferences
UNDEFINED NONE relationeditor:refresh Relation Editor: Refresh
UNDEFINED NONE reportbug Report a ticket to JOSM bugtracker
UNDEFINED, NONE system:copytags Edit: Copy Tags
UNDEFINED NONE tools:pasterelations Tool: Paste Relations
UP ALT+UP ALT relationeditor:moveup Relation Editor: Move Up
UP CMD+SHIFT+UP CTRL_SHIFT file:upload File: Upload data
UP CMD+UP CTRL system:movefocusup Map: Move up
UP CTRL+UP, RESERVED(CTRL) system:movefocusup reserved
UP SHIFT+UP SHIFT core:moveup Move objects up
U U DIRECT tools:customizestop Tool: Customize stop
U ALT+CMD+SHIFT+U ALT_CTRL_SHIFT file:uploadSelection File: Upload selection
U ALT+CMD+U ALT_CTRL file:updateselection File: Update selection
U ALT+SHIFT+U ALT_SHIFT tools:undelete File: Undelete object...
U ALT+U MNEMONIC menu:Audio Menu: Audio
U CMD+SHIFT+U CTRL_SHIFT subwindow:measurement Toggle: Measured values
U CMD+U CTRL file:updatedata File: Update data
U SHIFT+U SHIFT tools:unsnodes Tool: Unselect nodes
V ALT+CMD+SHIFT+V ALT_CTRL_SHIFT tools:ReverseTerrace Tool: Reverse a Terrace
V ALT+CMD+V ALT_CTRL menu:edit:pasteAtSource Edit: Paste at source position
V ALT+SHIFT+V ALT_SHIFT subwindow:validator Toggle: Validation results
V ALT+V MNEMONIC menu:View Menu: View
V CMD+SHIFT+V, CTRL_SHIFT system:pastestyle Edit: Paste Tags
V CMD+V CTRL system:paste Edit: Paste
V CTRL+V RESERVED(CTRL) system:paste reserved
V META+V RESERVED(META) system:paste reserved
V SHIFT+V SHIFT tools:validate Tool: Validation
W W DIRECT mapmode:ImproveWay Mode: Improve Way
W W DIRECT mapmode:ImproveWayAccuracy Mode: Improve Way Accuracy
W ALT+CMD+W ALT_CTRL tools:selecthighway Tool: Select Highway
W ALT+META+W RESERVED(ALT+META) system:closeallwindows reserved
W ALT+SHIFT+W ALT_SHIFT subwindow:osminspector Toggle: OSM Inspector Bugs
W ALT+W MNEMONIC menu:Windows Menu: Windows
W CMD+SHIFT+W CTRL_SHIFT waydownloader:waydownload Way Download
W CMD+W CTRL menu:view:wireframe Toggle Wireframe view
W META+SHIFT+W RESERVED(META+SHIFT) system:closefile reserved
W SHIFT+W SHIFT wayselector:wayselect Non-branching way sequences
X X DIRECT mapmode:extrude Mode: Extrude
X ALT+CMD+X ALT_CTRL file:exportsigs Export sigs to XML...
X ALT+SHIFT+X ALT_SHIFT gpxfilter:egpx Tool: Add EGPX layer
X ALT+X ALT tools:splitobject Tool: Split Object
X CMD+SHIFT+X CTRL_SHIFT tools:AddressEdit Tool: Address Edit
X CMD+SHIFT+X CTRL_SHIFT tools:pointInfo Tool: Point info
X CTRL+X RESERVED(CTRL) system:cut reserved
X META+X RESERVED(META) system:cut reserved
Y Y DIRECT tools:geotagged Tool: Display geotagged images
Y ALT+SHIFT+Y ALT_SHIFT subwindow:imagewaypoint Toggle: WayPoint Image
Y CMD+SHIFT+Y CTRL_SHIFT tools:simplifyArea Tool: Simplify Area
Y CMD+Y CTRL system:redo Edit: Redo
Y CTRL+Y RESERVED(CTRL) system:redo reserved
Y SHIFT+Y SHIFT tools:simplify Tool: Simplify Way
Z ALT+CMD+Z ALT_CTRL tools:AddressInterpolation Tool: Address Interpolation
Z ALT+SHIFT+Z ALT_SHIFT tools:selmodways Tool: Select last modified ways
Z ALT+Z ALT buildings_tools:circle Data: Set buildings shape to circle
Z CMD+SHIFT+Z CTRL_SHIFT tools:undoselection Tool: Undo selection
Z CMD+Z CTRL system:undo Edit: Undo
Z CTRL+Z RESERVED(CTRL) system:undo reserved
Z META+SHIFT+Z RESERVED(META+SHIFT) system:redo reserved
Z META+Z RESERVED(META) system:undo reserved
Z SHIFT+Z SHIFT tools:selmodnodes Tool: Select last modified nodes

If there are parsing errors they will appear below:

See also

Last modified 19 months ago Last modified on 2016-08-12T14:57:31+02:00