Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#18501 closed defect (fixed)

Combine way action refuses to combine way when some nodes are outside of the download area

Reported by: GerdP Owned by: team
Priority: normal Milestone: 19.12
Component: Core Version:
Keywords: template_report, regression Cc:

Description

What steps will reproduce the problem?

  1. Have a way with a least one node outside of the download area
  2. Try to combine this way with a new way that shares an end node which is inside the download area

What is the expected result?

Ways are combined

What happens instead?

Nothing, action "Combine way is disabled"

Please provide any additional information below. Attach a screenshot if possible.

Regression of #18083

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-12-31 14:25:24 +0100 (Tue, 31 Dec 2019)
Build-Date:2019-12-31 13:27:22
Revision:15625
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15625 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 1190 MB / 4551 MB (830 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35250)
+ PolygonCutOut (v0.7)
+ apache-commons (35092)
+ buildings_tools (35248)
+ continuosDownload (82)
+ ejml (35122)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ merge-overlap (35248)
+ o5m (35248)
+ opendata (35248)
+ pbf (35248)
+ poly (35248)
+ reverter (35248)
+ undelete (35248)
+ utilsplugin2 (35248)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (1)

18495.patch (3.6 KB) - added by GerdP 3 months ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 3 months ago by stoecker

I wouldn't consider this as bad. Technically it is unnecessary, but it trains the users not to work with stuff going outside.

comment:2 in reply to:  1 ; Changed 3 months ago by GerdP

Replying to stoecker:

I wouldn't consider this as bad. Technically it is unnecessary, but it trains the users not to work with stuff going outside.

As bad as what?

comment:3 in reply to:  2 Changed 3 months ago by stoecker

As bad as what?

As bad behaviour. Means I think it is a feature, not a bug 😼

comment:4 Changed 3 months ago by GerdP

Well, it causes trouble, see #18495. I think we should allow the combination when the shared node is either new or not outside the download area (or if there is no download area), else show a popup similar to that mentioned in ticket:18495#comment:6.

BTW: JOSM also allows to add nodes to a way at the "outside" end node. I thought this would also provoke the popup, but it doesn't.

Changed 3 months ago by GerdP

Attachment: 18495.patch added

comment:5 in reply to:  4 ; Changed 3 months ago by skyper

Replying to GerdP:

Well, it causes trouble, see #18495. I think we should allow the combination when the shared node is either new or not outside the download area (or if there is no download area), else show a popup similar to that mentioned in ticket:18495#comment:6.

+1 for combining when shared node is within download area but be careful with new nodes as unglueing makes it easy to create dangerous nodes with id:0.

BTW: JOSM also allows to add nodes to a way at the "outside" end node. I thought this would also provoke the popup, but it doesn't.

New ticket ?

comment:6 Changed 3 months ago by Don-vip

Milestone: 20.01

comment:7 Changed 3 months ago by anonymous

Ticket #18506 has been marked as a duplicate of this ticket.

comment:8 Changed 3 months ago by GerdP

Resolution: fixed
Status: newclosed

In 15628/josm:

fix #18501 and #18495 : revert changes from r15617

comment:9 Changed 3 months ago by Klumbumbus

Milestone: 20.0119.12

comment:10 in reply to:  5 Changed 3 months ago by skyper

Replying to skyper:

Replying to GerdP:

BTW: JOSM also allows to add nodes to a way at the "outside" end node. I thought this would also provoke the popup, but it doesn't.

New ticket ?

See #18515

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.