Modify

Opened 14 months ago

Closed 10 months ago

Last modified 4 months ago

#18083 closed defect (fixed)

Combine way: No warning about data outside of download area

Reported by: skyper Owned by: team
Priority: normal Milestone: 20.01
Component: Core Version: latest
Keywords: template_report combine way download area Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Have two ways, connected at end nodes, with at least one way completely outside download area.
  2. combine the ways

What is the expected result?

A warning about combining ways outside of download area. Similar to the one about deleting nodes outside download area.

What happens instead?

No warning

Please provide any additional information below. Attach a screenshot if possible.

Mark this as defect as it is easy to damage relations this way, as they might not have been downloaded at all.

see #17400 and #18084 for the same problem with split way

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-08-26 08:55:27 +0200 (Mon, 26 Aug 2019)
Build-Date:2019-08-26 06:57:10
Revision:15322
Relative:URL: ^/trunk

Attachments (2)

josm_18083_sample.osm (5.1 KB) - added by skyper 13 months ago.
sample file
18083.patch (1.1 KB) - added by GerdP 10 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 14 months ago by skyper

Description: modified (diff)

comment:2 Changed 13 months ago by Don-vip

can you please attach a sample .osm file?

Changed 13 months ago by skyper

Attachment: josm_18083_sample.osm added

sample file

comment:3 Changed 13 months ago by skyper

Description: modified (diff)

See attached file.

Simply, combine the two ways.

I usually get in these kind of situations when downloading selected incomplete members within the relation manager.

comment:4 Changed 12 months ago by mdk

There is also a bigger problem when the way outside the download area belongs to a relation (see #6914). In this case these relations may not be loaded. If this way is deleted during combine, there will be conflicts on upload, because the relations still reference the deleted way.

comment:5 Changed 10 months ago by GerdP

The current code ignores incomplete ways in the selection. It would be easy to do the same for ways with nodes outside the download area. So, action would be disabled when the selection contains fewer than two ways which are complete and not outside. If C is pressed only the "good" ways are used for combine.
For a warning we would enable the action when two or more complete ways are selected and show a popup if any of them has nodes outside the download area.
Or maybe a mixture of both solutions?

Changed 10 months ago by GerdP

Attachment: 18083.patch added

comment:6 Changed 10 months ago by GerdP

Milestone: 19.12

The patch implements the "easy" and silent change.

comment:7 Changed 10 months ago by GerdP

Resolution: fixed
Status: newclosed

In 15617/josm:

fix #18083: Combine way: No warning about data outside of download area
Ignore ways with nodes outside download area so that action is disabled when the selection doesn't contain enough "good" ways.

comment:8 Changed 10 months ago by GerdP

See #18495 which shows a regression.
I fear my change was too agressive. You described the rather unlikely case that one way is completely outside of the download area. My change rejects ways with one or more nodes outside the download area. This happens quite often and I see no problem when we allow the combination.

comment:9 Changed 10 months ago by GerdP

See also #18501

comment:10 in reply to:  7 Changed 10 months ago by skyper

Resolution: fixed
Status: closedreopened

Replying to GerdP:

In 15617/josm:

fix #18083: Combine way: No warning about data outside of download area
Ignore ways with nodes outside download area so that action is disabled when the selection doesn't contain enough "good" ways.

Reopen as this change was reverted with r15628.

comment:11 Changed 10 months ago by Klumbumbus

Milestone: 19.1220.01

move milestone, feel free to remove instead

comment:12 Changed 10 months ago by GerdP

Resolution: fixed
Status: reopenedclosed

In 15681/josm:

fix #18083 (again): Don't combine ways when the shared node is old and outside of the download area. If that happens, show a notification "Combine ways refused. (A shared node is outside of the download area)"
Please suggest a better message text.

comment:13 Changed 4 months ago by skyper

See #19394 for a follow-up and an unexpected behavior: comment 2.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.