Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#17629 closed enhancement (fixed)

complain about more descriptive names and propose to delete them [PATCH]

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 19.04
Component: Core validator Version:
Keywords: template_report Cc: stoecker

Description (last modified by mkoniecz)

Patch: https://josm.openstreetmap.de/ticket/17629#comment:20

What steps will reproduce the problem?

  1. Create amenity=restaurant name=Restaurant
  2. Create amenity=place_of_worship religion=muslim name=Mosque
  3. Create amenity=toilets name=Toilet
  4. Run validator

What is the expected result?

Validator complains about descriptive names and offers to remove them

What happens instead?

Nothing

Please provide any additional information below. Attach a screenshot if possible.

http://overpass-turbo.eu/s/I7p http://overpass-turbo.eu/s/I7r http://overpass-turbo.eu/s/I7t

Next part of https://josm.openstreetmap.de/ticket/17100

To be added in https://josm.openstreetmap.de/browser/josm/trunk/data/validator/unnecessary.mapcss#L93

Spotted in https://github.com/osmlab/name-suggestion-index/blob/master/dist/names_discard.json (note that this file list both generic and nonbrand names, not all of the should be purged)

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-03 00:33:43 +0200 (Wed, 03 Apr 2019)
Build-Date:2019-04-03 01:30:50
Revision:14954
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14954 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 435 MB / 869 MB (102 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34867)
+ buildings_tools (34904)
+ continuosDownload (82)
+ imagery_offset_db (34867)
+ measurement (34867)
+ reverter (34961)
+ todo (30306)

Validator rules:
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/deprecated.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/combinations.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (0)

Change History (24)

comment:1 Changed 6 months ago by mkoniecz

Summary: complain about more descriptive namescomplain about more descriptive names and propose to delete them

comment:2 Changed 6 months ago by mkoniecz

Description: modified (diff)

comment:3 Changed 6 months ago by mkoniecz

BTW, I see also amenity=place_of_worship name=Church, Cami that seems to mean "mosque" in Turkish and used 1500+ in Turkey as a descriptive name - see http://overpass-turbo.eu/s/I7u

1500 Biserica meaning "church" in Romanian used for amenity=place_of_worship

3000+ amenity=pharmacy name=Аптека

comment:4 Changed 6 months ago by Don-vip

List of suspicious names used more than 2000 times to check:

comment:5 Changed 6 months ago by mkoniecz

​Cmentarz parafialny: 2479 "Parish cemeteries" in Polish?

This is a borderline thing. In some places this is a valid name (in places where there are multiple cemeteries), is some places it is on border of description and actual name, in some places it is a descriptive name.

Kwiatowa, Spacerowa, Zielona, Sportowa, Wiejska, Sosnowa, Wiejska, Łąkowa, Parkowa, Kolejowa, Ogrodowa, Kościelna are all popular street names in Poland. These names are not going to be used as decriptive names due to a grammar form. I am pretty sure that after excluding highway=* usage will drop to nearly 0.

Rynek is for market square, and many of them have it now as the official street name.

name=building is already caught on building=* - see https://josm.openstreetmap.de/browser/josm/trunk/data/validator/unnecessary.mapcss#L97
The same with house, rumah, jalan

Updated lists:

List of suspicious names used more than 2000 times to check:

ones not listed in the list above:

  • amenity=place_of_worship name=Church
  • Cami that seems to mean "mosque" in Turkish and used 1500+ in Turkey as a descriptive name - see ​http://overpass-turbo.eu/s/I7u
  • 1500 Biserica meaning "church" in Romanian used for amenity=place_of_worship
  • amenity=restaurant name=Restaurant
  • amenity=place_of_worship religion=muslim name=Mosque
  • amenity=toilets name=Toilet
Last edited 6 months ago by mkoniecz (previous) (diff)

comment:6 Changed 6 months ago by mkoniecz

List of suspicious names used more than 2000 times to check:

And thank you very much for preparing this list!

comment:7 Changed 6 months ago by mkoniecz

https://github.com/matkoniecz/josm/tree/descriptive has patch, currently at https://github.com/matkoniecz/josm/commit/48bf590c25a0e146921fd4306e4a4b9bfb8e13ce.patch

It removes entries that I initially reported and Pond, all only from objects where this name is both descriptive and provides no additional info.

Equivalent in iD - https://github.com/openstreetmap/iD/issues/6055#issuecomment-485131822

Last edited 6 months ago by mkoniecz (previous) (diff)

comment:8 Changed 6 months ago by mkoniecz

Description: modified (diff)
Summary: complain about more descriptive names and propose to delete themcomplain about more descriptive names and propose to delete them [PATCH]

comment:9 Changed 6 months ago by mkoniecz

After this patch is processed I plan to look again at remaining entries, consult with local communities in cases that are not obvious and make the next patch.

comment:10 Changed 6 months ago by Don-vip

Milestone: 19.04

comment:11 Changed 6 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 15005/josm:

fix #17629 - complain about more descriptive names and propose to delete them

comment:12 Changed 6 months ago by mkoniecz

Description: modified (diff)

comment:13 Changed 6 months ago by mkoniecz

@Don-vip Are you sure about Rathaus? In Poland removal of name=Ratusz (translates to the same) would be incorrect in many cases, it is often actually a name, even on building=townhall or amenity=townhall.

Last edited 6 months ago by mkoniecz (previous) (diff)

comment:14 Changed 6 months ago by mkoniecz

Description: modified (diff)

comment:15 in reply to:  13 ; Changed 6 months ago by Don-vip

Cc: stoecker added

Replying to mkoniecz:

@Don-vip Are you sure about Rathaus? In Poland removal of name=Ratusz (translates to the same) would be incorrect in many cases, it is often actually a name, even on building=townhall.

Not sure. Dirk?

comment:16 in reply to:  15 Changed 6 months ago by stoecker

Replying to Don-vip:

Replying to mkoniecz:

@Don-vip Are you sure about Rathaus? In Poland removal of name=Ratusz (translates to the same) would be incorrect in many cases, it is often actually a name, even on building=townhall.

Not sure. Dirk?

I'm not sure. Our "Rathaus" was always only Rathaus to me. It's a descriptive name, but nevertheless its also a real name. Everybody in our town will know what's meant with "Rathaus" :-)

comment:17 Changed 6 months ago by Klumbumbus

I would rather not warn about "Rathaus" as this is a controversial case. Rathaus is the function (townhall) but I "feel" it also kind of the name of the building as it was usually built for this purpose.
Better avoid some false positives. We will never catch all descriptive names with our validator anyway and this is probably not the goal anyway. More like warning the user from time to time about descriptive names to train/educate him to not use descriptives names in general.

comment:18 Changed 6 months ago by Don-vip

OK. I'll also remove "Mairie" then. I'm not sure everyone would agree to remove them (same issue).

Last edited 6 months ago by Don-vip (previous) (diff)

comment:19 Changed 6 months ago by Don-vip

@mkoniecz: can you please include the removal for amenity=townhall in your patch?

comment:20 Changed 6 months ago by mkoniecz

@mkoniecz: can you please include the removal for amenity=townhall in your patch?

@Don-vip done:

https://github.com/matkoniecz/josm/commit/ece30bb3075c906120d74c52529108949976115e.patch from https://github.com/matkoniecz/josm/tree/descriptive

Better avoid some false positives. We will never catch all descriptive names with our validator anyway and this is probably not the goal anyway. More like warning the user from time to time about descriptive names to train/educate him to not use descriptives names in general.

There are far more languages to catch even all variations of "house", "church", "mosque".

Education of mappers and helping in removal of ones that are extremely widespread is more than enough. For rare descriptive names is it not worth the effort to add a validator rule.

Last edited 6 months ago by mkoniecz (previous) (diff)

comment:21 Changed 6 months ago by mkoniecz

Description: modified (diff)

comment:22 Changed 6 months ago by mkoniecz

What about Waldweg Feldweg? Both are quite popular and unwanted descriptive names according to https://wiki.openstreetmap.org/wiki/File:Tracks_with_descriptive_name_tags.png

Is it safe to always remove them highway=track, highway=footway, highway=path?

comment:23 in reply to:  20 Changed 6 months ago by Klumbumbus

Replying to mkoniecz:

Education of mappers and helping in removal of ones that are extremely widespread is more than enough. For rare descriptive names is it not worth the effort to add a validator rule.

Yes. Thats what I said/meant.

comment:24 in reply to:  22 Changed 6 months ago by Klumbumbus

Replying to mkoniecz:

What about Waldweg Feldweg? Both are quite popular and unwanted descriptive names according to https://wiki.openstreetmap.org/wiki/File:Tracks_with_descriptive_name_tags.png

They could be misused as descriptive names but they are also official street names sometimes, so we shouldn't warn.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.