Modify

Opened 3 years ago

Closed 3 years ago

#14180 closed defect (fixed)

Crash after downloading

Reported by: nereocystis Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version:
Keywords: template_report javabug Cc: chkalch

Description

What steps will reproduce the problem?

  1. Download "wine on piedmont, oakland, ca"
  2. josm complains about bug

What is the expected result?

no complaint

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-12-31 17:39:03 +0100 (Sat, 31 Dec 2016)
Build-Date:2017-01-01 02:33:05
Revision:11425
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11425 en) Linux Ubuntu 16.10
Memory Usage: 366 MB / 1680 MB (257 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1680x1050
Maximum Screen Size: 1680x1050
Dataset consistency test: No problems found

Plugins:
+ auto_tools (1479831713)
+ buildings_tools (33004)
+ utilsplugin2 (33088)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: Update plugins - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- E: java.lang.NullPointerException: Failed to retrieve atom name.
- E: java.lang.NullPointerException: Failed to retrieve atom name.
- E: Handled by bug report queue: java.lang.NullPointerException: Failed to retrieve atom name.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NullPointerException: Failed to retrieve atom name.
	at sun.awt.X11.XlibWrapper.XGetAtomName(Native Method)
	at sun.awt.X11.XAtom.getName(XAtom.java:186)
	at sun.awt.X11.XDataTransferer.getTargetNameForAtom(XDataTransferer.java:165)
	at sun.awt.X11.XDataTransferer.getNativeForFormat(XDataTransferer.java:154)
	at sun.awt.datatransfer.DataTransferer.getFlavorsForFormatsAsSet(DataTransferer.java:812)
	at sun.awt.datatransfer.SunClipboard.formatArrayAsDataFlavorSet(SunClipboard.java:347)
	at sun.awt.datatransfer.SunClipboard.isDataFlavorAvailable(SunClipboard.java:190)
	at org.openstreetmap.josm.plugins.utilsplugin2.actions.PasteRelationsAction.updateEnabledState(PasteRelationsAction.java:113)
	at org.openstreetmap.josm.actions.JosmAction$SelectionChangeAdapter.selectionChanged(JosmAction.java:383)
	at org.openstreetmap.josm.data.osm.DataSet.fireSelectionChanged(DataSet.java:600)
	at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:788)
	at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:799)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.selectPrims(SelectAction.java:969)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mousePressed(SelectAction.java:443)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:280)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:279)
	at java.awt.Component.processMouseEvent(Component.java:6530)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4522)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by anonymous

When I experienced the problem, the item had an addr:housenumber, but no associatedStreet.

When I added the associatedStreet, the problem went away.

comment:2 Changed 3 years ago by Don-vip

Component: CorePlugin utilsplugin2

comment:3 Changed 3 years ago by skyper

Still old good javabug:6322854, see #8404, #11093, #11485, #13441, #12763 ?

comment:4 Changed 3 years ago by Don-vip

Yes, the plugin needs the same workaround as the one implemented in JOSM core.

comment:5 Changed 3 years ago by skyper

Keywords: javabug added

comment:6 Changed 3 years ago by skyper

Ticket #14269 has been marked as a duplicate of this ticket.

comment:7 Changed 3 years ago by skyper

Cc: chkalch added

comment:8 Changed 3 years ago by Don-vip

Ticket #14286 has been marked as a duplicate of this ticket.

comment:9 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33123:33125].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.