Modify

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#11485 closed defect (fixed)

NPE: Failed to retrieve atom name

Reported by: naoliv Owned by: team
Priority: normal Milestone: 15.05
Component: Core Version:
Keywords: javabug npe linux x11 Cc:

Description

I pressed Alt+A and got this:

Atom was 0
ERRO: java.lang.NullPointerException: Failed to retrieve atom name.
java.lang.NullPointerException: Failed to retrieve atom name.
	at sun.awt.X11.XlibWrapper.XGetAtomName(Native Method)
	at sun.awt.X11.XAtom.getName(XAtom.java:186)
	at sun.awt.X11.XDataTransferer.getTargetNameForAtom(XDataTransferer.java:166)
	at sun.awt.X11.XDataTransferer.getNativeForFormat(XDataTransferer.java:155)
	at sun.awt.datatransfer.DataTransferer.getFlavorsForFormats(DataTransferer.java:804)
	at sun.awt.datatransfer.ClipboardTransferable.<init>(ClipboardTransferable.java:89)
	at sun.awt.X11.XClipboard.getContents(XClipboard.java:106)
	at org.openstreetmap.josm.gui.tagging.ac.AutoCompletingComboBox$AutoCompletingComboBoxDocument.insertString(AutoCompletingComboBox.java:137)
	at javax.swing.text.AbstractDocument.replace(AbstractDocument.java:670)
	at javax.swing.text.JTextComponent.setText(JTextComponent.java:1718)
	at javax.swing.plaf.metal.MetalComboBoxEditor$1.setText(MetalComboBoxEditor.java:61)
	at javax.swing.plaf.basic.BasicComboBoxEditor.setItem(BasicComboBoxEditor.java:82)
	at org.openstreetmap.josm.gui.tagging.ac.AutoCompletingComboBox.configureEditor(AutoCompletingComboBox.java:233)
	at javax.swing.plaf.basic.BasicComboBoxUI$Handler.contentsChanged(BasicComboBoxUI.java:1861)
	at javax.swing.AbstractListModel.fireContentsChanged(AbstractListModel.java:118)
	at javax.swing.DefaultComboBoxModel.setSelectedItem(DefaultComboBoxModel.java:93)
	at javax.swing.JComboBox.setSelectedItem(JComboBox.java:578)
	at org.openstreetmap.josm.gui.tagging.ac.AutoCompletingComboBox.setSelectedItem(AutoCompletingComboBox.java:247)
	at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper$AddTagsDialog.<init>(TagEditHelper.java:585)
	at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper.addTag(TagEditHelper.java:132)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog$AddAction.actionPerformed(PropertiesDialog.java:1012)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1662)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2870)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:263)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2962)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2954)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2833)
	at java.awt.Component.processEvent(Component.java:6293)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1887)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:762)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1027)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:899)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:727)
	at java.awt.Component.dispatchEventImpl(Component.java:4742)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

JOSM

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-05-26 01:31:54
Last Changed Author: Don-vip
Revision: 8426
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-05-26 01:37:50 +0200 (Tue, 26 May 2015)
Last Changed Rev: 8426

Identification: JOSM/1.5 (8426 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 1525 MB / 10206 MB (603 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-2
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (30892)
- OpeningHoursEditor (30962)
- PicLayer (31114)
- SimplifyArea (30962)
- buildings_tools (31120)
- conflation (0.1.7)
- contourmerge (1013)
- download_along (30892)
- editgpx (30892)
- geotools (31068)
- importvec (30892)
- jts (31002)
- log4j (30892)
- measurement (30892)
- merge-overlap (30988)
- opendata (31116)
- pbf (31010)
- pdfimport (30892)
- poly (31056)
- reverter (31120)
- scripting (30710)
- todo (29154)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31153)

I can't reproduce it again.

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by Don-vip

Keywords: javabug npe linux added
Milestone: 15.05

It's javabug:6322854 again. We probably need to implement the workaround of r5752 / r8038 for another widget.

comment:2 Changed 5 years ago by Don-vip

Am I right if assume the bug occurred right after you pasted a key/value?

comment:3 Changed 5 years ago by naoliv

I had a lot of data in JOSM, if this makes some difference.
With a node selected, pressed Alt+A and started typying p and l (to type place). Since it was a little slow (due to the amount of data) it seems that I pressed pl before the dialog was available (and then the error occurred)

comment:4 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8429/josm:

fix #11485 - robustness to JDK-6322854 when dealing with system selection

comment:5 Changed 3 years ago by Don-vip

Keywords: x11 added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.