Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11484 closed enhancement (fixed)

Should group "missing name" validation results

Reported by: naoliv Owned by: team
Priority: normal Milestone: 15.05
Component: Core validator Version:
Keywords: Cc:

Description

The "missing name" test isn't grouping all its problems inside one category (since the name is being used in the info message):
http://i.imgur.com/HOALJBi.png

Shouldn't the name be excluded from the message?

JOSM

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-05-26 01:31:54
Last Changed Author: Don-vip
Revision: 8426
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-05-26 01:37:50 +0200 (Tue, 26 May 2015)
Last Changed Rev: 8426

Identification: JOSM/1.5 (8426 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 1010 MB / 10206 MB (521 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-2
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (30892)
- OpeningHoursEditor (30962)
- PicLayer (31114)
- SimplifyArea (30962)
- buildings_tools (31120)
- conflation (0.1.7)
- contourmerge (1013)
- download_along (30892)
- editgpx (30892)
- geotools (31068)
- importvec (30892)
- jts (31002)
- log4j (30892)
- measurement (30892)
- merge-overlap (30988)
- opendata (31116)
- pbf (31010)
- pdfimport (30892)
- poly (31056)
- reverter (31120)
- scripting (30710)
- todo (29154)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31153)

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by naoliv

The same for Very long segment of XX kilometers

comment:2 Changed 6 years ago by Klumbumbus

kind of a regression of r8239.

I think the individual name after name:*= helps to better understand the error message.

Are there real use cases where you get a lot of these errors, or was the screenshot created with a overpass extract which specialized on these error types?

comment:3 Changed 6 years ago by Klumbumbus

Same question for Very long segment of XX kilometers

comment:4 Changed 6 years ago by naoliv

Both are real with what I work (but maybe I am not a good example of a JOSM user, since usually I work with big areas or a lot of data).
Sorting them could help a lot (#11072; I usually see the Missing name and Very long segment messages inserted between the other warnings) or, if possible, could they be displayed in another level?

For example:

Warnings
  |_ Something A
  |_ Something B
  |_ Very long segments
    |_ segment of 10 kilometers
    |_ segment of 15 kilometers
    |_ segment of XX kilometers
  |_ Something C
  |_ Missing names
    |_ add tag with correct language key in name:*=Foo
    |_ add tag with correct language key in name:*=Bar
  |_ …

comment:5 Changed 6 years ago by Don-vip

Milestone: 15.05
Type: defectenhancement

comment:6 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8455/josm:

fix #11484 - group "missing name" and "long segments" validation results

comment:7 Changed 6 years ago by Don-vip

In 8458/josm:

see #11484 - update unit test

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.