Modify

Opened 9 years ago

Closed 9 years ago

Last modified 5 years ago

#8404 closed defect (fixed)

crash when inserting password from clipboard into authentication dialog

Reported by: pavel.nedr@… Owned by: pavel.nedr@…
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report javabug x11 linux Cc: muh

Description

What steps will reproduce the problem?

  1. edit a map
  2. open "send changes to server" dialog, enter comment
  3. press "send changes to server"
  4. josm asks about login and password from osm opening authentication dialog
  5. copy password to clipboard from third-party software (keepass)
  6. insert password into josm dialog by pressing ctrl-v or shift-ins (right-click don't working at all)
  7. displaying error message (authentication dialog stays on front)

! Same problem occurs in Settings dialog !

What is the expected result?

  • ctrl-v - ok - authentification done

What happens instead?

  • crash

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-02-06 02:31:34
Last Changed Author: Don-vip
Revision: 5697
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-02-06 01:35:48 +0100 (Wed, 06 Feb 2013)
Last Changed Rev: 5697

Identification: JOSM/1.5 (5697 ru)
Memory Usage: 149 MB / 876 MB (59 MB allocated, but free)
Java version: 1.7.0_09-icedtea, Oracle Corporation, OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: DirectUpload (29210)
Plugin: editgpx (29210)
Plugin: openstreetbugs (29210)
Plugin: reltoolbox (29210)
Plugin: reverter (29216)
Plugin: turnlanes (29210)

java.lang.NullPointerException: Failed to retrieve atom name.
	at sun.awt.X11.XlibWrapper.XGetAtomName(Native Method)
	at sun.awt.X11.XAtom.getName(XAtom.java:186)
	at sun.awt.X11.XDataTransferer.getTargetNameForAtom(XDataTransferer.java:166)
	at sun.awt.X11.XDataTransferer.getNativeForFormat(XDataTransferer.java:155)
	at sun.awt.datatransfer.DataTransferer.getFlavorsForFormats(DataTransferer.java:804)
	at sun.awt.datatransfer.ClipboardTransferable.<init>(ClipboardTransferable.java:89)
	at sun.awt.X11.XClipboard.getContents(XClipboard.java:106)
	at javax.swing.TransferHandler$TransferAction.actionPerformedImpl(TransferHandler.java:1747)
	at javax.swing.TransferHandler$TransferAction.access$700(TransferHandler.java:1684)
	at javax.swing.TransferHandler$TransferAction$1.run(TransferHandler.java:1707)
	at javax.swing.TransferHandler$TransferAction$1.run(TransferHandler.java:1705)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at javax.swing.TransferHandler$TransferAction$2.run(TransferHandler.java:1722)
	at javax.swing.TransferHandler$TransferAction$2.run(TransferHandler.java:1720)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.TransferHandler$TransferAction.actionPerformed(TransferHandler.java:1719)
	at javax.swing.text.JTextComponent.invokeAction(JTextComponent.java:1513)
	at javax.swing.text.JTextComponent.paste(JTextComponent.java:1491)
	at javax.swing.text.DefaultEditorKit$PasteAction.actionPerformed(DefaultEditorKit.java:1363)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1661)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2870)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2917)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2833)
	at java.awt.Component.processEvent(Component.java:6282)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1895)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:762)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1027)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:899)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:727)
	at java.awt.Component.dispatchEventImpl(Component.java:4731)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:729)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:702)
	at java.awt.EventQueue$4.run(EventQueue.java:700)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:699)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:155)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1077)
	at java.awt.Component.show(Component.java:1651)
	at java.awt.Component.setVisible(Component.java:1603)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1003)
	at org.openstreetmap.josm.gui.io.CredentialDialog.setVisible(CredentialDialog.java:80)
	at org.openstreetmap.josm.io.auth.AbstractCredentialsAgent$1.run(AbstractCredentialsAgent.java:56)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:241)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:727)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:697)
...<snip>...

Attachments (1)

снимок3.png (913.8 KB) - added by anonymous 9 years ago.
screenshot

Download all attachments as: .zip

Change History (21)

Changed 9 years ago by anonymous

Attachment: снимок3.png added

screenshot

comment:1 Changed 9 years ago by Don-vip

Looks like a JDK bug (http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6322854) already encoutered by Netbeans (https://netbeans.org/bugzilla/show_bug.cgi?id=126145). Netbeans seems to have included a workaround we should try to report to JOSM.

comment:2 Changed 9 years ago by Don-vip

Question: are you running Synergy ? (http://synergy-foss.org)

comment:3 Changed 9 years ago by Don-vip

If yes, what version ? It looks like this bug in Synergy http://synergy-foss.org/spit/issues/details/26/ and fixed in version 1.3.6.

comment:4 Changed 9 years ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

comment:5 Changed 9 years ago by Don-vip

Reporter: changed from anonymous to pavel.nedr@…

comment:6 Changed 9 years ago by Don-vip

Owner: changed from anonymous to pavel.nedr@…

comment:7 Changed 9 years ago by Don-vip

Up ? Without answer from you I will assume this is caused by this Synergy bug and close this ticket as "othersoftware".

comment:8 Changed 9 years ago by pavel.nedr@…

Hi,
no, i don't use synergy (and don't know about it)

comment:9 Changed 9 years ago by Don-vip

Damn :( Can you tell me more about your system and installed applications ? Looks like you are the only one affected by this bug, the more info we have the more likely we can help you.

comment:10 Changed 9 years ago by anonymous

Yes, I can, but after 10th March (I'm on vacation now)

comment:11 Changed 9 years ago by Don-vip

ok no problem :)

comment:12 Changed 9 years ago by Don-vip

Ticket #7500 has been marked as a duplicate of this ticket.

comment:13 Changed 9 years ago by Don-vip

Cc: muh added

From #7500:

This exception. After copying the pw into a text-editor and re-copying it to the clipboard and then to JOSM everything works fine. I suppose it's related to the way KeePass 2 (based on Mono) copies the pw to the clipboard.
Please provide any additional information below. Attach a screenshot if possible.
KeePass 2.16, Linux Mint Debian (= Debian testing), kernel 3.0.0-1-amd64

@pavel: Are you using KeePass ? EDIT: I've read again the ticket, sorry So it's definitively KeePass' fault. What version are you using ?
@muh: Still have this problem ?

Last edited 9 years ago by Don-vip (previous) (diff)

comment:14 Changed 9 years ago by Don-vip

Mmm there's nothing we can do except catch the NPE and ignore the error. That's what Netbeans guys did.

comment:15 Changed 9 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

In 5752/josm:

fix #8404 - workaround for JDK bug 6322854 (crash when inserting password from clipboard corrupted by KeePass)

comment:16 Changed 8 years ago by anonymous

Still an issue.

$lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise

$ uname -rsv
Linux 3.2.0-54-generic #82-Ubuntu SMP Tue Sep 10 20:08:42 UTC 2013

JOSM version 6238

comment:17 Changed 7 years ago by Don-vip

Not really fixed, it happened again in #11093

comment:18 Changed 6 years ago by Don-vip

Keywords: javabug added

comment:19 Changed 5 years ago by Don-vip

Keywords: x11 added

comment:20 Changed 5 years ago by Don-vip

Keywords: linux added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain pavel.nedr@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.