Modify

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#11093 closed defect (fixed)

NPE when logging in

Reported by: michaelinredhill Owned by: michaelinredhill
Priority: normal Milestone: 15.02
Component: Core Version: tested
Keywords: template_report javabug npe clipboard x11 linux Cc:

Description

What steps will reproduce the problem?

  1. Load tracklog, & download surrounding area
  2. Update map & attempt to upload
  3. warned of errors & correct them.
  4. Login dialog appears.
  5. Enter details & attempt to login

What is the expected result?

successfully login.

What happens instead?

Program abends & asks me to report the bug.

Please provide any additional information below. Attach a screenshot if possible.

Revision: 7995
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-01-31 15:17:59 +0100 (Sat, 31 Jan 2015)
Build-Date: 2015-02-01 02:33:54
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7995

Identification: JOSM/1.5 (7995 en_GB) Linux Mint 17.1 Rebecca
Memory Usage: 240 MB / 1305 MB (64 MB allocated, but free)
Java version: 1.8.0_31, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found


Last errors/warnings:
- E: Failed to locate image 'Waypoint'
- E: Failed to locate image 'Waypoint'
- E: Failed to locate image 'Waypoint'
- E: java.lang.NullPointerException: Failed to retrieve atom name.
- E: java.lang.NullPointerException: Failed to retrieve atom name.

java.lang.NullPointerException: Failed to retrieve atom name.
	at sun.awt.X11.XlibWrapper.XGetAtomName(Native Method)
	at sun.awt.X11.XAtom.getName(XAtom.java:186)
	at sun.awt.X11.XDataTransferer.getTargetNameForAtom(XDataTransferer.java:164)
	at sun.awt.X11.XDataTransferer.getNativeForFormat(XDataTransferer.java:153)
	at sun.awt.datatransfer.DataTransferer.getFlavorsForFormats(DataTransferer.java:735)
	at sun.awt.datatransfer.ClipboardTransferable.<init>(ClipboardTransferable.java:90)
	at sun.awt.X11.XClipboard.getContents(XClipboard.java:108)
	at javax.swing.TransferHandler$TransferAction.actionPerformedImpl(TransferHandler.java:1755)
	at javax.swing.TransferHandler$TransferAction.access$800(TransferHandler.java:1692)
	at javax.swing.TransferHandler$TransferAction$1.run(TransferHandler.java:1715)
	at javax.swing.TransferHandler$TransferAction$1.run(TransferHandler.java:1713)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86)
	at javax.swing.TransferHandler$TransferAction$2.run(TransferHandler.java:1730)
	at javax.swing.TransferHandler$TransferAction$2.run(TransferHandler.java:1728)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at javax.swing.TransferHandler$TransferAction.actionPerformed(TransferHandler.java:1727)
	at javax.swing.text.JTextComponent.invokeAction(JTextComponent.java:1462)
	at javax.swing.text.JTextComponent.paste(JTextComponent.java:1440)
	at javax.swing.text.DefaultEditorKit$PasteAction.actionPerformed(DefaultEditorKit.java:1363)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1663)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2880)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2927)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2843)
	at java.awt.Component.processEvent(Component.java:6302)
	at java.awt.Container.processEvent(Container.java:2234)
	at java.awt.Component.dispatchEventImpl(Component.java:4881)
	at java.awt.Container.dispatchEventImpl(Container.java:2292)
	at java.awt.Component.dispatchEvent(Component.java:4703)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:806)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1074)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:945)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:771)
	at java.awt.Component.dispatchEventImpl(Component.java:4752)
	at java.awt.Container.dispatchEventImpl(Container.java:2292)
	at java.awt.Window.dispatchEventImpl(Window.java:2739)
	at java.awt.Component.dispatchEvent(Component.java:4703)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:751)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:702)
	at java.awt.EventQueue$3.run(EventQueue.java:696)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:724)
	at java.awt.EventQueue$4.run(EventQueue.java:722)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:721)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:109)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:184)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:229)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:227)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:227)
	at java.awt.Dialog.show(Dialog.java:1084)
	at java.awt.Component.show(Component.java:1654)
	at java.awt.Component.setVisible(Component.java:1606)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.io.CredentialDialog.setVisible(CredentialDialog.java:80)
	at org.openstreetmap.josm.io.auth.AbstractCredentialsAgent$1.run(AbstractCredentialsAgent.java:58)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:301)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:749)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:702)
	at java.awt.EventQueue$3.run(EventQueue.java:696)
...<snip>...

Attachments (0)

Change History (9)

comment:1 Changed 5 years ago by Klumbumbus

Summary: Abend when logging inNPE when logging in

comment:2 Changed 5 years ago by skyper

Looks like a java bug, similar to #9771.

Does it happen all the time ?

Please, try to install java 1.7 a long side 1.8 and use update-alternatives or a local script to start JOSM with java 1.7

comment:3 Changed 5 years ago by Don-vip

Keywords: javabug npe clipboard added

It looks like to be again javabug:6322854

I implemented a workaround for it in r5752 to fix #8404 but it looks like something still must be done.

comment:4 in reply to:  2 Changed 5 years ago by Don-vip

Replying to skyper:

Please, try to install java 1.7

It won't help, this bug affects all versions of Java.

comment:5 Changed 5 years ago by Don-vip

Owner: changed from team to michaelinredhill
Status: newneedinfo

@michaelinredhill: did you paste something (your login or your password) just before the crash?

comment:6 Changed 5 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

In 8038/josm:

fix #11093 - workaround for Java bug JDK-6322854 in JosmTextField. Use it in CredentialDialog

comment:7 Changed 5 years ago by Don-vip

Milestone: 15.02

comment:8 Changed 3 years ago by Don-vip

Keywords: x11 added

comment:9 Changed 3 years ago by Don-vip

Keywords: linux added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain michaelinredhill.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.