Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12979 closed defect (fixed)

Error while opening an WMS layer

Reported by: dido Owned by: dido
Priority: major Milestone: 16.06
Component: Core imagery Version:
Keywords: template_report jcs cache Cc:

Description

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 en) Windows 7 64-Bit
Memory Usage: 566 MB / 910 MB (384 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- CommandLine (32158)
- SeaMapEditor (31926)
- continuosDownload (44)
- measurement (32158)
- poly (32158)
- reverter (32158)
- turnrestrictions (32158)

Tagging presets:
- E:\m<user.name>pping\BG_Mount<user.name>ins\TYP\JOSM\bgmpresets.xml

Map paint styles:
- E:\m<user.name>pping\BG_Mount<user.name>ins\TYP\JOSM\BGMount<user.name>ins.m<user.name>pcss

Last errors/warnings:
- E: F<user.name>iled to loc<user.name>te im<user.name>ge ''
- W:  Туристически обекти: Could not get presets icon 
- E: F<user.name>iled to loc<user.name>te im<user.name>ge ''
- W:  Бариери: Could not get presets icon 
- E: j<user.name>v<user.name>.l<user.name>ng.Illeg<user.name>lArgumentException: Neg<user.name>tive position

OSM API: http://bgm.uni-plovdiv.net:40158/api

java.lang.IllegalArgumentException: Negative position
	at sun.nio.ch.FileChannelImpl.write(Unknown Source)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDisk.write(BlockDisk.java:216)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDiskCache.processUpdate(BlockDiskCache.java:399)
	at org.apache.commons.jcs.auxiliary.AbstractAuxiliaryCacheEventLogging.updateWithEventLogging(AbstractAuxiliaryCacheEventLogging.java:65)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache.doUpdate(AbstractDiskCache.java:815)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache$MyCacheListener.handlePut(AbstractDiskCache.java:673)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$PutEvent.doRun(AbstractCacheEventQueue.java:350)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$AbstractCacheEvent.run(AbstractCacheEventQueue.java:269)
	at org.apache.commons.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:304)

Attachments (0)

Change History (12)

comment:1 Changed 3 years ago by Don-vip

Cc: wiktorn added
Component: CoreCore imagery
Keywords: jcs cache added

comment:2 Changed 3 years ago by wiktorn

Cc: wiktorn removed
Owner: changed from team to wiktorn
Status: newassigned

comment:3 Changed 3 years ago by wiktorn

Owner: changed from wiktorn to dido
Status: assignedneedinfo

Can you tell me, what size of the WMS cache file do you have? It's usually in directory:

%LOCALAPPDATA%\Josm\cache\tiles

I'm interested in files:

WMS_BLOCK.key
WMS_BLOCK.data

comment:4 Changed 3 years ago by wiktorn

In 10417/josm:

Fix block cache growing outside the limit.

  • Missing setting of the block size prevented JCS to properly limit of the cache file size when using Block Disk. Set the block size to 4096
  • Block Disk Cache do not reduce the size of the file, when setting the limit lower than the actual file size, so now JOSM will remove all the cache files by itself when limit is set to lower than before value
  • Because of above two, bumped naming of the files to _v2 so older (possibly way above the file size limit) file will be removed

See: #12979, #12986

comment:5 Changed 3 years ago by Don-vip

Milestone: 16.06

comment:6 Changed 3 years ago by dido

Hi,

here's the file listing:

17.06.2016 Ј. 10:38 426474166 TMS_BLOCK.data
17.06.2016 Ј. 21:26 3573998 TMS_BLOCK.key
15.06.2016 Ј. 23:16 2147483648 WMS_BLOCK.data
15.06.2016 Ј. 23:34 5754444 WMS_BLOCK.key
10.06.2016 Ј. 21:15 0 WMTS_BLOCK.data
14.06.2016 Ј. 23:23 4 WMTS_BLOCK.key

comment:7 Changed 3 years ago by wiktorn

Thanks, this clarifies situation for me. As a workaround, you may either:

  • work with JOSM latest
  • remove the files by your self once such problems happens
  • go to extended settings and set jcs.cache.use_block_cache to false. This is needed only till next release

comment:8 Changed 3 years ago by wiktorn

BlockDisk is not supporting cache sizes larger than 2GB's, this is already reported in JCS:
https://issues.apache.org/jira/browse/JCS-156

I've also provided them a patch with a fix for this. Hope that it will be included in JCS tree before we will release next JOSM.

comment:9 Changed 3 years ago by wiktorn

Ticket #12986 has been marked as a duplicate of this ticket.

comment:10 Changed 3 years ago by wiktorn

Resolution: fixed
Status: needinfoclosed

comment:11 Changed 3 years ago by wiktorn

Ticket #13077 has been marked as a duplicate of this ticket.

comment:12 Changed 3 years ago by anonymous

Ticket #13112 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dido.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.