Modify

Opened 5 years ago

Closed 5 years ago

#13112 closed defect (duplicate)

Warning after loading at startup

Reported by: Aun Johnsen <lists@…> Owned by: wiktorn
Priority: normal Milestone:
Component: Core imagery Version: tested
Keywords: template_report jcs cache Cc:

Description

What steps will reproduce the problem?

  1. Open a fresh JOSM
  2. do something

What is the expected result?

Normal editing behaviour

What happens instead?

A warning about unexpected error, with the options to "Do nothing" or "Report a bug". After selected choice, editing continues as normal.

Please provide any additional information below. Attach a screenshot if possible.

This is constantly happening after starting JOSM, but not until I do something inside the window (select download area, or trying to do something AFTER remote control download). Suspect that the problem is linked with Mac OS X El Capitan and some feature of JOSM loaded to memory.

This problem was not present under previous stable version, and there have been some time since updates affecting Java capabilities.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 en) Mac OS X 10.11.5
Memory Usage: 616 MB / 910 MB (168 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
- DxfImport (1006)
- FixAddresses (32158)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- SeaChart (32158)
- SeaMapEditor (31926)
- apache-commons (32158)
- apache-http (32158)
- continuosDownload (44)
- ejml (32158)
- geochat (32158)
- geotools (31895)
- jts (31906)
- merge-overlap (32158)
- opendata (32158)
- reverter (32158)
- rex (1884)
- turnlanes (32158)
- turnrestrictions (32158)
- undelete (32158)
- utilsplugin2 (32158)
- waydownloader (32158)

Tagging presets:
- https://github.com/simonpoole/beautified-JOSM-preset/raw/master/gen/vespucci_zip.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Leaftype&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OpenSeaMap_bridge&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
- https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Hafen.xml
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Sport.xml

Map paint styles:
- ${HOME}/Documents/workspace/JOSM-ONC/INT1_MapCSS.mapcss
- ${HOME}/Documents/workspace/mapnik-brasil/base.mapcss
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1

Validator rules:
- https://raw.githubusercontent.com/OSMBrasil/validador-josm/master/Rules_Brazilian-Specific.validator.mapcss
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/Seamark.validator.mapcss
- https://raw.githubusercontent.com/stefan-a-bauer/josm-validators/master/mtb.validator.mapcss

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out
- W: Failed to load https://josm.openstreetmap.de/maps, use cached file and retry next time: java.net.SocketTimeoutException: Read timed out
- E: Broken tagging preset "service-Service way type" - number of items in 'display_values' must be the same as in 'values'
- E: Detailed information: [Alley, Driveway, Parking, Parking ailse, Drive-through, Emergency access] <> [alley, driveway, parking_aisle, drive-through, emergency_access]
- E: java.lang.IllegalArgumentException: Negative position

java.lang.IllegalArgumentException: Negative position
	at sun.nio.ch.FileChannelImpl.write(FileChannelImpl.java:755)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDisk.write(BlockDisk.java:216)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDiskCache.processUpdate(BlockDiskCache.java:399)
	at org.apache.commons.jcs.auxiliary.AbstractAuxiliaryCacheEventLogging.updateWithEventLogging(AbstractAuxiliaryCacheEventLogging.java:65)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache.doUpdate(AbstractDiskCache.java:815)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache$MyCacheListener.handlePut(AbstractDiskCache.java:673)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$PutEvent.doRun(AbstractCacheEventQueue.java:350)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$AbstractCacheEvent.run(AbstractCacheEventQueue.java:269)
	at org.apache.commons.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:304)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Component: CoreCore imagery
Keywords: jcs cache added
Owner: changed from team to wiktorn

comment:2 Changed 5 years ago by wiktorn

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12979.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain wiktorn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.