Modify

Opened 3 years ago

Closed 3 years ago

#13077 closed defect (duplicate)

opening a random layer at the first time in the session an error appears

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 en) Windows 10 64-Bit
Memory Usage: 798 MB / 1778 MB (357 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- DirectDownload (32158)
- DirectUpload (32158)
- HouseNumberTaggingTool (31926)
- ImportImagePlugin (32158)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- RoadSigns (32177)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- download_along (32158)
- editgpx (32223)
- ejml (32158)
- ext_tools (32158)
- geotools (31895)
- jts (31906)
- log4j (32158)
- measurement (32158)
- ods-bag (0.6.7)
- opendata (32158)
- opendataservices (0.6.7)
- pbf (32158)
- photo_geotagging (32158)
- poly (32158)
- reverter (32158)
- terracer (32158)
- turnlanes (32158)
- turnrestrictions (32158)
- utilsplugin2 (32158)
- wikipedia (32182)

Map paint styles:
- Y:\== Routes\JOSM\== BAG\BAG Import Plugin Open Street Map JOSM\BAG\BAG\Style Sheet Peewee\Style Sheet Fin (Ilpo) over NL borden\nlsigns\nlsigns-all.mapcss
- Y:\== Routes\JOSM\== BAG\BAG Import Plugin Open Street Map JOSM\BAG\BAG\bag-plugin-0.6.6\Bag-plugin-0.6.6\Ods-bag-style-0.6.6.mapcss
- https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss
- https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Potlach2_access&zip=1
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs.zip

Last errors/warnings:
- W: Ext_Tools warning: can not load file <josm.pref>\plugins\ext_tools\tools.cfg
- W: Ext_Tools warning: can not load file <josm.pref>\plugins\ext_tools\repo.cfg
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- E: java.lang.IllegalArgumentException: Negative position

java.lang.IllegalArgumentException: Negative position
	at sun.nio.ch.FileChannelImpl.write(Unknown Source)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDisk.write(BlockDisk.java:216)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDiskCache.processUpdate(BlockDiskCache.java:399)
	at org.apache.commons.jcs.auxiliary.AbstractAuxiliaryCacheEventLogging.updateWithEventLogging(AbstractAuxiliaryCacheEventLogging.java:65)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache.doUpdate(AbstractDiskCache.java:815)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache$MyCacheListener.handlePut(AbstractDiskCache.java:673)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$PutEvent.doRun(AbstractCacheEventQueue.java:350)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$AbstractCacheEvent.run(AbstractCacheEventQueue.java:269)
	at org.apache.commons.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:304)

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by wiktorn

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12979.
This is already fixed in current JOSM. For stable version, you'll need to manually remove the files in directory:

%LOCALAPPDATA%\Josm\cache\tiles

One of the file grew to 2GB and stable JOSM doesn't handle well this situation.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.