Modify

Opened 5 years ago

Closed 5 years ago

#12986 closed defect (duplicate)

Loading of background imagery results in IllegalArgumentException

Reported by: osmTOGA Owned by: osmTOGA
Priority: normal Milestone: 16.06
Component: Core imagery Version:
Keywords: template_report jcs cache Cc: wiktorn

Description

What steps will reproduce the problem?

  1. Start JOSM

Option 1:

  1. Click on Download button
  2. Download window with background imagery appears
  3. Error pops up

Option 2:

  1. Load saved session which includes background imagery
  2. Zoom in
  3. Error pops up

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

The error appears only once every session as soon as background imagery gets loaded. JOSM is usable without any further problems after the error is closed.
A few days ago I cleared the cache, which seemed to stop the described behaviour, but now it's back and clearing the cache doesn't resolve it anymore.

Additionally I tried JOSM-latest, it shows the same behaviour.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 de) Windows 7 64-Bit
Memory Usage: 588 MB / 2222 MB (448 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- Mapillary (32158)
- PicLayer (32158)
- RoadSigns (32177)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- continuosDownload
- ejml (32158)
- geochat (32158)
- geotools (31895)
- imagery_offset_db (32158)
- jts (31906)
- measurement (32158)
- opendata
- reverter (32158)
- todo (29154)
- turnrestrictions (32158)
- utilsplugin2 (32158)

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1

Map paint styles:
- %UserProfile%\OSM\JOSM-Paintstyles\Power_lines.mapcss
- https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&style&zip=1

Last errors/warnings:
- W: Fehlende Erweiterungs-Hauptversion in Erweiterung OSMRecPlugin
- W: Achtung - <html>Die Erweiterung opendata erfordert JOSM Version 10407. Die aktuelle JOSM-Version ist 10327.<br>Um diese Erweiterung verwenden zu können, muss JOSM aktualisiert werden.</html>
- W: Achtung - <html>Die Erweiterung continuosDownload erfordert JOSM Version 10358. Die aktuelle JOSM-Version ist 10327.<br>Um diese Erweiterung verwenden zu können, muss JOSM aktualisiert werden.</html>
- E: java.lang.IllegalArgumentException: Negative position

java.lang.IllegalArgumentException: Negative position
	at sun.nio.ch.FileChannelImpl.write(Unknown Source)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDisk.write(BlockDisk.java:216)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDiskCache.processUpdate(BlockDiskCache.java:399)
	at org.apache.commons.jcs.auxiliary.AbstractAuxiliaryCacheEventLogging.updateWithEventLogging(AbstractAuxiliaryCacheEventLogging.java:65)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache.doUpdate(AbstractDiskCache.java:815)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache$MyCacheListener.handlePut(AbstractDiskCache.java:673)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$PutEvent.doRun(AbstractCacheEventQueue.java:350)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$AbstractCacheEvent.run(AbstractCacheEventQueue.java:269)
	at org.apache.commons.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:304)

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by Don-vip

Cc: wiktorn added
Component: CoreCore imagery

comment:2 Changed 5 years ago by Don-vip

Keywords: jcs cache added

comment:3 Changed 5 years ago by wiktorn

Owner: changed from team to osmTOGA
Status: newneedinfo

Can you tell me, what size of the TMS cache file do you have? It's usually in directory:

%LOCALAPPDATA%\Josm\cache\tiles

I'm interested in files:

TMS_BLOCK.key
TMS_BLOCK.data

comment:4 Changed 5 years ago by wiktorn

In 10417/josm:

Fix block cache growing outside the limit.

  • Missing setting of the block size prevented JCS to properly limit of the cache file size when using Block Disk. Set the block size to 4096
  • Block Disk Cache do not reduce the size of the file, when setting the limit lower than the actual file size, so now JOSM will remove all the cache files by itself when limit is set to lower than before value
  • Because of above two, bumped naming of the files to _v2 so older (possibly way above the file size limit) file will be removed

See: #12979, #12986

comment:5 Changed 5 years ago by Don-vip

Milestone: 16.06

comment:6 Changed 5 years ago by wiktorn

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #12979.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain osmTOGA.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.