Modify

Opened 5 years ago

Closed 5 years ago

#12987 closed defect (irreproducible)

download object leads to objects downloaded to nirvana

Reported by: dieterdreist Owned by: dieterdreist
Priority: major Milestone:
Component: Core Version: latest
Keywords: template_report gsoc-core regression Cc: michael2402, Klumbumbus, Stereo

Description

What steps will reproduce the problem?

  1. download object (and referers) from the file menu with no data layer available and "download to new layer" not checked

What is the expected result?

a new layer gets created (as there was none) and the objects end up there

What happens instead?

no layer is created and I don't know where the objects are, but if I select all I see many of them in the windows on the right (see screenshot, note that there is no data layer). When I select view-> zoom to data, nothing is happening

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-17 02:58:36 +0200 (Fri, 17 Jun 2016)
Build-Date:2016-06-17 01:34:23
Revision:10409
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10409 en) Mac OS X 10.11.5
Memory Usage: 729 MB / 1820 MB (231 MB allocated, but free)
Java version: 1.8.0_66-b17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
- TombPlugin (46)
- alignways (32161)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- ejml (32158)
- geochat (32158)
- geotools (31895)
- imagery_offset_db (32158)
- jts (31906)
- opendata (32289)
- print (32191)
- proj4j (32158)
- reltoolbox (32158)
- reverter (32158)
- undelete (32158)
- utilsplugin2 (32158)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.dialogs.relation.actions.SetRoleAction@66ed4ee9
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.dialogs.relation.ReferringRelationsBrowser$ReloadAction@6c3ff79b
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.dialogs.relation.ReferringRelationsBrowser$EditAction@4cfe6a52
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.dialogs.relation.actions.OKAction@6cafaab6
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.dialogs.relation.actions.CancelAction@630b5ced

Attachments (3)

Screen Shot 2016-06-17 at 19.04.24.png (1.7 MB) - added by dieterdreist 5 years ago.
Screen Shot 2016-06-22 at 12.17.05.png (2.3 MB) - added by dieterdreist 5 years ago.
after download object (1 node downloaded)
Screen Shot 2016-06-22 at 12.22.45.png (2.4 MB) - added by dieterdreist 5 years ago.
after select all

Change History (19)

Changed 5 years ago by dieterdreist

comment:1 Changed 5 years ago by Don-vip

Cc: michael2402 added
Keywords: gsoc-core regression added
Milestone: 16.06

comment:2 Changed 5 years ago by michael2402

I just tested this and cannot reproduce it using revision [10411], the plugins you have and the relations 4525457,2014364.

Does this happen with all id lists for you?

comment:3 Changed 5 years ago by stoecker

Owner: changed from team to dieterdreist
Status: newneedinfo

comment:4 Changed 5 years ago by dieterdreist

Resolution: irreproducible
Status: needinfoclosed

yes, I must admit I can't reproduce either with the current version. Don't know how this happened, now it all works fine and a new data layer gets created even if the object doesn't exist (404) (this might be questionable as well, but is out of scope for this ticket).

comment:5 Changed 5 years ago by Don-vip

Milestone: 16.06

comment:6 Changed 5 years ago by dieterdreist

Resolution: irreproducible
Status: closedreopened

Sorry, but it happened again, I'm reopening this. Actually, what I am doing and have been doing also the other time:
download an object, do some modifications, upload, remove the data layer.
After having done this several times, all of a sudden it doesn't show a data layer, but the data is there somehow. Interestingly, I was even able to add a tag and upload (because the object in question was already selected, 1st screenshot after "download object"), but when I select all, I don't see any data, but a lot of stuff is selected (although I only downloaded 1 node plus referrers, see 2nd screenshot

Changed 5 years ago by dieterdreist

after download object (1 node downloaded)

Changed 5 years ago by dieterdreist

after select all

comment:7 Changed 5 years ago by dieterdreist

this is the changeset I created "blindly": https://www.openstreetmap.org/changeset/40201308

comment:8 Changed 5 years ago by Don-vip

Milestone: 16.06

comment:9 Changed 5 years ago by Don-vip

Priority: normalmajor

this looks like a major regression we should not release until this is understood/fixed.

comment:10 Changed 5 years ago by michael2402

This seems to be a problem in the layer list. There might be two things causing this:

  • LayerListDialog table does not realize it needs to update - It should have been registered as action listener all the time since there were always layers present. So it should receive the layer added event and do a fireTableDataChanged
  • LayerListDialog forgetting the layer - But it queries the layer list directly from the layer manager
  • Layer not included in the layer list - But the active layer is set after adding it to the layer list.
  • ??? Some complex correlation of those three or some race condition...

Has anyone been able to reproduce this?

@dieterdreist if it ever happens again: Can you try hiding and then reopening the side layer dialog? Can you try adding an other new layer?

comment:11 Changed 5 years ago by dieterdreist

ok, I'll try these next time it happens.

comment:12 Changed 5 years ago by Don-vip

not reproduced since?

comment:13 Changed 5 years ago by Klumbumbus

Cc: Klumbumbus added

comment:14 Changed 5 years ago by Don-vip

Cc: Stereo added

@Stereo: did you experience this as well with JOSM latest on MacOS?

comment:15 Changed 5 years ago by Don-vip

Milestone: 16.0616.07

No news, let's fix it in next release. As almost all MacOS users are using Java 8 it's OK.

comment:16 Changed 5 years ago by Don-vip

Milestone: 16.07
Resolution: irreproducible
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dieterdreist.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.