Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12307 closed defect (fixed)

Reverter does not revert

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Plugin reverter Version:
Keywords: Cc: luiswoo, dieterdreist, Don-vip

Description

Josm Version 9329

Reverter: 8338_Plugin-Url: 31895;https://svn.openstreetmap.org/!svn/bc/31896/applications/editors/josm/dist/reverter.jar

Not work for changset https://www.openstreetmap.org/changeset/36409509 (http://nrenner.github.io/achavi/?changeset=36409509).

Changeset look very simple: move point and add this point to way, revert latest changes for both objects.

Attachments (2)

2016-01-06-222551_1168x1125_scrot.png (121.0 KB) - added by simon04 4 years ago.
revert-of-36409509.osm (6.4 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (27)

comment:1 Changed 4 years ago by anonymous

  1. Open josm
  2. Data/Revert changeset
  3. Enter 36409509, click revert

Object downloaded but not reverted, no undo/redo actions

comment:2 Changed 4 years ago by simon04

Bug also present in r9229 – at least no new core regression :)

Maybe related to #10780/#10985.

Last edited 4 years ago by simon04 (previous) (diff)

Changed 4 years ago by simon04

comment:3 Changed 4 years ago by simon04

Owner: changed from Upliner to anonymous
Status: newneedinfo

Worksforme: the result after reverting 36409509 → attachment:2016-01-06-222551_1168x1125_scrot.png

Please add required infos as required per newticket!

comment:4 in reply to:  3 Changed 4 years ago by Nakaner

Replying to simon04:

Worksforme: the result after reverting 36409509 → attachment:2016-01-06-222551_1168x1125_scrot.png

Please add required infos as required per newticket!

Although it was not me who reported the bug, I can confirm that the bug exists (it also occurs at my computer). Here is the information required by newticket.

What steps will reproduce the problem?

  1. Revert the changeset 36409509 using either the menu or the keyboard shortcut

What is the expected result?

A revert of the changeset.

What happens instead?

Progress bars create the impression that the changeset is being reverted but the data shown at the data layer at JOSM shows that nothing has been changed.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-11-24 00:04:12 +0100 (Tue, 24 Nov 2015)
Build-Date:2015-11-23 23:14:21
Revision:9060
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9060 de) Linux Arch Linux
Memory Usage: 561 MB / 1746 MB (484 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true]
Dataset consistency test: No problems found

Plugins:
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- ejml (31895)
- geotools (31895)
- jts (31772)
- reverter (31895)
- utilsplugin2 (31895)

Last errors/warnings:
- E: Defekte Objektvorlage "railway:signal:departure:states-Anzeigbare Signalbilder" - Anzahl der Datenworte in 'display_values' und in 'values' müssen gleich sein
- E: Detaillierte Information: [A 1 (Türen schließen);A 2 (Abfahren), A 1 (Türen schließen);A 2 (Abfahrt)] <> [DE-BOStrab:a1;off, DE-BOStrab:a2;off, DE-BOStrab:a1;DE-BOStrab:a2;off]

comment:5 Changed 4 years ago by naoliv

Indeed it is not working.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-07 03:14:25 +0100 (Thu, 07 Jan 2016)
Build-Date:2016-01-07 02:34:00
Revision:9336
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9336 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 1128 MB / 3641 MB (350 MB allocated, but free)
Java version: 1.8.0_72-internal-b05, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31772)
- Create_grid_of_ways (31772)
- FastDraw (31895)
- FixAddresses (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- buildings_tools (31895)
- download_along (31772)
- editgpx (31772)
- ejml (31895)
- geotools (31895)
- graphview (31895)
- jts (31772)
- log4j (31895)
- measurement (31895)
- merge-overlap (31772)
- opendata (31937)
- pdfimport (31895)
- photo_geotagging (31895)
- poly (31772)
- reverter (31897)
- tagging-preset-tester (31895)
- todo (29154)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (31895)

comment:6 Changed 4 years ago by naoliv

Ticket #12315 has been marked as a duplicate of this ticket.

comment:7 Changed 4 years ago by naoliv

Cc: luiswoo added
Priority: normalmajor

comment:8 Changed 4 years ago by naoliv

Owner: changed from anonymous to team
Status: needinfonew

reverter isn't reverting anything.

comment:9 Changed 4 years ago by simon04

Ticket #12318 has been marked as a duplicate of this ticket.

comment:10 Changed 4 years ago by simon04

Cc: dieterdreist Don-vip added
Summary: Reverter cant revert move point and include it to way for latest versions (nowbies ID changes)Reverter does not revert

comment:11 Changed 4 years ago by simon04

To summarize: According to the reports, reverter cannot revert

comment:12 Changed 4 years ago by naoliv

I can't also revert
https://www.openstreetmap.org/changeset/35542767 and
https://www.openstreetmap.org/changeset/35604230 (when inserting both to be reverted together)

Changed 4 years ago by simon04

Attachment: revert-of-36409509.osm added

comment:13 Changed 4 years ago by simon04

Please try again w/ reverter 31926.

comment:14 Changed 4 years ago by anonymous

All work fine, thanks.

comment:15 Changed 4 years ago by naoliv

Seems good now.

comment:16 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

Great.

What I did: ant clean dist in core and plugins/reverter making sure to use Java 7 both times. For 31897, core might have been compiled using Java 8 …

comment:17 Changed 4 years ago by hjart

I'm not sure whether I'm missing something, but I can't get it to work with https://www.openstreetmap.org/changeset/33672204. The problem is now a bit different in that the previous data (that I want back) isn't loaded and when trying to upload I'm getting a message that there's no changes to upload. Someone straightened this road and I'd really like to revert that change asap.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-08 10:43:21 +0100 (Fri, 08 Jan 2016)
Build-Date:2016-01-09 02:34:54
Revision:9345
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9345 da) Linux openSUSE 13.2 (Harlequin) (x86_64)
Memory Usage: 459 MB / 1328 MB (234 MB allocated, but free)
Java version: 1.8.0_65-b17, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- DirectUpload (31912)
- ImproveOsm (22)
- InfoMode (31772)
- Mapillary (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- measurement (31895)
- rasterfilters (31895)
- reverter (31897)
- scoutsigns (71)
- todo (29154)
- undelete (31895)
- utilsplugin2 (31895)
- wikipedia (31917)

comment:18 Changed 4 years ago by hjart

Resolution: fixed
Status: closedreopened

comment:19 Changed 4 years ago by hjart

Resolution: fixed
Status: reopenedclosed

Oh, I was indeed missing something. Thought the plugin would be updated automatically. Sorry

comment:20 Changed 4 years ago by anonymous

Not work for selected objects. Plugin version 31926 JOSM version 9329

comment:21 Changed 4 years ago by naoliv

anonymous, I am using it to revert full changesets and selected objects only, and it's properly working.
Do you have any example of what is not working?

comment:22 Changed 4 years ago by anonymous

For example: http://www.openstreetmap.org/way/233056719/history building is ok, but try to restore the version 1.

comment:23 Changed 4 years ago by naoliv

Right, I saw your problem.
I guess there is a different issue here (and I did open a ticket as #12360).

comment:24 Changed 4 years ago by anonymous

Ok, thanks.

comment:25 Changed 4 years ago by naoliv

Ticket #12362 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.