Modify

Opened 7 years ago

Closed 7 years ago

#12362 closed defect (duplicate)

reverter plugin doesn't seem to work anymore

Reported by: GerdP Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc: GerdP

Description

What steps will reproduce the problem?

  1. try to revert changeset 36558500
  2. look at way 9252792

What is the expected result?

The changeset merged this way with another one, producing invalid
tags like highway="track; path". The reverter plugin should show the
previous versions of the way.

What happens instead?

The way is shown as is.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-06 17:30:31 +0100 (Wed, 06 Jan 2016)
Build-Date:2016-01-06 16:32:31
Revision:9329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9329 en) Windows 10 64-Bit
Memory Usage: 736 MB / 3641 MB (173 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
- FastDraw (31895)
- apache-commons (31895)
- buildings_tools (31895)
- ejml (31895)
- geotools (31895)
- jts (31772)
- o5m (${version.entry.commit.revision})
- opendata (31937)
- pbf (31772)
- poly (31772)
- reverter (31897)
- utilsplugin2 (31895)

Last errors/warnings:
- W: Cannot start IPv4 remotecontrol server on port 8111: Address already in use: JVM_Bind
- W: Cannot start IPv6 remotecontrol server on port 8111: Address already in use: JVM_Bind
- W: Cannot lock cache directory. Will not use disk cache
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<The maximum bbox size is 0.25, and your request was too large. Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by naoliv

You are using an older version of the plugin.
Could you update it, please? It should solve your problem. See #12307.

comment:2 in reply to:  1 Changed 7 years ago by anonymous

Replying to naoliv:

You are using an older version of the plugin.
Could you update it, please? It should solve your problem. See #12307.

Ah, sorry. Should have done that before complaining. Problem seems to be solved.
Thanks for the quick reaction.

comment:3 Changed 7 years ago by naoliv

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12307.
Good! :-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.