Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#10835 closed defect (fixed)

consistency between preset and default mappaint style

Reported by: Klumbumbus Owned by: Klumbumbus
Priority: normal Milestone: 15.01
Component: Internal mappaint style Version:
Keywords: Cc:

Description (last modified by Klumbumbus)

This ticket can be used to refer to, when changes are made regarding to this topic.

The goal is:

  1. same icon for one feature
  2. support of the same geometries (node,way,closedway,relation)

in preset and mappaint style.

Also every item in the preset menu should have its own icon.

Deprecated icons should be moved to images_nodist folder.

So far the following changes have already been made:

[7717] - landuse=orchard, barrier=spikes, man_made=groyne, man_made=breakwater
[7711] - landuse
[7724] - sport
[7728] - generator:source
[7729] - golf
[7735] - natural
[7738] - amenity=drinking_water
[7744] - restriction
[7668][7736][7739] - move deprecated icons to images_nodist/presets folder

related osm svn changes

...more will come...

Attachments (1)

historic_panel.png (14.2 KB) - added by skyper 4 years ago.
screenshot

Download all attachments as: .zip

Change History (51)

comment:1 Changed 5 years ago by Klumbumbus

Description: modified (diff)

comment:2 Changed 5 years ago by bastiK

TODO: barrier=bollard

comment:3 Changed 5 years ago by Klumbumbus

In 7821/josm:

see #10835 - icon unification and geometry consistency for barrier=*

comment:4 Changed 5 years ago by Klumbumbus

In 7854/josm:

see #10835 - icon unification and geometry consistency for highway waypoints

comment:5 Changed 5 years ago by Klumbumbus

In 7877/josm:

see #10835 - remove highway=unsurfaced from mapaint style

comment:6 Changed 5 years ago by Klumbumbus

Milestone: 14.1215.01

There is still some work to do. I will do it in next milestone.

comment:7 Changed 5 years ago by Klumbumbus

todo: aerialway=t-bar

comment:8 Changed 5 years ago by Don-vip

You can do it now if you want :)

comment:9 in reply to:  8 Changed 5 years ago by Klumbumbus

Replying to Don-vip:

You can do it now if you want :)

No, I want to do it in the next days and check the whole aerialway group. This was just a reminder, that I do not forget this :)

comment:10 Changed 5 years ago by Don-vip

allright!

comment:11 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:12 Changed 5 years ago by Klumbumbus

In 7915/josm:

see #10835 - icon unification and geometry consistency for aerialway

comment:13 Changed 5 years ago by Klumbumbus

Ticket #10914 has been marked as a duplicate of this ticket.

comment:14 Changed 5 years ago by Klumbumbus

In 7927/josm:

see #10835 - icon unification and geometry consistency for whole facilities preset group

comment:15 Changed 5 years ago by aceman

amenity=ice_cream has no preset, but has an icon if created as a node.

comment:16 Changed 5 years ago by Don-vip

comment:17 Changed 5 years ago by Klumbumbus

In 7940/josm:

see #10835 - icon unification for place=*

comment:18 Changed 5 years ago by Klumbumbus

In 7942/josm:

see #10835 - icon unification and geometry consistency for some naturaltags. add validator warnings for some node features on ways

comment:19 Changed 5 years ago by Klumbumbus

In 7950/josm:

see #10835 - icon unification and geometry consistency for some shop tags. add own icon for shop=alcohol

comment:20 Changed 5 years ago by rickmastfan67

Some icons got broken in the [7950] changeset. Saw this in the CL in Windows 7 with the newest 'latest'.

ERROR: Failed to locate image 'styles/standard/shop/rental/library.png'
WARNING: Could not get presets icon styles/standard/shop/rental/library.png

comment:21 Changed 5 years ago by Klumbumbus

In 7952/josm:

see #10835 - fix icon path

comment:22 in reply to:  20 Changed 5 years ago by Klumbumbus

Replying to rickmastfan67:

Some icons got broken in the [7950] changeset.

Thanks. Fixed.

comment:23 Changed 5 years ago by Klumbumbus

In 7953/josm:

see #10835 - new icon for shop=books

comment:24 Changed 5 years ago by Klumbumbus

In 7960/josm:

see #10835 - icon unification and geometry consistency for some man_made, historic amd bridge tags.

comment:25 Changed 5 years ago by Klumbumbus

Description: modified (diff)

comment:26 Changed 5 years ago by Klumbumbus

Description: modified (diff)

comment:27 Changed 5 years ago by Klumbumbus

In 7962/josm:

see #10835 - move deprecated icons to nodist, see [o30914]

comment:28 Changed 5 years ago by Klumbumbus

In 7963/josm:

see #10835 - fix regression of r7960

comment:29 in reply to:  24 Changed 5 years ago by rickmastfan67

Replying to Klumbumbus:

In 7960/josm:

see #10835 - icon unification and geometry consistency for some man_made, historic amd bridge tags.

Missed one. Saw this in the CL on startup of the new 'latest' r7963.

ERROR: Failed to locate image 'styles/standard/bridge/support.svg'
WARNING: Could not get presets icon styles/standard/bridge/support.svg

comment:30 Changed 5 years ago by Klumbumbus

In 7964/josm:

see #10835 - fix typo

comment:31 Changed 5 years ago by Klumbumbus

In 7967/josm:

see #10835 - icon unification and geometry consistency for some power tags. add validator warnings

comment:32 in reply to:  31 ; Changed 5 years ago by skyper

Replying to Klumbumbus:

In 7967/josm:

see #10835 - icon unification and geometry consistency for some power tags. add validator warnings

Better use https://wiki.openstreetmap.org/wiki/Tag:power=substation#Switchgear and no redirects as redirects do not support languages and the wiki already includes four languages besides English.

comment:33 in reply to:  32 ; Changed 5 years ago by Klumbumbus

Replying to skyper:

Better use https://wiki.openstreetmap.org/wiki/Tag:power=substation#Switchgear and no redirects as redirects do not support languages and the wiki already includes four languages besides English.

But this would also not work for russian and polish, since they do not have a heading "Switchgear". And if one day someone creates the page power=switchgear, we will likely not notice for the JOSM preset and change power=substation#Switchgear to power=switchgear.

Last edited 5 years ago by Klumbumbus (previous) (diff)

comment:34 in reply to:  33 ; Changed 5 years ago by skyper

Guess we do not get around in these cases to do the job manually for each language as the script to automatically check/include the links will fail here, too.

comment:35 Changed 5 years ago by Klumbumbus

In 7975/josm:

see #10835 - icon unification and geometry consistency for some water related tags. add validator warnings

comment:36 in reply to:  34 Changed 5 years ago by Klumbumbus

Replying to skyper:

Guess we do not get around in these cases to do the job manually for each language as the script to automatically check/include the links will fail here, too.

I think the script will override manual edits each time it is executed.

comment:37 Changed 5 years ago by Klumbumbus

In 7977/josm:

see #10835 - icon unification and geometry consistency for some transport related tags (railway, aeroway,...). add validator warnings

comment:38 Changed 5 years ago by Klumbumbus

In 7978/josm:

see #10835 - fix hangar

comment:39 Changed 5 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

This is all I plan to do for now. Public transport is missing. I created an own ticket for this #11006.

Please report here or create new tickets, if you notice more inconsistecies between preset/mappaint/validator/wiki.

comment:40 Changed 5 years ago by bastiK

Great work, thanks!

comment:41 Changed 4 years ago by Klumbumbus

Description: modified (diff)

Changed 4 years ago by skyper

Attachment: historic_panel.png added

screenshot

comment:42 in reply to:  24 ; Changed 4 years ago by skyper

Resolution: fixed
Status: closedreopened

Replying to Klumbumbus:

In 7960/josm:

see #10835 - icon unification and geometry consistency for some man_made, historic amd bridge tags.

Now the top panel icon for historic=* is to small compared to the rest and the space around historic=boundary_stone is less than all the other icons which looks somehow off.

screenshot

comment:43 in reply to:  42 Changed 4 years ago by Klumbumbus

Replying to skyper:

Now the top panel icon for historic=* is to small compared to the rest

I think this should better be handled by the JOSM code. It should upscale atleast svg icons in this case, maybe also png icons. There are some icon scaling related tickets in the next milestone. Please add a comment there. (ticket:10688#comment:7)
As this is a default toolbar icon and the scaling will not be fixed in 15.01 I try to upolad the icon at a default size of 32px again. I already planed to do it this way, but it didn't correct downscale to 16px in Mapview (seems some special svg incompatibility again).

and the space around historic=boundary_stone is less than all the other icons which looks somehow off.

This schould also be handled by the JOSM code. It should align the icons centered. Adding transparent or white space around the icons is no clean solution. Please also add a comment at another ticket for this problem. Btw, I didn't touch this icon. It was already this way probably since it was added to preset some day.

comment:44 Changed 4 years ago by skyper

Ok, I did add my comments to #10688. Feel free to close this ticket again.

comment:45 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

Replaced castle icon in [o30926] with a default size of 160px. This way scaling works as expected in toolbar and mapview.

comment:46 Changed 4 years ago by Klumbumbus

In 7996/josm:

see #10835 - improve mappaint and validator for tourism=information

comment:47 Changed 4 years ago by Klumbumbus

In 7997/josm:

see #10835 - own icon for generator:source=geothermal

comment:48 Changed 4 years ago by Klumbumbus

In 8004/josm:

see #10835 - add icon for description=*

comment:49 Changed 4 years ago by Klumbumbus

In 8009/josm:

see #10835 - update boundary preset and mappaint

comment:50 Changed 4 years ago by Klumbumbus

In 8010/josm:

see #10835 - improve boundary preset, add maritime

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.