Modify

Opened 7 years ago

Last modified 9 months ago

#9125 reopened enhancement

shop=ice_cream should be detected and fixed to amenity=ice_cream

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: Cc:

Attachments (0)

Change History (14)

comment:1 Changed 7 years ago by stoecker

Sounds strange to me, to move a "shop" tag to the overfull generic "amenity". I doubt that is correct.

Last edited 7 years ago by stoecker (previous) (diff)

comment:2 Changed 7 years ago by mkoniecz

Note that shop=ice_cream is not recognised by JSOM and amenity=ice_cream is, this move is recommended both by wiki and taginfo. Statistics are around 3300 to 600.

But I was also surprised that it is moved in this direction. Adding recognition of shop=ice_cream would also be good for me.

Last edited 7 years ago by mkoniecz (previous) (diff)

comment:3 Changed 7 years ago by skyper

There was some discussion on tagging@osm a year or two ago which did not end in a conclusion but it was rather about cuisine=ice_cream or amenity=ice_cream. In my opinion we should use shop instead of amenity or amenity=cafe + cuisine=ice_cream.

comment:4 Changed 7 years ago by mkoniecz

Then - is it possible to add shop = ice_cream to presets and recognise it with an icon?

comment:5 Changed 7 years ago by Don-vip

Ticket #9358 has been marked as a duplicate of this ticket.

comment:6 Changed 7 years ago by simon04

From the very unclear situation for amenity=ice_cream and shop=ice_cream and cuisine=ice_cream it's hard to define a good validator/preset/style.

comment:7 Changed 5 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 9651/josm:

fix #9125, fix #12212 - add amenity=ice_cream and amenity=water_point to preset (mappaint already there)

comment:8 Changed 5 years ago by Klumbumbus

Resolution: fixedwontfix

The tagging situation is still not absolutely clear.

amenity=cafe + cuisine=ice_cream seems to be the most popular variant. This is already suported in JOSM preset.

I just added preset for amenity=ice_cream (mappaint was already there), which has also a high usage number.

A validator fix to change shop=ice_cream is not possible atm, as the wiki defines fine differences between them (however I think reality is different). It is also not deprecated in the wiki. OSM carto renderes both, shop=ice_cream and amenity=ice_cream.

However I added shop=ice_cream to ignore list, so it will no longer display the "value not in presets warning".

comment:9 Changed 13 months ago by mkoniecz

A validator fix to change shop=ice_cream is not possible atm, as the wiki defines fine differences between them (however I think reality is different).

I edited wiki and started thread at tagging mailing list. My goal is to remove claims from OSM Wiki that amenity=ice_cream and shop=ice_cream have different meaning, as it is not matching real tagging.

comment:10 in reply to:  9 Changed 13 months ago by Klumbumbus

Replying to mkoniecz:

started thread at tagging mailing list.

OK, please let us know about the result.

comment:11 Changed 12 months ago by mkoniecz

There were claims about some abstract differences but claims seemed unconvincing to me.

comment:12 Changed 9 months ago by mkoniecz

https://github.com/gravitystorm/openstreetmap-carto/issues/3970 proposed to remove rendering for shop=ice_cream in the default map style (if you think that reason for wontfixing this issue still holds then you probably want to comment there)

comment:13 Changed 9 months ago by mkoniecz

Also, note https://user-images.githubusercontent.com/42757252/68587144-af0ca300-04c9-11ea-990c-3cd3b9ee65fd.png - currently amenity=ice_cream is used far more often among mappers than shop=ice_cream unlike 2016 when it was closed

Last edited 9 months ago by mkoniecz (previous) (diff)

comment:14 Changed 9 months ago by Klumbumbus

Resolution: wontfix
Status: closedreopened

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to mkoniecz
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.