Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#10593 closed enhancement (fixed)

in "tag checker rules list" make it obvious which downloadable rules are already used

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 15.08
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. F12
  2. Validator settings
  3. Tag checker rules
  4. Attempt to check which ones from left are already used

What is the expected result?
It is possible to do it in easy way.

What happens instead?
It is not indicated which downloadable rules are used, both list are sorted in a different ways. On top of it entries in the left and right list have different heights.

Proposed fix:
Sort both list using the same order.


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-10-05 01:34:55
Last Changed Author: Don-vip
Revision: 7599
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-10-05 01:24:20 +0200 (Sun, 05 Oct 2014)
Last Changed Rev: 7599

Identification: JOSM/1.5 (7599 en) Linux Ubuntu 14.04.1 LTS
Memory Usage: 264 MB / 889 MB (27 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (30416)
- OpeningHoursEditor (30609)
- PicLayer (30436)
- buildings_tools (30485)
- geotools (30569)
- jts (30416)
- log4j (30416)
- measurement (30641)
- notes (v0.9.4)
- turnrestrictions (30651)

Attachments (1)

Selection_001.png (41.6 KB) - added by mkoniecz 6 years ago.

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by mkoniecz

Attachment: Selection_001.png added

comment:1 Changed 6 years ago by mkoniecz

Description: modified (diff)

comment:2 Changed 6 years ago by Klumbumbus

There is the same problem also for mappaint styles and presets. I think the best would be if there is the same solution for all three. For mappaint styles the proposed solution ("Sort both list using the same order.") will not work, since the manually order is important in the right column (and alphabetic order in the left column is good). My suggestion would be to hide or make the text color grey in the left column, if the entry is already in the right column.

comment:3 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:4 Changed 6 years ago by stoecker

For Maps we already use green background color to indicate, that an entries match.

When we are on it, maybe we should also think about displaying icons. Due to #10581 I'm reworking the JOSM cron a bit and thinking about replacing the icon lines in styles, rules, presets with an inline base64 encoding. This will increase file size, but then all is inline and no additional icon loading necessary (like we do for plugins). Could be unified for plugins as well BTW.

comment:5 Changed 6 years ago by Klumbumbus

I didn't think about maps. Green background is also fine.

comment:6 in reply to:  description Changed 6 years ago by skyper

Replying to mkoniecz:

What happens instead?

list have different heights.

This is another general problem. Noticed it last week in relation dialog, too. Did open a separated ticket: #10599.

comment:7 Changed 6 years ago by Don-vip

Type: defectenhancement

comment:8 Changed 5 years ago by simon04

Resolution: fixed
Status: newclosed

In 8507/josm:

fix #10593 - Preference, mappaint/preset/validator sources: indicate added/active items by gray/green checkmark

comment:9 Changed 5 years ago by simon04

Milestone: 15.07

comment:10 Changed 5 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.