Modify

Opened 5 years ago

Closed 5 years ago

Last modified 9 months ago

#10592 closed enhancement (fixed)

Default Mac OS X keyboard shortcuts conflict with system, could be improved.

Reported by: Stereo Owned by: team
Priority: normal Milestone: 14.10
Component: Core shortcuts Version:
Keywords: template_report, macosx Cc:

Description (last modified by Don-vip)

My console lists the following keyboard shortcuts that could be changed to shortcuts that don't require seven years of yoga classes and actually work.

I had manually changed the Wireframe view shortcut before this.

INFO: Silent shortcut conflict: 'file:exportgpx' moved by 'system:findselected' to '⌘+⌥+F1'.
INFO: Silent shortcut conflict: 'file:downloadreferrers' moved by 'apple-reserved-42' to '⌘+⌥+F2'.
INFO: Silent shortcut conflict: 'file:updatedata' moved by 'system:underline' to '⌘+⌥+F3'.
INFO: Silent shortcut conflict: 'file:updatemodified' moved by 'system:minimizeall' to '⌘+⌥+F4'.
INFO: Silent shortcut conflict: 'copy:coordinates' moved by 'system:colors' to '⌘+⌥+F5'.
INFO: Silent shortcut conflict: 'system:purge' moved by 'system:printsetup' to '⌘+⌥+F6'.
INFO: Silent shortcut conflict: 'system:merge' moved by 'system:minimize' to '⌘+⌥+F7'.
INFO: Silent shortcut conflict: 'core:info' moved by 'system:info' to '⌘+⌥+F8'.
INFO: Silent shortcut conflict: 'core:historyinfo' moved by 'system:hide' to '⌘+⌥+F9'.
INFO: Silent shortcut conflict: 'tools:jumpto' moved by 'system:toselection' to '⌘+⌥+F10'.
INFO: Silent shortcut conflict: 'tools:multipoly_create' moved by 'system:bold' to '⌘+⌥+F11'.
INFO: Silent shortcut conflict: 'menu:windows:changesetdialog' moved by 'system:copystyle' to '⌘+⌥+F12'.
INFO: Silent shortcut conflict: 'core_multikey:hidingFilter' moved by 'system:hideothers' to '⌥+⇧+F10'.
INFO: Silent shortcut conflict: 'conflation:replace' moved by 'system:search' to '⌥+⇧+F11'.
INFO: Silent shortcut conflict: 'mapmode:cadastre-fr-buildings' moved by 'tools:adjnodes' to '⌥+⇧+F12'.
INFO: Silent shortcut conflict: 'view:zoominalternate' moved by 'system:preferences' to '⌘+⇧+F1'.

What steps will reproduce the problem?

  1. Launch JOSM from the Mac OS X terminal with java -jar /Applications/JOSM.app/Contents/Java/*.jar
  2. Watch the silent warnings flow by.

What is the expected result?

Keyboard shortcuts that are easy to remember and usable on laptops.

What happens instead?

These shortcuts are difficult to type, and don't even work.

Please provide any additional information below. Attach a screenshot if possible.

The problem wasn't as bad in the previous tested version, before the shortcuts were made mac-friendly in changeset 7539. For example, ctrl-W used to toggle wireframe view, got changed to command-W, and now conflicts with the Mac OS X standard shortcut to close a window.

Revision: 7588
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-09-29 23:52:43 +0200 (Mon, 29 Sep 2014)
Build-Date: 2014-09-29 22:12:08
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7588

Identification: JOSM/1.5 (7588 en_GB) Mac OS X 10.9.5
Memory Usage: 619 MB / 3641 MB (426 MB allocated, but free)
Java version: 1.8.0_20, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30416)
- CommandLine (30678)
- DirectDownload (30697)
- DirectUpload (30697)
- FixAddresses (30416)
- HouseNumberTaggingTool (30416)
- OpeningHoursEditor (30609)
- PicLayer (30436)
- RoadSigns (30495)
- alignways (30631)
- areaselector (1411072924)
- buildings_tools (30485)
- cadastre-fr (30703)
- conflation (0.1.7)
- contourmerge (1010)
- dataimport (30416)
- download_along (30416)
- geotools (30569)
- imagery_offset_db (30534)
- importvec (30416)
- jts (30416)
- livegps (30506)
- mapdust (30502)
- merge-overlap (30416)
- mirrored_download (30664)
- namemanager (30416)
- notes (v0.9.4)
- opendata (30607)
- pdfimport (30416)
- public_transport (30664)
- reverter (30521)
- scripting (30700)
- surveyor (30646)
- tageditor (30703)
- terracer (30643)
- turnlanes (30416)
- turnrestrictions (30651)
- undelete (30416)
- utilsplugin2 (30460)

Last errors/warnings:
- E: Failed to locate image ''
- E: Failed to locate image ''
- W: Could not get presets icon 
- E: Failed to locate image ''
- W: Could not get presets icon

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by Don-vip

Component: CoreCore shortcuts

comment:2 Changed 5 years ago by Don-vip

What is this key: ?

comment:3 Changed 5 years ago by Stereo

That's option/left alt. There's no alt gr on Macs.

http://www.macforbeginners.com/media/images/74-keyboard-keys.jpg has images.

comment:4 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:5 Changed 5 years ago by Don-vip

In 7605/josm:

see #10592 - disable irrelevant os x system shortcuts

comment:6 Changed 5 years ago by Don-vip

In 7606/josm:

fix #10592 - fix other shortcuts

comment:7 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

comment:8 Changed 5 years ago by Don-vip

Ticket #10610 has been marked as a duplicate of this ticket.

comment:9 Changed 5 years ago by Don-vip

Milestone: 14.10

comment:10 Changed 9 months ago by aricamartin

The well described the Mac OS X keyboard shortcuts in this ticket. I am getting the error code 0x3e9(1001) in my system. I also try to fix error code 0x3e9(1001) for the help purpose but did not get any response.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.