Modify

Opened 6 years ago

Closed 6 years ago

#10610 closed defect (duplicate)

CMD-Shift-4 conflict on OSX

Reported by: escada Owned by: team
Priority: minor Milestone:
Component: Core shortcuts Version:
Keywords: template_report Cc:

Description

In the latest JOSM release all CTRL-keys where replaced by CMD-keys on OSX. However sometimes this creates a conflict. CMD-SHIFT-4 is the make screenshot key combination, so it is no longer possible to add the 4th item from the previous used tags anymore.
I don't have a good solution for this. Revert to the old key assignment for all "add previous tag keys" ? Of course I could remap the key myself for this situation to the CTRL-key, but other people might have this problem too.

I keep the status below, but it has nothing to do with the problem.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-29 22:12:08
Last Changed Author: Don-vip
Revision: 7588
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-29 23:52:43 +0200 (Mon, 29 Sep 2014)
Last Changed Rev: 7588

Identification: JOSM/1.5 (7588 nl) Mac OS X 10.9.4
Memory Usage: 422 MB / 455 MB (141 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30416)
- DirectDownload (30697)
- DirectUpload (30697)
- FastDraw (30416)
- HouseNumberTaggingTool (30416)
- ImportImagePlugin (30416)
- OpeningHoursEditor (30609)
- PicLayer (30436)
- RoadSigns (30495)
- alignways (30631)
- buildings_tools (30485)
- contourmerge (1010)
- download_along (30416)
- ext_tools (30685)
- geochat (30513)
- geotools (30569)
- imagery_offset_db (30534)
- jts (30416)
- kendzi3d (1.0.180)
- kendzi3d-jogl (37)
- log4j (30416)
- measurement (30641)
- merge-overlap (30416)
- mirrored_download (30664)
- notes (v0.9.4)
- opendata (30607)
- pdfimport (30416)
- print (30416)
- reltoolbox (30587)
- reverter (30521)
- scripting (30700)
- terracer (30643)
- turnlanes (30416)
- utilsplugin2 (30460)
- wikipedia (30629)

Last errors/warnings:
- W: org.openstreetmap.josm.io.OsmTransferException: Kon geen verbinding maken met de server van OSM. Controleer uw verbinding met internet.. Oorzaak: java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Kon geen verbinding maken met de server van OSM. Controleer uw verbinding met internet.. Oorzaak: java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Kon geen verbinding maken met de server van OSM. Controleer uw verbinding met internet.. Oorzaak: java.net.UnknownHostException: api.openstreetmap.org

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10592.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.