Modify

Opened 5 years ago

Closed 5 years ago

#10609 closed defect (fixed)

ctrl+a does not select all layers

Reported by: richlv Owned by: team
Priority: normal Milestone: 14.10
Component: Core Version: tested
Keywords: focus layer regression Cc:

Description

this is a regression.
have multiple layers, hit ctrl+a - they are not selected.
my usecase is opening a larger amount of gpx files and merging them in josm.

last "tested" version when this worked : 7480
first "tested" version where this does not work : 7588

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by Don-vip

this is intended behaviour of r7539. I thought the JOSM ctrl-a action (select all objects) was more useful than selecting all layers. I'd like to hear opinions from other people.

comment:2 Changed 5 years ago by Klumbumbus

If you first click into the layers dialog and then ctrl+a, then it should select all layers because there is the same behavior for all other dialogs.

If you click in the map view and then ctrl+a then it selects all objects of the current layer.

comment:3 in reply to:  2 Changed 5 years ago by skyper

Replying to Klumbumbus:

If you first click into the layers dialog and then ctrl+a, then it should select all layers because there is the same behavior for all other dialogs.

If you click in the map view and then ctrl+a then it selects all objects of the current layer.

Yes, the shortcuts did/should work depending on focus, though I hate the needed "click" to focus on Linux where I am used to have focus by mouse only.

comment:4 Changed 5 years ago by richlv

indeed, it should work depending on the focus - ctrl+a in the map view is useful and worked just fine when focus was there, but if focus is somewhere else, shortcuts should affect that functionality :)

comment:5 Changed 5 years ago by Don-vip

Keywords: focus layer added
Milestone: 14.10

comment:6 Changed 5 years ago by Don-vip

Keywords: regression added

comment:7 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7617/josm:

fix #10609 - ctrl+a does not select all layers (regression, partial revert of r7539)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.