Modify

Opened 10 years ago

Last modified 7 months ago

#9908 reopened enhancement

[WIP patch] Filter downloaded notes

Reported by: skyper Owned by: ToeBee
Priority: major Milestone:
Component: Core notes Version:
Keywords: filter github Cc: iandees, Klumbumbus

Description (last modified by skyper)

It would be nice to filter notes and to only download requested. Several filter options come to my mind:

  • by user (exclude + only mentioned)
  • by status
    • I often want to get rid of closed ones as the system gets quite slow with lots of notes.
  • by time (span of time, creation + closed)

Maybe even a combination would be cool in order to find only the notes closed by a certain user in a specific timespan.

Attachments (2)

Screenshot 2021-04-07 at 23.50.46.png (321.6 KB ) - added by simon04 3 years ago.
wip-notes-download.patch (11.3 KB ) - added by NoteRoamer 7 months ago.
Work In Progress on new notes download action.

Download all attachments as: .zip

Change History (19)

comment:1 by skyper, 10 years ago

Cc: iandees added

comment:2 by Don-vip, 10 years ago

Keywords: github added
Resolution: othersoftware
Status: newclosed

comment:3 by skyper, 9 years ago

Resolution: othersoftware
Status: closedreopened

As notes is integrated into core this enhancement request is back.

P.S.: Do we need an new component "Core notes" ?

comment:4 by skyper, 9 years ago

See also #9907 with a similar scenario.

in reply to:  3 ; comment:5 by Don-vip, 9 years ago

Replying to skyper:

P.S.: Do we need an new component "Core notes" ?

I will rename the "plugin notes" component to "core notes" when we deprecate the plugin.

@ToeBee: can we do that now, or are there some features in the plugin we don't offer yet in core?

comment:6 by ToeBee, 9 years ago

I'd be fine with renaming. I think the only feature that hasn't been put into core yet is to use the API search functionality to download notes.

in reply to:  5 comment:7 by skyper, 9 years ago

Replying to Don-vip:

Replying to skyper:

P.S.: Do we need an new component "Core notes" ?

I will rename the "plugin notes" component to "core notes" when we deprecate the plugin.

Well, I can live with "plugin notes", so far, and enhancements might be valid for both.

in reply to:  6 comment:8 by skyper, 9 years ago

Replying to ToeBee:

I'd be fine with renaming. I think the only feature that hasn't been put into core yet is to use the API search functionality to download notes.

Did you implement "Open in Webbrowser", yet, or is there at least the id visible ?

By the way, I can only download and open new notes but all other actions are unavailable (greyed out) atm with r7787. Is this intended or should I open a new ticket ?

comment:9 by Klumbumbus, 9 years ago

Cc: Klumbumbus added

comment:10 by Don-vip, 7 years ago

The Notes API is still very limited. We can only search for notes on text and comments, not on users and dates.
There are a few tickets aiming at improving the Notes API:

comment:11 by skyper, 4 years ago

There were some enhancements committed to search by user and dates, see #1955

comment:12 by skyper, 3 years ago

Description: modified (diff)

According to the API description, searching aka filtered download is now possible. See API_v0.6#Search_for_notes:_GET_/api/0.6/notes/search.

comment:13 by Don-vip, 3 years ago

Ticket #20583 has been marked as a duplicate of this ticket.

comment:14 by simon04, 3 years ago

/api/0.6/notes/search does not support filtering by a bounding box, e.g., https://api.openstreetmap.org/api/0.6/notes/search?bbox=11,47,12,48&q=trail

The UI could be inspired by the changeset query dialog:

comment:15 by Don-vip, 3 years ago

Summary: Filter notesFilter downloaded notes

comment:16 by NoteRoamer, 7 months ago

I'm a bit uncertain if this issue is about filtering notes before downloading or after downloading. Title suggests after but content seems to be about before. I will assume before.

I'm posting to let anyone interested know that I'm working on an action that will use some more features of the current OSM API to select which notes to download. When done and tested it should replace the current "Search notes..." action.

The current state is that matching on a string and/or a username works. It is also possible to change some settings for this one query (or use the defaults from preferences). It should be usable and should not have any negative effects. It probably is lacking in the UI and several features of the OSM API is still missing.

I will attach a patch for what I have so far, any comments are welcome.

comment:17 by gaben, 7 months ago

Summary: Filter downloaded notes[WIP patch] Filter downloaded notes

by NoteRoamer, 7 months ago

Attachment: wip-notes-download.patch added

Work In Progress on new notes download action.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain ToeBee.
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from ToeBee to the specified user. Next status will be 'new'.
Next status will be 'needinfo'. The owner will be changed from ToeBee to skyper.
as duplicate The resolution will be set to duplicate. Next status will be 'closed'. The specified ticket will be cross-referenced with this ticket.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.