Modify

Opened 5 years ago

Closed 4 years ago

#9907 closed enhancement (fixed)

When using remote control on osm.org download also note(s) if URL contains "/note/123456" or "&layers=N"

Reported by: skyper Owned by: ToeBee
Priority: normal Milestone: 15.04
Component: Core notes Version:
Keywords: github Cc: iandees

Description

While trying to reproduce #9858 I was not able to open the mentioned note as it was closed a while ago.

Please have an option to download a specific note.

Attachments (0)

Change History (22)

comment:1 Changed 5 years ago by skyper

Cc: iandees added

comment:2 Changed 5 years ago by Don-vip

Please create directly notes defect on Github.

comment:3 in reply to:  2 Changed 5 years ago by skyper

Replying to Don-vip:

Please create directly notes defect on Github.

The best would be to have them interact (e.g. https://stackoverflow.com/questions/6671584/how-to-export-trac-to-github-issues).

This solution could work for every maintainer interested in using github instead of trac.

comment:4 Changed 5 years ago by Don-vip

Most of github josm plugins are either dead either very slowly updated. I won't waste my time to implement an automatic solution.
Hence I close those tickets from unaware users and switch them to github with a little hope that they may be fixed some day. I expect active users like you to directly create tickets there to minimize work for josm team.
Thanks for your comprehension.

comment:5 in reply to:  4 Changed 5 years ago by skyper

Replying to Don-vip:

Most of github josm plugins are either dead either very slowly updated. I won't waste my time to implement an automatic solution.
Hence I close those tickets from unaware users and switch them to github with a little hope that they may be fixed some day. I expect active users like you to directly create tickets there to minimize work for josm team.
Thanks for your comprehension.

Hey, the solution I mentioned is using Trac's XML-RPC interface and I expected the plugin maintainers to run a cron job to get their issues. Likewise they could have some script to make a Trac comment linking to the new created issue and close the ticket in the same run they close their issues. Did not want to spend your time.

comment:6 Changed 5 years ago by Don-vip

Keywords: github added
Resolution: othersoftware
Status: newclosed

I know :) but the point is, the simple presence of these tickets here causes a workload for us, so I'd prefer not to see them here in the first place.

=> upstream ticket: https://github.com/iandees/josm-notes/issues/23

comment:7 Changed 4 years ago by skyper

Resolution: othersoftware
Status: closedreopened

This would be still an enhancement.
Not sure where it belongs to now as pasted into DownloadDialog below mentioned URLs behave the same atm

In fact, the note is not downloaded at all even with checkbox checked.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-12-11 02:33:43
Last Changed Author: Don-vip
Revision: 7787
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-12-11 00:15:17 +0100 (Thu, 11 Dec 2014)
Last Changed Rev: 7787

Identification: JOSM/1.5 (7787 en) Linux Debian GNU/Linux 7.7 (wheezy)
Memory Usage: 344 MB / 882 MB (216 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u71-2.5.3-2~deb7u1
VM arguments: [-Djosm.home=$HOME/.josm_notes]
Program arguments: [--language=en, test.osn]
Dataset consistency test: No problems found

comment:8 Changed 4 years ago by Klumbumbus

Ticket #10931 has been marked as a duplicate of this ticket.

comment:9 Changed 4 years ago by Klumbumbus

Summary: Download specific noteWhen using remote control on osm.org download also note(s) if URL contains "/note/123456" or "&layers=N"

comment:10 Changed 4 years ago by skyper

Not sure if remote control is the only solution. Still prefer a solution to simply type/paste the note id like it is working with object ids.

comment:11 Changed 4 years ago by simon04

In 8195/josm:

see #9907 - Make "Open Location" capable of downloading notes

If more than one download task is suitable, ask the user which tasks to perform.

comment:12 Changed 4 years ago by simon04

In 8197/josm:

see #9907 - Remote control: let the user decide which suitable download tasks to perform

This enables downloading notes from corresponding URLs (cf. #8195)

comment:13 Changed 4 years ago by Klumbumbus

Milestone: 15.04

comment:14 Changed 4 years ago by Klumbumbus

Is this feature already finished? Notes download does not work for me.

comment:15 Changed 4 years ago by simon04

"Remote control" or "Open location"? Which URL did you test?

comment:16 Changed 4 years ago by Klumbumbus

Remote control (the edit button on osm.org).

(I just tried open locaction, which works for me.)

Revision: 8199
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: simon04
Last Changed Date: 2015-04-15 23:51:33 +0200 (Wed, 15 Apr 2015)
Build-Date: 2015-04-16 01:31:12
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8199

Identification: JOSM/1.5 (8199 en) Windows 7 32-Bit
Memory Usage: 742 MB / 742 MB (145 MB allocated, but free)
Java version: 1.8.0_31, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files\Java\jre1.8.0_31\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files\josm-latest-bla.jnlp, -Djnlpx.remove=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=256m,768m, -Djnlpx.splashport=61388, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]
Dataset consistency test: No problems found
Last edited 4 years ago by Klumbumbus (previous) (diff)

comment:17 Changed 4 years ago by simon04

Concerning the edit button @osm.org: This calls http://127.0.0.1:8111/load_and_zoom?left=1&top=2&right=3&bottom=4 without any information about the active layers. So this would require a modification there (→ https://github.com/openstreetmap/openstreetmap-website/) plus an adoption of the /load_and_zoom handler (this currently calls the standard DownloadOsmTask in any case).

comment:18 Changed 4 years ago by simon04

In 8203/josm:

see #9907 - Open Location, Which tasks to perform?: use standard icons

comment:20 Changed 4 years ago by simon04

In 8209/josm:

see #9907 - Open Location: detect note layer also when non-standard layer is active on osm.org

For instance, when the cycle map plus notes layers are active, layers=CN.

comment:21 in reply to:  10 Changed 4 years ago by Klumbumbus

Replying to skyper:

a solution to simply type/paste the note id like it is working with object ids.

This case was fixed in [8196]

comment:22 Changed 4 years ago by simon04

Resolution: fixed
Status: reopenedclosed

The outstanding part is split to #11367, so this ticket is fixed. :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ToeBee.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.