Modify

Opened 15 months ago

Closed 14 months ago

Last modified 14 months ago

#20583 closed enhancement (fixed)

Filter notes in notes dialog

Reported by: mrgenie@… Owned by: simon04
Priority: normal Milestone: 21.04
Component: Core notes Version: latest
Keywords: Feature Notes filter Cc:

Description

For the Notes Window in JOSM I'd request a new feature that allows with a quick click to

  • Show only the notes of the user currently logged in to openstreetmap.org; at the top of JOSM I see my own username @Username and I simply wish a small button enable/disable if enabled only see my own notes
  • Sort bar at the top, like most OS explorers have where I can sort by
    1. date
    2. username

Attachments (1)

Screenshot 2021-04-07 at 23.31.19.png (126.6 KB) - added by simon04 14 months ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 15 months ago by skyper

Some sorting is already possible using the sort button.

For the filter part, see #9908.

comment:2 Changed 15 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9908.
Agreed, you can already sort using the dialog sort button, and the filtering part will be addressed by #9908

comment:3 Changed 14 months ago by simon04

Keywords: filter added
Priority: minornormal
Resolution: duplicate
Status: closedreopened
Summary: feature request for the notes windowFilter notes in notes dialog

#9908 is about downloading.
This is about filtering the notes dialog.

comment:4 Changed 14 months ago by simon04

Milestone: 21.04
Owner: changed from team to simon04
Status: reopenednew

comment:5 Changed 14 months ago by simon04

Resolution: fixed
Status: newclosed

In 17714/josm:

fix #20583 - Filter notes in notes dialog

Changed 14 months ago by simon04

comment:6 Changed 14 months ago by Klumbumbus

Great! Very useful feature.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.