Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9482 closed defect (fixed)

regression: irregular behaviour drawing ways

Reported by: malenki Owned by: Don-vip
Priority: critical Milestone: 14.01
Component: Core Version:
Keywords: Cc:

Description

How to reproduce:
Draw a new way in an empty data layer.
Switch to "select" mode (S) and select the beginning of the way (where the arrows of the way point away from)
Switch to draw mode

What happens:
Draw mode continues the way on the end of the way (where the arrow is located).

What was expected:
Draw mode should continue drawing the way on the end where the selected node is.

Due to this bug normal mapping workflow is affected seriously.

Worked on r6534, broken on r6542
Tested with virgin ~/.josm

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by Don-vip

Milestone: 14.01

comment:2 Changed 6 years ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

Regression from r6542 see #9423. I'm working on a proper fix.

comment:3 Changed 6 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 6546/josm:

fix #9482, see #9423, see #6853 - fix regression from r6542: irregular behaviour drawing ways

comment:4 Changed 6 years ago by Don-vip

Manual build is in progress, a new jar should be available in some minutes. Thanks for reporting this bug.

comment:5 Changed 6 years ago by malenki

Thanks for the quick fix, too.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.