Modify

Opened 8 years ago

Closed 8 years ago

#9483 closed defect (duplicate)

GitHub mirror broken

Reported by: simon04 Owned by: team
Priority: normal Milestone:
Component: unspecified Version:
Keywords: Cc: avarab@…

Description

Due to the changes in build.xml in r6540 (and r6545), the mirror on GitHub isn't updated any more. This might be due to the "evil build.xml revision hack" in the Git commit bcbc70ea2e5c51b5d27222fe69c7e963645ca263.

I assume, one needs to manually merge the changes …

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by Don-vip

Component: Tracunspecified
Owner: changed from stoecker to team

Who set up this mirror ?

comment:2 Changed 8 years ago by simon04

Keywords: bastiK added

Maybe bastiK? I assumed, it is being updated on the JOSM server, isn't it?

comment:3 Changed 8 years ago by stoecker

No. JOSM does not actively use git. We got some requests in the past, but still there is no real good reason other than that certain developers like git more and don't want to see the disadvantages. Someone did setup the git mirror to satisfy these git fans.

comment:4 Changed 8 years ago by simon04

Cc: avarab@… added
Keywords: bastiK removed

I investigated: Some time ago when the mirror was also broken, https://github.com/avar fixed it (see archive of no longer accessible https://github.com/openstreetmap/josm/issues/1).

Ævar, maybe you could give us some details how the mirroring is set up. Thank you! :-)

comment:5 Changed 8 years ago by avarab@…

Yeah it was indeed that conflict, I've solved it and the mirror is back up now.

comment:6 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

Thank you a lot!

comment:7 Changed 8 years ago by Don-vip

Ticket #9735 has been marked as a duplicate of this ticket.

comment:8 Changed 8 years ago by mkoniecz

Resolution: fixed
Status: closedreopened

comment:9 Changed 8 years ago by mkoniecz

I reopened, as my ticket was closed as duplicate of this one (mirror is currently not updating).

Last edited 8 years ago by mkoniecz (previous) (diff)

comment:10 Changed 8 years ago by simon04

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #6887.
One GitHub ticket is enough. ;-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.