Modify

Opened 6 years ago

Closed 6 years ago

Last modified 20 months ago

#9315 closed defect (fixed)

Used old internationalization file for Japanese language.

Reported by: mfuji Owned by: team
Priority: normal Milestone: 13.11 (hotfix)
Component: Core Version: tested
Keywords: i18n Cc: simon04

Description

Jar file of version 6383 seems to contain an old i18n file for Japanese.
It contains many wrong translation which were already fixed months ago.

Attachments (0)

Change History (27)

comment:1 Changed 6 years ago by Don-vip

Cc: simon04 added

comment:2 Changed 6 years ago by simon04

In 6387/josm:

i18n update - see #9315

comment:3 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

Actually, I have no idea what happened during the i18n process. It seems that old .po files have been retrieved from launchpad since ja.po contains:

"POT-Creation-Date: 2013-11-12 10:58+0100\n"
"PO-Revision-Date: 2012-05-27 13:59+0000\n"
...
"X-Launchpad-Export-Date: 2012-06-02 04:48+0000\n"
"X-Generator: Launchpad (build 15342)\n"

The one used for r6387 seems to be correct:

"POT-Creation-Date: 2013-11-15 21:07+0100\n"
"PO-Revision-Date: 2013-11-12 08:22+0000\n"
...
"X-Launchpad-Export-Date: 2013-11-15 04:48+0000\n"
"X-Generator: Launchpad (build 16831)\n"

comment:4 Changed 6 years ago by aceman

Resolution: fixed
Status: closedreopened

This still does not seem finished. Before this patch, the 'sk' translations was shown to be 76% complete at http://josm.openstreetmap.de/wiki/Translations (and also JOSM start page). Now it is at 89%. But that is still bogus as the 'sk' translation should be at 99.9% (JOSM core, not extensions). Please check it.

comment:5 Changed 6 years ago by simon04

At least the used sk.po seems okay:

"POT-Creation-Date: 2013-11-15 21:07+0100\n"
"PO-Revision-Date: 2013-11-12 19:12+0000\n"

I'm unsure whether the statement "JOSM core, not extensions" on Translations is correct since the entire translation template (w/ plugins) contains 8397 msgids, among those 2378 belong to plugins.

Do you recall the percentage stated on Translations before r6383? Besides the percentage, are there other indicators that the sk translations are broken/incomplete/outdated?

comment:6 Changed 6 years ago by Don-vip

Was Japanese the only language impacted ? If not we should release a new tested :)

Last edited 6 years ago by Don-vip (previous) (diff)

comment:7 Changed 6 years ago by simon04

Apparently not (there are (too) many files from 2012):

josm.all/i18n/po$ grep PO-Revision-Date *.po
bg.po:"PO-Revision-Date: 2013-06-24 15:10+0000\n"
ca.po:"PO-Revision-Date: 2013-11-11 07:36+0000\n"
cs.po:"PO-Revision-Date: 2013-10-21 06:58+0000\n"
da.po:"PO-Revision-Date: 2012-06-01 08:35+0000\n"
de.po:"PO-Revision-Date: 2013-11-08 06:49+0000\n"
el.po:"PO-Revision-Date: 2013-08-24 07:36+0000\n"
en_AU.po:"PO-Revision-Date: 2011-07-20 11:31+0000\n"
en_GB.po:"PO-Revision-Date: 2012-04-11 21:53+0000\n"
es.po:"PO-Revision-Date: 2012-05-01 11:44+0000\n"
et.po:"PO-Revision-Date: 2012-05-23 20:38+0000\n"
eu.po:"PO-Revision-Date: 2013-03-30 13:56+0000\n"
fi.po:"PO-Revision-Date: 2012-04-10 16:28+0000\n"
fr.po:"PO-Revision-Date: 2013-10-21 16:21+0000\n"
gl.po:"PO-Revision-Date: 2013-03-30 13:37+0000\n"
hu.po:"PO-Revision-Date: 2013-11-10 00:31+0000\n"
id.po:"PO-Revision-Date: 2011-12-14 05:58+0000\n"
it.po:"PO-Revision-Date: 2013-11-11 07:12+0000\n"
ja.po:"PO-Revision-Date: 2012-05-27 13:59+0000\n"
nb.po:"PO-Revision-Date: 2011-07-19 17:53+0000\n"
nl.po:"PO-Revision-Date: 2012-03-04 12:02+0000\n"
pl.po:"PO-Revision-Date: 2013-11-01 10:58+0000\n"
pt_BR.po:"PO-Revision-Date: 2013-10-11 12:18+0000\n"
pt.po:"PO-Revision-Date: 2012-06-02 00:32+0000\n"
ru.po:"PO-Revision-Date: 2012-06-01 13:53+0000\n"
sk.po:"PO-Revision-Date: 2012-05-15 09:12+0000\n"
sv.po:"PO-Revision-Date: 2012-05-20 09:59+0000\n"
tr.po:"PO-Revision-Date: 2013-11-05 19:02+0000\n"
uk.po:"PO-Revision-Date: 2013-11-10 16:26+0000\n"
zh_CN.po:"PO-Revision-Date: 2012-04-16 12:46+0000\n"
zh_TW.po:"PO-Revision-Date: 2013-07-14 15:08+0000\n"

comment:8 in reply to:  5 ; Changed 6 years ago by aceman

Replying to simon04:

At least the used sk.po seems okay:

"POT-Creation-Date: 2013-11-15 21:07+0100\n"
"PO-Revision-Date: 2013-11-12 19:12+0000\n"

Yes, I have now downloaded both 6386 and 6388 and checked that 6386 contains old outdated sk translation. 6388 seems to contain the current state of the translation so it is fine.

I'm unsure whether the statement "JOSM core, not extensions" on Translations is correct since the entire translation template (w/ plugins) contains 8397 msgids, among those 2378 belong to plugins.

So this claim on the Translation page should be sorted out.

Do you recall the percentage stated on Translations before r6383? Besides the percentage, are there other indicators that the sk translations are broken/incomplete/outdated?

I recall that the percentage is going down with each tested release which I find strange because I translate more and more strings (in core). But maybe it is just that the plugins are inflating faster than I can improve core... I do not see any other indicator that the translation is broken.

I also think you should upload a new 'tested' version (but based on 6383+fixed translations, not 6388 with already changes English strings).

comment:9 in reply to:  8 Changed 6 years ago by simon04

Replying to aceman:

Yes, I have now downloaded both 6386 and 6388 and checked that 6386 contains old outdated sk translation. 6388 seems to contain the current state of the translation so it is fine.

Good to hear that :-)

So this claim on the Translation page should be sorted out.

I agree.

I recall that the percentage is going down with each tested release which I find strange because I translate more and more strings (in core). But maybe it is just that the plugins are inflating faster than I can improve core... I do not see any other indicator that the translation is broken.

This might be due to many plugins being added. In #8645 we are discussing to split the translation into core, plugins and maybe data (for presets, imagery). Feel free to join the discussion.

I also think you should upload a new 'tested' version (but based on 6383+fixed translations, not 6388 with already changes English strings).

So r6387 should be released as new tested

comment:10 Changed 6 years ago by Don-vip

Agreed. We'll need to check carefully next i18n updates...

comment:11 Changed 6 years ago by simon04

I am unsure what led to this error. In past times, I never had troubles with those updates. It remains to decide on the transifex topic. ;-)

comment:12 Changed 6 years ago by rickmastfan67

It doesn't seem that the server is offering [6387] as the new tested yet after it was set to be so. The download area still says that [6383] is the "tested" version. Maybe the server needs to be given a kick in the behind to get it to build it?

comment:13 Changed 6 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

I wasn't aware we couldn't promote intermediate versions (those between latest) as tested, so it didn't work. I have changed it to r6388 and launched the build manually, it worked.

comment:14 in reply to:  13 Changed 6 years ago by stoecker

Replying to Don-vip:

I wasn't aware we couldn't promote intermediate versions (those between latest) as tested, so it didn't work. I have changed it to r6388 and launched the build manually, it worked.

Yep. That's not possible. A tested must always have been a latest before.

I'm unsure whether the statement "JOSM core, not extensions" on Translations is correct since the entire translation template (w/ plugins) contains 8397 msgids, among those 2378 belong to plugins.

So this claim on the Translation page should be sorted out.

If these texts are wrong, then the translation data files are wrong as well. These numbers are directly taken from the included data files.

comment:15 Changed 6 years ago by aceman

No, the data files are fine and the numbers are correct too. Opening the .po file for 'sk' in poedit also claims to have 89% translated. But that those are all strings including plugins.

The problem is the wiki page above that table claims the numbers are without plugins. So if you not do any processing of the data files to remove plugins (and count the percentage anew), then the claim is wrong.

comment:16 Changed 6 years ago by stoecker

The data files contains these many strings. When I recreate them they only contains about 6200.

Something went wrong with creation of the language files. They include too many strings.

comment:17 Changed 6 years ago by aceman

Last known good .po file I have stored locally has 8349 English strings (according to poedit program). Not sure how it counts plural forms.

comment:18 in reply to:  17 Changed 6 years ago by stoecker

Replying to aceman:

Last known good .po file I have stored locally has 8349 English strings (according to poedit program). Not sure how it counts plural forms.

This is not about .po files. These are translated into ".lang" files. The Wiki page shows the contents of these lang files, which are directly used by JOSM.

comment:19 Changed 6 years ago by aceman

Sure, but Launchpad should export/import all those strings into the .po file 1:1 and not miss any strings in the process. So I hope the .lang and .po files are equivalent in content. If not, there is a problem.

comment:20 in reply to:  19 Changed 6 years ago by stoecker

Replying to aceman:

Sure, but Launchpad should export/import all those strings into the .po file 1:1 and not miss any strings in the process. So I hope the .lang and .po files are equivalent in content. If not, there is a problem.

They are not. The .lang files only contain the part relevant for the software (i.e. core or plugin). Thus it should always be a subset of the whole .po file.

comment:21 Changed 5 years ago by aceman

I could only find one .lang file per language in the data/ subdirectory of JOSM source.

But anyway, what is the conclusion. Do you see any problem?

comment:22 in reply to:  21 ; Changed 5 years ago by stoecker

Replying to aceman:

But anyway, what is the conclusion. Do you see any problem?

As Vincent did the update I think he needs to verify (next time :-) that his build environment is ok. There are some cases which cause a bit trouble for the i18n stuff (e.g. adding additional files into the source tree or adding links, ...). Maybe we also could automate the i18n update on the server to eleminate such troubles.

As long as people or computers are involved, errors will happen :-)

comment:23 Changed 5 years ago by aceman

And the wiki text?

comment:24 in reply to:  22 Changed 5 years ago by Don-vip

Replying to stoecker:

As Vincent did the update I think he needs to verify (next time :-) that his build environment is ok.

Hey I didn't do the i18n update this time ! :D (but I already broke it once in the past, it seems easy to make it bad)

Maybe we also could automate the i18n update on the server to eleminate such troubles.

+1 . If we could automate the entire thing with verification checks it would be a huge benefit :)

comment:25 Changed 5 years ago by simon04

I performed the i18n update as summarized in ticket:8645#comment:17. Not sure why this let to problems.

comment:26 Changed 5 years ago by Don-vip

Milestone: 13.11 (6388 hotfix)

comment:27 Changed 20 months ago by stoecker

Milestone: 13.11 (6388 hotfix)13.11 (hotfix)

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.