Modify

Opened 6 years ago

Closed 4 years ago

#9208 closed enhancement (fixed)

add building=supermarket to presets, consider building=supermarket as a building

Reported by: jphilipz Owned by: team
Priority: normal Milestone: 15.05
Component: Internal preset Version:
Keywords: building Cc:

Description (last modified by Don-vip)

  1. would like to suggest the addition of the building drop down in the supermarket preset, because if the supermarket is drawn as a way, it will not be rendered as a building without a building entry.

2. public buildings seem to be incorrectly presetted as stated in the wiki. < http://wiki.openstreetmap.org/wiki/Tag:amenity%3Dpublic_building > Duplicate of #8978

Attachments (0)

Change History (23)

comment:1 in reply to:  description Changed 6 years ago by skyper

Replying to ypharis@…:

  1. would like to suggest the addition of the building drop down in the supermarket preset, because if the supermarket is drawn as a way, it will not be rendered as a building without a building entry.

-1, fix the renderer and do not tag for renderers. See also my comment on #9203.

  1. public buildings seem to be incorrectly presetted as stated in the wiki. < http://wiki.openstreetmap.org/wiki/Tag:amenity%3Dpublic_building >

+1

comment:2 Changed 6 years ago by skyper

  1. is duplicate of #8978

comment:3 Changed 6 years ago by skyper

Keywords: building added

comment:4 Changed 6 years ago by Don-vip

Description: modified (diff)
Summary: preset issues - supermarket, public buildingpreset : add building to supermarket
Type: defectenhancement

comment:5 Changed 6 years ago by simon04

As a more general enhancement, we could automatically set building=yes for shops/amenities/… if they are applied to a closed way. And refrain from doing that on nodes.

In addition, supermarket ways without building=yes should be identified by the validator as "Area style way without building=yes".

What do you think?

comment:6 Changed 6 years ago by Don-vip

I like it, with these remarks:

a closed way

... without any existing "building=*" tag of course

"Area style way without building=yes"

+1 on the idea but not on the wording. "Area style way" can be a landuse or a natural land. But I'm bad at proposing better wordings :(

comment:7 Changed 6 years ago by simon04

Milestone: 14.02

comment:8 Changed 6 years ago by Don-vip

Milestone: 14.0214.03

comment:9 Changed 5 years ago by Don-vip

Milestone: 14.0314.04

comment:10 Changed 5 years ago by Don-vip

Milestone: 14.0414.05

move enhancements to next milestone

comment:11 Changed 5 years ago by Don-vip

Milestone: 14.05

comment:12 Changed 5 years ago by Don-vip

Ticket #10124 has been marked as a duplicate of this ticket.

comment:13 Changed 5 years ago by mkoniecz

Summary: preset : add building to supermarketadd building=supermarket to presets, consider building=supermarket as a building

comment:14 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 8410/josm:

fix #9208 - add building=supermarket

comment:15 Changed 4 years ago by Klumbumbus

Milestone: 15.05

comment:16 Changed 4 years ago by aceman

I do not agree with adding building=supermarket. The wiki page is empty so you do not know when to use that tag. So it is undocumented. Then, why is building=retail not enough for shop=supermarket? Values of "civic" and "public" are used much more and at least have wiki descriptions and those were not added to JOSM.

comment:17 in reply to:  5 Changed 4 years ago by aceman

Replying to simon04:

As a more general enhancement, we could automatically set building=yes for shops/amenities/… if they are applied to a closed way. And refrain from doing that on nodes.

Beware that some amenities should not be put on the building itself, but the area around the buildings. So you would again have to maintain some list of which amenities are of which type.

comment:18 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: closedreopened

comment:19 in reply to:  16 Changed 4 years ago by Klumbumbus

Replying to aceman:

I do not agree with adding building=supermarket. The wiki page is empty so you do not know when to use that tag. So it is undocumented. Then, why is building=retail not enough for shop=supermarket?

building=* describes the building type. So building=supermarket is a building, which was built as a supermarket. (typical for the architecture of those buildings are special entrances for custumors and delivery with ramp for hgv and often only one level) building=retail is fine for a supermarket aswell. building=supermarket is a bit more precise than building=retail.

comment:20 Changed 4 years ago by anonymous

"why is building=retail not enough for shop=supermarket" - because shop=retail includes everything from a huge mall to a kiosk and more. building=supermarket is more specific and represents relatively well-defined type of buildings.

comment:21 Changed 4 years ago by aceman

Sure, please link to the discussion where the "well-defined"ness was agreed upon and then put the definition on the wiki. Thanks.

comment:22 Changed 4 years ago by Klumbumbus

This is fixed for now. Remember that the value of building is not such an "important" tag and is not meant to replace e.g. shop=supermarket. This tag was used nearly 5000 times and spread worldwide even without an extended wiki page or a josm preset. So I think the community agreed on this. The wiki page for shop=supermarket was improved. For building=civic|public, we have other tickets: #8708, #8978

comment:23 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.