Modify

Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#8978 closed enhancement (fixed)

sort out support for building=civic, building=public, amenity=public_building

Reported by: aceman Owned by: team
Priority: normal Milestone: 16.04
Component: Internal preset Version: tested
Keywords: building Cc: Math1985

Description (last modified by aceman)

There are the values of "civic" and "public" listed at http://wiki.openstreetmap.org/wiki/Key:building but they do not seem to be offered inside JOSM (and get no Man made/building... header in the "attributes" panel). Also in the presets for "Public buildings", e.g. townhall, police none of them seem to set the building type (only the amenity).

I see those tags are not used much (http://wiki.openstreetmap.org/wiki/Tag:building%3Dpublic http://wiki.openstreetmap.org/wiki/Tag:building%3Dcivic) and there is much more usage of amenity=public_building . But the wiki says that one should not be used anymore: http://wiki.openstreetmap.org/wiki/Tag:amenity%3Dpublic_building . Can we somehow mark it deprecated in JOSM? Or is the wiki wrong on all this?

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by skyper

The wiki page was change three years ago but I did not find any discussion on tagging@osm. Though, I think this should be changed and public_building deprecated, I would like to have a discussion on tagging@osm first/meanwhile to sort out this problem and give the developers of other editors/software a change to follow.

Overall, building=* is not well integrated and up-to-date within presets and will need some intension, but always keep in mind that amenity=police, for example, might be more than just a building and we do not want to encourage to add the tag twice (e.g. one the area + the building).

comment:2 Changed 6 years ago by skyper

Keywords: building added

comment:3 Changed 6 years ago by skyper

What is the difference between civic and public ?

comment:4 Changed 6 years ago by aceman

Good question. I use it as public = official authority building (e.g. townhall, administrative office, bureau), where people go to do some administrative paperwork. But a building of ministry (of defense, etc) where people normally not go is building=office+office=government. Building=civic is some local centre serving inhabitants, e.g. community centre, culture centre (where there they can meet to organize cultural activities, folk art, small exhibitions, etc), maybe police station too.

Not sure if that is the official usage.

comment:5 Changed 5 years ago by aceman

Description: modified (diff)
Priority: normaltrivial

You are right, there are even more disputes cropping up on those wiki pages since my report.

comment:6 Changed 5 years ago by Don-vip

Ticket #9708 has been marked as a duplicate of this ticket.

comment:7 Changed 3 years ago by Klumbumbus

Ticket #12588 has been marked as a duplicate of this ticket.

comment:8 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 10095/josm:

fix #8978 - deprecate amenity=public_building, add building=public

comment:9 Changed 3 years ago by Klumbumbus

Cc: Math1985 added
Milestone: 16.03
Priority: trivialnormal

comment:10 Changed 3 years ago by Klumbumbus

In 10096/josm:

see #8978 - remove mappaint style of amenity=public_building

comment:11 Changed 3 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.