Modify

Opened 5 years ago

Closed 5 years ago

#12588 closed enhancement (duplicate)

Remove support for amenity=public_building and add tag to validator as deprecated

Reported by: Math1985 Owned by: team
Priority: normal Milestone:
Component: Internal preset Version:
Keywords: Cc:

Description

JOSM has since long supported the tag amenity=public_building. However, over the years, it has become more and more clear that there are a number of problems with this tag.

A discussion on this tag was held on the tagging mailing list, which resulted in a proposal and a vote: http://wiki.openstreetmap.org/wiki/Proposed_features/Government_offices
The tag office=government (which already has JOSM support) was proposed (and accepted) as a better tagging scheme for government offices. At the same time, the tag amenity=public_building was formally marked as 'discouraged'.

Before this vote, the tag already had been marked as 'Don't use' on the wiki, apparently without discussion, since 2010 (see http://wiki.openstreetmap.org/wiki/Tag:amenity%3Dpublic_building ).

The main reason for discouraging the tag was that it's meaning was not clear. It is used for a wide range of different things, such as government buildings, train stations, expo halls, art centres, municipal sport centres, and band stands, amongst others. Nearly all of these have more specific other tags.

The tag has limited software support. The editor iD does not support the tag, and neither does openstreetmap-carto.

I would propose to:

  • Remove the preset for amenity=public_building.
  • Add the tag to the list of deprecated tags of the validator, with office=government as suggested replacement. Not all objects currently tagged amenity=public_building are government buildings, but this is the best suggestion we can do.

This ticket supersedes https://josm.openstreetmap.de/ticket/8978.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by anonymous

I was wondering what the status is of this report? Has anybody already decided whether this suggestion is or is not a good idea?

comment:2 Changed 5 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8978.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.