Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12587 closed defect (fixed)

Fails to download GPX via URL in Download Location dialog

Reported by: andygol Owned by: team
Priority: normal Milestone: 16.04
Component: Core Version:
Keywords: Download Location, GPS, GPX Cc:

Description (last modified by andygol)

What steps will reproduce the problem?

  1. Open Download Location dialog
  2. Enter URL to GPX file (Ex. http://tasks.openstreetmap.us/project/23/task/809.gpx)
  3. Press Download URL button

Download Location

What is the expected result?

Expected to get downloaded into JOSM GPS-track or like in example above get boundaries for task from HOT TM

What happens instead?

Instead of GPS-track I get message error about Unexpected Exception

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-02-28 14:07:49 +0100 (Sun, 28 Feb 2016)
Build-Date:2016-02-28 20:07:32
Revision:9900
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9900 en) Mac OS X 10.11.3
Memory Usage: 657 MB / 910 MB (102 MB allocated, but free)
Java version: 1.8.0_73-b02, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=/Users/user/Library, -DDocumentsDirectory=/Users/user/Documents, -DApplicationSupportDirectory=/Users/user/Library/Application Support, -DCachesDirectory=/Users/user/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
- DirectUpload (31912)
- FastDraw (31895)
- FixAddresses (31772)
- HouseNumberTaggingTool (31772)
- Mapillary (32040)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- RoadSigns (31895)
- alignways (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- changesetID (UNKNOWN)
- colorscheme (31772)
- conflation (0.1.9)
- continuosDownload (1446070193)
- download_along (31772)
- ejml (31895)
- geochat (31895)
- geotools (31895)
- imagery_offset_db (32046)
- imageryadjust (31772)
- josm-config (1449603193)
- jts (31772)
- mbtiles (v2.0)
- measurement (31895)
- merge-overlap (31967)
- opendata (32071)
- pbf (31772)
- rasterfilters (31895)
- reltoolbox (31895)
- reverter (32005)
- scripting (30722)
- todo (29154)
- tofix (1456504567)
- turnlanes (31772)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (32018)
- waydownloader (31772)
- wikipedia (32058)

Last errors/warnings:
- W: Unable to use English input method
- W: Unable to use English input method
- E: Could not parse WMS layer list. Incoming data:
- E: org.openstreetmap.josm.io.OsmTransferException: java.lang.NullPointerException. Cause: java.lang.NullPointerException
- E: org.openstreetmap.josm.io.OsmTransferException: java.lang.NullPointerException. Cause: java.lang.NullPointerException

org.openstreetmap.josm.io.OsmTransferException: java.lang.NullPointerException
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:176)
	at org.openstreetmap.josm.io.OsmServerLocationReader$GpxParser.parse(OsmServerLocationReader.java:158)
	at org.openstreetmap.josm.io.OsmServerLocationReader$GpxParser.parse(OsmServerLocationReader.java:151)
	at org.openstreetmap.josm.io.OsmServerLocationReader.doParse(OsmServerLocationReader.java:51)
	at org.openstreetmap.josm.io.OsmServerLocationReader.parseRawGps(OsmServerLocationReader.java:103)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadGpsTask$DownloadTask.realRun(DownloadGpsTask.java:116)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
	at java.util.regex.Matcher.getTextLength(Matcher.java:1283)
	at java.util.regex.Matcher.reset(Matcher.java:309)
	at java.util.regex.Matcher.<init>(Matcher.java:229)
	at java.util.regex.Pattern.matcher(Pattern.java:1093)
	at org.openstreetmap.josm.tools.HttpClient$Response.getContent(HttpClient.java:273)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:172)
	... 12 more

Attachments (1)

Download Location 2016-03-02.png (71.6 KB) - added by andygol 4 years ago.
Download Location

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by andygol

Download Location

comment:1 Changed 4 years ago by andygol

Description: modified (diff)

comment:2 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 9912/josm:

fix #12587 - fix NPE in HttpClient

comment:3 Changed 4 years ago by simon04

Milestone: 16.03

comment:4 Changed 4 years ago by Don-vip

In 9915/josm:

see #12587 - checkstyle

comment:5 Changed 4 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.