Modify

Opened 6 years ago

Closed 6 years ago

#8977 closed defect (duplicate)

NPE when using "Lane and road attributes" style

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: External mappaint style Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Just clicked to enable "Lane and road attributes" and it gave a NPE

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-08-16 01:35:54
Last Changed Author: bastiK
Revision: 6150
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-08-14 16:23:33 +0200 (Wed, 14 Aug 2013)
Last Changed Rev: 6150

Identification: JOSM/1.5 (6150 pt_BR) Linux Debian GNU/Linux testing (jessie)
Memory Usage: 231 MB / 1667 MB (66 MB allocated, but free)
Java version: 1.7.0_21, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u21-2.3.9-5
VM arguments: [-Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugin: Create_grid_of_ways (29771)
Plugin: PicLayer (29809)
Plugin: SimplifyArea (29778)
Plugin: buildings_tools (29778)
Plugin: contourmerge (1005)
Plugin: editgpx (29596)
Plugin: geotools (29767)
Plugin: jts (29613)
Plugin: log4j (29435)
Plugin: merge-overlap (29778)
Plugin: opendata (29771)
Plugin: pdfimport (29805)
Plugin: reverter (29771)
Plugin: scripting (30540)
Plugin: turnrestrictions (29435)
Plugin: utilsplugin2 (29771)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.preferences.SourceEntry.getZipEntryDirName(SourceEntry.java:166)
	at org.openstreetmap.josm.gui.mappaint.MapImage.getImage(MapImage.java:56)
	at org.openstreetmap.josm.gui.mappaint.RepeatImageElemStyle.paintPrimitive(RepeatImageElemStyle.java:56)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$StyleCollector.drawAll(StyledMapRenderer.java:214)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:1425)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:320)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:533)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:604)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5212)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:295)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1236)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5160)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4971)
	at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
	at javax.swing.RepaintManager$3.run(RepaintManager.java:784)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:784)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:757)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:706)
	at javax.swing.RepaintManager.access$1000(RepaintManager.java:62)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1651)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:727)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:697)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by AlfonZ

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8972.
Fixed in r6151.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.