Modify

Opened 6 years ago

Closed 7 months ago

#8765 closed enhancement (fixed)

Integration of Osmand data with Josm to contribute to OSM

Reported by: mircozorzo Owned by: team
Priority: normal Milestone: 18.08
Component: Core Version:
Keywords: OsmAnd, integration Cc: bitnapper, Klumbumbus, openstreetmap.org-user-d1g

Description

It could be useful a plugin that allow Josm to edit pois stored in OsmAnd device?

Or a plugin that can import in Josm the audio/video or photo note in the device that runs the OsmaAnd application?

Now I find a bit laborious edit the data collected with OsmAnd in Josm I hope it will be more easy.

I think at a option that let me tap on screen to send (via internet) from my OsmAnd device to Josm application on my pc (like Keepright) the audio/video note, the pois.

Bye, Mirco

Attachments (0)

Change History (18)

comment:1 Changed 6 years ago by Victor

Hello, just a short comment about OsmAnd data structure. On sdcard there is main osmand folder /sdcard/osmand (user-configurable)

  • tracks (all tracks recorded by user)
  • avnotes (all audio/video notes created by user)
    • shortlink_encoding.jpg
    • shortlink_encoding.mp4

This notes can be linked to the GPX track by timestamps or by http://wiki.openstreetmap.org/wiki/Shortlink implementation.

comment:2 Changed 6 years ago by anonymous

For me it would be sufficient to show the position of avnotes on the map based on their shortlink in a separate layer with the possibility to show or play them directly in JOSM. In Osmand you can always take an avnote, this is totally independent from recording a gpx-track.

Regards Rupert

comment:3 Changed 5 years ago by percherie

Hello,

I am interested in adding this new function. In the meantime I added notes all over the map for it to work properly. Once the change on the card I finished my closing note, it is not very easy for other contributor JOSM but can not read 3gp files or use the short links.

One solution would be to import WAV files and place them according to their file name. For example:

Original name: xVkXcJOZ---1.3gp
WAV Name: xVkXcJOZ---1.wav <=> 16,43.2321,2.9257.wav
Short link to retrieve the file name: http://www.openstreetmap.org/go/xVkXcJOZ
Normal to extract the filename link : http://www.openstreetmap.org/#map=16/43.2321/2.9257

comment:4 Changed 5 years ago by anonymous

Hi,
I use OsmAnd too, and take pictures and audio notes with it. I then copy the gpx-tracks and the files from the avnotes to my PC for editing with JOSM. The gpx contains waypoints <wpt> which use a <name> tag to point to a media file at that positon. The filename also is a shortlink, as you noticed.

A way to let JOSM associate media to a track using the <name> of a waypoint would be very helpful!

Right now, I can associate the jpgs with the track because of their timestamp. But I can't corellate the 3gp audio right now. I haven't tried mp4 video yet.

Thanks for looking into this!

comment:5 in reply to:  2 Changed 5 years ago by anonymous

Replying to anonymous:

For me it would be sufficient to show the position of avnotes on the map based on their shortlink in a separate layer with the possibility to show or play them directly in JOSM. In Osmand you can always take an avnote, this is totally independent from recording a gpx-track.

Regards Rupert

Yeah, that's what I'd like, too. But how is the resolution of a shortlink? Isn't the waypoint more exact?

Also, Osmand saves the avnotes in a folder "avnotes" and the gpx separately in "tracks", but the gpx do not save the file path for the avnotes. So if you don't copy the files in the same directory, JOSM could not find any of the notes. In this case, I'd love JOSM to ask for the directory of the associated avnotes.

J

comment:6 Changed 5 years ago by jakubt

This is really needed, I think any of the proposals if correctly implemented are good. I do not have problem with pictures - I do not know how, I guess it is by using EXIF tags that it works - I simply drag abd drop files to JOSM and it works. However it is not very easy to use audio notes, which is strange, because there are plugins for audio mapping (using time synchronization) for much simpler mapping methods. Currently the only way to use audio notes is to start it at the beginning and let it run whole time.

comment:7 in reply to:  6 ; Changed 5 years ago by anonymous

Replying to jakubt:

I do not have problem with pictures (...) However it is not very easy to use audio notes.

JPGs and WAVs are supported in JOSM, but JOSM can't do much with 3gp / 3gpp audio files, as mentioned above.
Somebody said it has to do with Java lacking 3gp support. Maybe it'll change in the future, or maybe someone will find a good workaround.

Replying to J:

But how is the resolution of a shortlink? Isn't the waypoint more exact?

QuadTiles can be as exact as any waypoint: http://wiki.openstreetmap.org/wiki/Quadtile
But I don't know how accurate the 8 letters are that are used by OsmAnd.

I'd love JOSM to ask for the directory of the associated avnotes.

+11... It's a small thing, but would make life better ;)

comment:8 Changed 5 years ago by Don-vip

Ticket #10457 has been marked as a duplicate of this ticket.

comment:9 Changed 5 years ago by Don-vip

Cc: bitnapper added

Sample file in #10457.

comment:10 Changed 5 years ago by Klumbumbus

Cc: Klumbumbus added

comment:11 in reply to:  7 Changed 3 years ago by Ivan

Replying to anonymous:

Replying to jakubt:

I do not have problem with pictures (...) However it is not very easy to use audio notes.

JPGs and WAVs are supported in JOSM, but JOSM can't do much with 3gp / 3gpp audio files, as mentioned above.
Somebody said it has to do with Java lacking 3gp support. Maybe it'll change in the future, or maybe someone will find a good workaround.

Replacing WebMarker.actionPerformed(ActionEvent ev) implementation with

try {
    File file = new File(webUrl.toURI());
    Desktop.getDesktop().open(file);
}...

works just fine for me for opening 3gp notes made with OsmAnd.

comment:12 Changed 3 years ago by openstreetmap.org-user-d1g

Cc: openstreetmap.org-user-d1g added

comment:13 Changed 3 years ago by simon04

For mp3/3gp/3gpp support please see #2089, #11017.

Concerning "allow JOSM to edit POIs stored in OsmAnd": OsmAnd is capable of exporting non-commited changes as OsmChange since https://github.com/osmandapp/Osmand/commit/0e05d955cc0d3df84463ff47b28954cf64c0de59. However, due to https://github.com/osmandapp/Osmand/issues/792 and https://github.com/osmandapp/Osmand/commit/714296c2fdbd8bf3075c59287f1d8f99f26b80e7, version="1" is written to every changed node. Thus causing conflicts when updating/uploading the data with JOSM.

What can we do:

  • try to get OsmAnd fixed
  • write a plugin for importing OsmAnd osc files
  • add a hack in JOSM core when seeing generator="OsmAnd"

comment:14 in reply to:  13 Changed 3 years ago by openstreetmap.org-user-d1g

Replying to simon04:

What can we do:

  • write a plugin for importing OsmAnd osc files

freeExec did a separate programm here: https://github.com/freeExec/osc2osn

I not sure if it is up-to-date (last commit 11 month ago).

And of course this is C#, not Java.

comment:15 Changed 8 months ago by Don-vip

In 14101/josm:

see #8765, fix #11086 - Support notes in osmChange (.osc) files created by OsmAnd

comment:16 Changed 8 months ago by Don-vip

Except 3gp/3gpp support, is there something else to do?

comment:17 Changed 7 months ago by mircozorzo

No, it Will do the job.

comment:18 Changed 7 months ago by Don-vip

Component: unspecifiedCore
Milestone: 18.08
Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.