Modify

Opened 4 years ago

Closed 7 weeks ago

Last modified 7 weeks ago

#11086 closed enhancement (fixed)

Allow import notes form created in Osmand *.osc files

Reported by: anonymous Owned by: team
Priority: normal Milestone: 18.08
Component: Core notes Version: latest
Keywords: import, osmchange, osc, osmand Cc:

Description (last modified by Don-vip)

I have notes created in Osmand and when trying open in JOSM, then get info about no data in file.

<?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
<osmChange generator="OsmAnd" version="0.6">
  <create>
    <note lat="50.23887555404037" lon="13.358299552342795" id="-2">
      <comment text="something" />
    </note>
  </create>
  <modify />
  <delete />
</osmChange>

Attachments (2)

poi_modification.note.create.osc (271 bytes) - added by simon04 2 years ago.
poi_modification.note.modify.osc (258 bytes) - added by simon04 2 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 4 years ago by skyper

Keywords: notes import added

comment:2 Changed 4 years ago by Don-vip

Keywords: osmchange osc osmand added

comment:3 Changed 4 years ago by Don-vip

Component: CoreCore notes
Owner: changed from team to ToeBee

Moving notes tickets to their own component

comment:4 Changed 4 years ago by Don-vip

Keywords: notes removed

comment:5 Changed 2 years ago by scai

+1 For supporting OsmAnd notes.

Until then you can use this litte sed script for converting notes to nodes with a note tag. The resulting file can be opened in JOSM:

sed -i 's/note/node/g; s/comment text=/tag k="note" v=/g' poi_modification.osc

For the people without sed: Open poi_modification.osc in your favorite text editor, then replace all occurrences of note with node, then every comment text= with tag k="note" v=.

Changed 2 years ago by simon04

Changed 2 years ago by simon04

comment:6 Changed 22 months ago by Klumbumbus

Component: Core notesCore
Owner: changed from ToeBee to team

(osc files are not Notes)

comment:7 Changed 7 weeks ago by Don-vip

Description: modified (diff)

comment:8 Changed 7 weeks ago by Don-vip

Ticket #16565 has been marked as a duplicate of this ticket.

comment:9 in reply to:  6 Changed 7 weeks ago by Klumbumbus

Component: CoreCore notes

Replying to Klumbumbus:

(osc files are not Notes)

OK, these are Notes nevertheless (even if the default data format is .osn!?)

comment:10 Changed 7 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 14101/josm:

see #8765, fix #11086 - Support notes in osmChange (.osc) files created by OsmAnd

comment:11 Changed 7 weeks ago by Don-vip

Milestone: 18.08

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.