Modify

Opened 6 years ago

Closed 2 years ago

#8764 closed enhancement (duplicate)

MacBook Pro Retina Display support

Reported by: neic Owned by: neic
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Retina macosx Cc: ggeldenhuis, Stereo

Description

JOSM looks blurry on MacBook Pro with retina display.

As i see it there are minimum three changes to be made:

  1. Set HiDPI support in Info.plist to make the UI text render with higher DPI,
  2. make icons with higher resolution and
  3. make the map render with higher DPI.

I dont know the complications 2 and 3 will make, but 1 is easy to fix:

In the file josm/trunk/macosx/JOSM.app/Contents/Info.plist add the lines

    <key>NSHighResolutionCapable</key>
    <string>True</string>

inside <plist><dict> … </dict></plist>.

It enables the HiDPI support in Apple Java 6 and make the UI text render beautiful.

Attachments (1)

Screen Shot 2013-11-13 at 22.03.19.png (7.3 KB) - added by ggeldenhuis 6 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 6 years ago by stoecker

See also #8654.

comment:2 Changed 6 years ago by Don-vip

comment:3 Changed 6 years ago by Don-vip

In 6012/josm:

see #8764 - Enables the HiDPI support in Apple Java 6

comment:4 Changed 6 years ago by Don-vip

Owner: changed from Radfahrer to neic
Status: newneedinfo

Java 7u40 has been released, can you give it a try and tell us if it works ? Thanks.

comment:5 Changed 6 years ago by Don-vip

(you currently must launch JOSM with Web Start or manually to use Java 7 on Mac, the OS X package does not yet support Java 7)

comment:6 Changed 6 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

Point 1 should be fixed. We won't do points 2 and 3 because it does not concern more than 1% of our users and it would burden JOSM for the 99% other people (and no one of us has a Mac anyway)

comment:7 Changed 6 years ago by stoecker

I want a non-Mac notebook with Retina display. Really. When can I buy one for reasonable price...

comment:8 Changed 6 years ago by Don-vip

Resolution: fixed
Status: closedreopened

comment:9 Changed 6 years ago by Don-vip

Ticket #9310 has been marked as a duplicate of this ticket.

comment:10 Changed 6 years ago by Don-vip

Cc: ggeldenhuis added
Component: Installer MacOSCore
Keywords: osx added

From #9310 screenshot we could do something for preferences icons, I didn't think it would be so small...


@ggeldenhuis: To use Java 7 on Mac you currently cannot use Web Start. Can you try with regular JAR file ? "java -jar josm-tested.jar" to see if it's better ? InstallNotes#MacOS

Changed 6 years ago by ggeldenhuis

comment:11 Changed 6 years ago by ggeldenhuis

I will give it a go. java -version still show 6 on the command line. I am using the jar file locally copied into applications directory and not webstart. I will get it sorted and report back.

I've seen a possibly related issue when editing fields in Advanced Preferences. Screenshot attached.

comment:12 Changed 6 years ago by anonymous

Hello,

I am using the Java Web Start version of JOSM with Java 7 and the text is clear and crisp.

However, the icons are still at the low resolution, and the map view also.

Is there a way to a least have an high resolution map display?

comment:13 Changed 5 years ago by Don-vip

Keywords: macosx added; osx removed

comment:14 Changed 5 years ago by Don-vip

Keywords: Mac removed

comment:15 Changed 5 years ago by Stereo

Cc: Stereo added

comment:16 Changed 2 years ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #9995.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain neic.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.