Modify

Opened 7 years ago

Closed 7 years ago

#7722 closed defect (fixed)

do not render junction=roundabout as area

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Internal mappaint style Version: latest
Keywords: junction roundabout Cc:

Description

Please, do not render junction=roundabout as area.

Thanks

r5241

Attachments (1)

7722.patch (3.3 KB) - added by simon04 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by skyper

Happens with a closed way.

A closed way with highway=* should never be treated as area unless it is tagged with area=yes.

comment:2 Changed 7 years ago by simon04

Resolution: fixed
Status: newclosed

In 5247/josm:

fix #7722 - do not render junction=roundabout as area

comment:3 Changed 7 years ago by skyper

This line is outdated:
trunk/styles/standard/elemstyles.xml?rev=5247#L742

Note: junction=roundabout can be used on nodes but please never use mini_roundabouts for normal ones as these are two different things. See: http://lists.openstreetmap.org/pipermail/tagging/2012-May/010107.html

Changed 7 years ago by simon04

Attachment: 7722.patch added

comment:4 Changed 7 years ago by simon04

Summary: do not render junction=roundabout as area[Patch] do not render junction=roundabout as area

I tried to stay away from the roundabout discussion … ;-)

skyper, I'd …

  • allow junction=roundabout on nodes + icon
  • require highway only for junctions on ways (validator)
  • remove area style for highway=turning_circle

… do you agree?

comment:5 in reply to:  4 ; Changed 7 years ago by skyper

Replying to simon04:

I tried to stay away from the roundabout discussion … ;-)

skyper, I'd …

  • allow junction=roundabout on nodes + icon
  • require highway only for junctions on ways (validator)
  • remove area style for highway=turning_circle

… do you agree?

Thanks, that is fine, but please delete the second part of source:trunk/styles/standard/elemstyles.xml?rev=5247#L742.

comment:6 in reply to:  5 ; Changed 7 years ago by simon04

Replying to skyper:

Thanks, that is fine, but please delete the second part of source:trunk/styles/standard/elemstyles.xml?rev=5247#L742.

Already covered in the patch. :-)

comment:7 Changed 7 years ago by simon04

In 5250/josm:

fix #7722 - update roundabout-related styles/presets/checks.

  • allow junction=roundabout on nodes + icon
  • require highway only for junctions on ways (validator)
  • remove area style for highway=turning_circle

comment:8 in reply to:  6 Changed 7 years ago by skyper

Replying to simon04:

Replying to skyper:

Thanks, that is fine, but please delete the second part of source:trunk/styles/standard/elemstyles.xml?rev=5247#L742.

Already covered in the patch. :-)

Sorry, should have look at it. :-)

comment:9 Changed 7 years ago by skyper

Summary: [Patch] do not render junction=roundabout as areado not render junction=roundabout as area

comment:10 Changed 7 years ago by skyper

Ticket #7755 has been marked as a duplicate of this ticket.

comment:11 Changed 7 years ago by skyper

Resolution: fixed
Status: closedreopened

Now all roundabouts are rendered white instead of the colour according to highway=*

We do not have to evaluate junction=roundabout for rendered colour but simple stick to the highway rendering.

EDIT: It is also not possible to use the preset for several ways forming a circle.

Last edited 7 years ago by skyper (previous) (diff)

comment:12 in reply to:  11 Changed 7 years ago by simon04

Replying to skyper:

Now all roundabouts are rendered white instead of the colour according to highway=*

We do not have to evaluate junction=roundabout for rendered colour but simple stick to the highway rendering.

So basically, we only render roundabouts on nodes? The oneway arrows are determined differently.

comment:13 Changed 7 years ago by simon04

Ticket #7764 has been marked as a duplicate of this ticket.

comment:14 Changed 7 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 5274/josm:

fix #7722 - do not render junction=roundabout in white

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.