Modify

Opened 9 years ago

Closed 7 years ago

#7723 closed defect (fixed)

Extrude tool does not remove some nodes

Reported by: Zverikk Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Check the attached file. There is a house with name="this house". Select extrude tool (X) and try to drag left or right (eastern or western) walls.

Expected: wall nodes moved. Result: nodes remain in place, and new one created, resulting in self-intersecting way.

Attachments (4)

housex.osm (364.8 KB) - added by Zverikk 9 years ago.
search for "this house"
extruder_7723_example.osm (889 bytes) - added by skyper 9 years ago.
sample
extrudes.osm (3.2 KB) - added by AlfonZ 9 years ago.
extrude possibilities
extrudes.png (9.8 KB) - added by AlfonZ 9 years ago.
extrude possibilities

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by Zverikk

Attachment: housex.osm added

search for "this house"

comment:1 Changed 9 years ago by mdk

This is "as expected", even if you can't see it. The upper left and the lower right angels of the building are not exactly 90° (I thing by merging with the building south of this building). If you select both buildings and press "q" "nothing" happens, except, that now the angels are EXACTLY 90° and not only NEARLY. Now the extrude works without extra nodes.

comment:2 in reply to:  1 Changed 9 years ago by skyper

Replying to mdk:

This is "as expected", even if you can't see it. The upper left and the lower right angels of the building are not exactly 90° (I thing by merging with the building south of this building). If you select both buildings and press "q" "nothing" happens, except, that now the angels are EXACTLY 90° and not only NEARLY. Now the extrude works without extra nodes.

No, it does not work right !
Even after using "q", move the left/right wall that the south wall will get small than the southern building.

Problem seems to get rid of the former "shared" node and instead add the new node to the other building (probably not easy).

Last edited 9 years ago by skyper (previous) (diff)

comment:3 Changed 9 years ago by skyper

Priority: normalmajor

This happens quite often lately even with single buildings. It somehow depends on the sides of the building (eg east and west work but north and south do not). Extruding first one working side fixes the issue. Gonna attach sample file.

  • Just try to extrude the south wall of the building inwards.
Last edited 9 years ago by skyper (previous) (diff)

Changed 9 years ago by skyper

Attachment: extruder_7723_example.osm added

sample

Changed 9 years ago by AlfonZ

Attachment: extrudes.osm added

extrude possibilities

Changed 9 years ago by AlfonZ

Attachment: extrudes.png added

extrude possibilities

comment:4 Changed 9 years ago by AlfonZ

It seems to me that the confusion is caused by (underdocumented) possibilities the extrude mode provides by moving the mouse while dragging - perpendicular to the segment and aligned with neighboring segment(s).
It can be seen more easily on angles distinctly different from 90°.

extrude possibilities

So when the angles are near 90°, it can be hard to distinguish which one of the choices possible is being selected, leading to unexpected results.

comment:5 in reply to:  3 ; Changed 9 years ago by skyper

Priority: majornormal

Replying to skyper:

This happens quite often lately even with single buildings.

Ok, I used it with Gauß-Krüger projection. Have to watch if I can reproduce it with new ways created with extruder.

EDT: If AlfonZ is right I should find a solution with only one instead of two extra nodes.

Last edited 9 years ago by skyper (previous) (diff)

comment:6 in reply to:  5 Changed 9 years ago by skyper

Replying to skyper:

Replying to skyper:

This happens quite often lately even with single buildings.

Ok, I used it with Gauß-Krüger projection. Have to watch if I can reproduce it with new ways created with extruder.

EDT: If AlfonZ is right I should find a solution with only one instead of two extra nodes.

Ok, situation solved for enlarging but for smallering this methode does not work producing unwanted results. Gonna open other tickets: #7990, #7991.

comment:7 in reply to:  4 Changed 9 years ago by skyper

Replying to AlfonZ:

It seems to me that the confusion is caused by (underdocumented) possibilities the extrude mode provides by moving the mouse while dragging - perpendicular to the segment and aligned with neighboring segment(s).

So when the angles are near 90°, it can be hard to distinguish which one of the choices possible is being selected, leading to unexpected results.

It happened again.

I only had one possibility smallering and it sometimes happened even after using "rectify" several times.

comment:8 Changed 7 years ago by Zverikk

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.