Modify

Opened 12 years ago

Last modified 6 days ago

#7282 new defect

OsmTransferCanceledException while opening changeset or uploading changes

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: upload, network, api, changeset, upload-api-response error ResponseCode 500 Cc: bergertho

Description (last modified by Don-vip)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-19 02:32:42
Last Changed Author: Don-vip
Revision: 4667
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-19 00:02:30 +0100 (Mon, 19 Dec 2011)
Last Changed Rev: 4667

Identification: JOSM/1.5 (4667 de)
Memory Usage: 97 MB / 494 MB (13 MB allocated, but free)
Java version: 1.6.0_29, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: ElevationProfile (27285)
Plugin: PicLayer (27241)
Plugin: buildings_tools (27355)
Plugin: openstreetbugs (27119)
Plugin: osmarender (27309)
Plugin: terracer (27289)
Plugin: turnrestrictions (27241)

org.openstreetmap.josm.io.OsmTransferCanceledException
	at org.openstreetmap.josm.io.OsmApi.sleepAndListen(OsmApi.java:486)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:576)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:510)
	at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:460)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesAsDiffUpload(OsmServerWriter.java:132)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:208)
	at org.openstreetmap.josm.gui.io.UploadLayerTask.run(UploadLayerTask.java:126)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

EDIT More recent stacktrace from #8884:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-07-10 01:34:22
Last Changed Author: stoecker
Revision: 6060
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-07-08 22:13:24 +0200 (Mon, 08 Jul 2013)
Last Changed Rev: 6060

Identification: JOSM/1.5 (6060 es) Windows 7 64-Bit
Memory Usage: 102 MB / 247 MB (25 MB allocated, but free)
Java version: 1.7.0_09, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.policy=file:C:\Program Files (x86)\Java\jre7\lib\security\javaws.policy, -DtrustProxy=true, -Xverify:remote, -Djnlpx.home=C:\Program Files (x86)\Java\jre7\bin, -Djnlpx.origFilenameArg=C:\Users\carlos\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\21\73111055-7f952e4e, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Xbootclasspath/a:C:\Program Files (x86)\Java\jre7\lib\javaws.jar;C:\Program Files (x86)\Java\jre7\lib\deploy.jar;C:\Program Files (x86)\Java\jre7\lib\plugin.jar, -Djnlpx.splashport=50966, -Djnlp.application.href=http://josm.openstreetmap.de/download/josm.jnlp, -Djnlpx.jvm=C:\Program Files (x86)\Java\jre7\bin\javaw.exe, -Djnlpx.vmargs=-Djnlp.application.href=http://josm.openstreetmap.de/download/josm.jnlp]
Dataset consistency test: No problems found

Plugin: turnrestrictions (29435)

org.openstreetmap.josm.io.OsmTransferCanceledException
	at org.openstreetmap.josm.io.OsmApi.sleepAndListen(OsmApi.java:545)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:635)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:569)
	at org.openstreetmap.josm.io.OsmApi.openChangeset(OsmApi.java:407)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:201)
	at org.openstreetmap.josm.gui.io.UploadLayerTask.run(UploadLayerTask.java:126)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (25)

comment:1 by skyper, 12 years ago

Ticket #7283 has been marked as a duplicate of this ticket.

comment:2 by skyper, 12 years ago

Cc: bergertho added
Keywords: upload added
Version: tested

comment:3 by bastiK, 12 years ago

Description: modified (diff)

Could you describe the problem in more detail, how often have you tried, are you able to upload with other versions of the software? Small or large changeset?

comment:4 by skyper, 12 years ago

Owner: changed from team to anonymous
Status: newneedinfo

comment:5 by skyper, 12 years ago

Owner: changed from anonymous to bergertho

comment:6 by skyper, 12 years ago

Resolution: needinfo
Status: needinfoclosed

comment:7 by Don-vip, 11 years ago

Keywords: network api changeset added
Resolution: needinfo
Status: closedreopened
Summary: JOSM/1.5 (4667 de) - Upload not possibleUnable to upload modifications (OsmTransferCanceledException while opening changeset)
Version: tested

Happened again with r6060 in #8884

comment:8 by Don-vip, 11 years ago

Ticket #8884 has been marked as a duplicate of this ticket.

comment:9 by Don-vip, 11 years ago

Description: modified (diff)

comment:10 by Don-vip, 11 years ago

Description: modified (diff)
Summary: Unable to upload modifications (OsmTransferCanceledException while opening changeset)OsmTransferCanceledException while opening changeset or uploading changes

comment:11 by Don-vip, 11 years ago

Owner: changed from bergertho to team
Status: reopenednew

comment:12 by simon04, 8 years ago

Keywords: upload-api-response added

comment:13 by Don-vip, 5 years ago

Priority: normalmajor

comment:14 by Don-vip, 5 years ago

Ticket #14058 has been marked as a duplicate of this ticket.

comment:15 by Don-vip, 5 years ago

Ticket #15526 has been marked as a duplicate of this ticket.

comment:16 by Don-vip, 5 years ago

Ticket #17289 has been marked as a duplicate of this ticket.

comment:17 by Klumbumbus, 4 years ago

Ticket #19371 has been marked as a duplicate of this ticket.

comment:18 by simon04, 4 years ago

in reply to:  18 comment:19 by skyper, 4 years ago

Replying to simon04:

osmwiki:Platform_Status – API and website down (osmwiki:Special:Diff/1999767)

Not for me, or did it change again?

comment:21 by skyper, 4 years ago

Keywords: error ResponseCode 500 added

comment:22 by simon04, 4 years ago

Ticket #7850 has been marked as a duplicate of this ticket.

comment:23 by simon04, 4 years ago

Ticket #19490 has been marked as a duplicate of this ticket.

comment:24 by simon04, 4 years ago

Ticket #19922 has been marked as a duplicate of this ticket.

comment:25 by anonymous, 6 days ago

It's happening again - I can't even add a single POI..

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from team to the specified user.
Next status will be 'needinfo'. The owner will be changed from team to anonymous.
as duplicate The resolution will be set to duplicate. Next status will be 'closed'. The specified ticket will be cross-referenced with this ticket.
The owner will be changed from team to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.