Modify

Opened 4 years ago

Closed 22 months ago

Last modified 22 months ago

#15526 closed defect (duplicate)

Exception in the shutdown of JOSM and fails to save changes

Reported by: RailAir Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report upload Cc:

Description

What steps will reproduce the problem?

  1. Tried to upload changes. Today some irregularities in the upload procedure.

What is the expected result? Upload as usual.

What happens instead? Upload fails sometimes but it seems that the upload was succesful in the background. And the last trial was to close JOSM. Popup says there are some unsaved changes.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-29 19:52:48 +0100 (Sun, 29 Oct 2017)
Build-Date:2017-10-29 19:11:19
Revision:13053
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13053 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1703 (15063)
Memory Usage: 862 MB / 1820 MB (402 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1280x1024, \Display1 1280x1024
Maximum Screen Size: 1280x1024
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (33735)
+ editgpx (33004)
+ pbf (33568)
+ poly (33570)
+ turnrestrictions (33537)
+ undelete (33480)

Tagging presets:
+ C:\Program Files (x86)\JOSM\Presets_Historic_Stone.zip

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&zip=1

Last errors/warnings:
- E: Error header: Version mismatch: Provided 1, server had: 2 of Way 264347680
- E: Konflikte gefunden - <html>Hochladen <strong>fehlgeschlagen</strong>, da der Server eine neuere Version<br>von einem Ihrer Punkte, Linien oder Relationen hat.<br>Der Konflikt wird durch ein Objekt vom Typ <strong>Linie</strong> mit der Kennung <strong>264.347.680</strong> ausgelöst.<br>Der Server hat Version 2, Ihre Version ist 1.<br>Wählen Sie <strong>Nur Linie 264.347.680 synchronisieren</strong>, um dieses Objekt zu synchronisieren.<br>Wählen Sie <strong>Ganzen Datensatz synchronisieren</strong>, um den kompletten lokalen Datensatz mit dem Server zu synchronisieren.<br>Wählen Sie <strong>Abbrechen</strong>, um abzubrechen und weiterzuarbeiten.</html>
- W: Ungespeicherte Änderungen - <html>Die Relation wurde geändert.<br><br>Wollen Sie die Änderungen speichern?</html>
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- E: Handled by bug report queue: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
- W: 1 problems occured during upload/save


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled
	at org.openstreetmap.josm.io.OsmApi.sleepAndListen(OsmApi.java:581)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:679)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:621)
	at org.openstreetmap.josm.io.OsmApi.modifyPrimitive(OsmApi.java:397)
	at org.openstreetmap.josm.io.OsmServerWriter.makeApiRequest(OsmServerWriter.java:234)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesIndividually(OsmServerWriter.java:115)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:214)
	at org.openstreetmap.josm.gui.io.UploadLayerTask.run(UploadLayerTask.java:125)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

=== RUNNING THREADS ===
Thread: Timer-0 (37) of main
java.lang.Object.wait(Native Method)
java.util.TimerThread.mainLoop(Unknown Source)
java.util.TimerThread.run(Unknown Source)

Thread: WMS-downloader-17 (2478)
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.parkNanos(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.pollFirst(Unknown Source)
org.openstreetmap.josm.data.cache.HostLimitQueue.poll(HostLimitQueue.java:84)
org.openstreetmap.josm.data.cache.HostLimitQueue.poll(HostLimitQueue.java:30)
java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: RemoteControl HTTPS Server (40) of main
java.net.DualStackPlainSocketImpl.accept0(Native Method)
java.net.DualStackPlainSocketImpl.socketAccept(Unknown Source)
java.net.AbstractPlainSocketImpl.accept(Unknown Source)
java.net.PlainSocketImpl.accept(Unknown Source)
java.net.ServerSocket.implAccept(Unknown Source)
sun.security.ssl.SSLServerSocketImpl.accept(Unknown Source)
org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.run(RemoteControlHttpsServer.java:404)

Thread: Attach Listener (5) of system

Thread: Signal Dispatcher (4) of system

Thread: File Watcher (12) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.takeFirst(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.take(Unknown Source)
sun.nio.fs.AbstractWatchService.take(Unknown Source)
org.openstreetmap.josm.io.FileWatcher.processEvents(FileWatcher.java:135)
org.openstreetmap.josm.io.FileWatcher$$Lambda$4/1830908236.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: DestroyJavaVM (46) of main

Thread: message-notifier-0 (45) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.parkNanos(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(Unknown Source)
java.util.concurrent.ScheduledThreadPoolExecutor$DelayedWorkQueue.take(Unknown Source)
java.util.concurrent.ScheduledThreadPoolExecutor$DelayedWorkQueue.take(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: JCS-ElementEventQueue-Thread-7 (35) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.util.concurrent.LinkedBlockingQueue.take(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: RemoteControl HTTP Server (39) of main
java.net.DualStackPlainSocketImpl.accept0(Native Method)
java.net.DualStackPlainSocketImpl.socketAccept(Unknown Source)
java.net.AbstractPlainSocketImpl.accept(Unknown Source)
java.net.PlainSocketImpl.accept(Unknown Source)
java.net.ServerSocket.implAccept(Unknown Source)
java.net.ServerSocket.accept(Unknown Source)
org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpServer.run(RemoteControlHttpServer.java:104)

Thread: RemoteControl HTTPS Server (41) of main
java.net.DualStackPlainSocketImpl.accept0(Native Method)
java.net.DualStackPlainSocketImpl.socketAccept(Unknown Source)
java.net.AbstractPlainSocketImpl.accept(Unknown Source)
java.net.PlainSocketImpl.accept(Unknown Source)
java.net.ServerSocket.implAccept(Unknown Source)
sun.security.ssl.SSLServerSocketImpl.accept(Unknown Source)
org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.run(RemoteControlHttpsServer.java:404)

Thread: Thread-1 (11) of main
sun.nio.fs.WindowsNativeDispatcher.GetQueuedCompletionStatus0(Native Method)
sun.nio.fs.WindowsNativeDispatcher.GetQueuedCompletionStatus(Unknown Source)
sun.nio.fs.WindowsWatchService$Poller.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: styled-map-renderer-633 (2573)
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.ForkJoinPool.awaitWork(Unknown Source)
java.util.concurrent.ForkJoinPool.runWorker(Unknown Source)
java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)

Thread: class org.openstreetmap.josm.gui.io.SaveLayersDialog$SaveAndUploadTask-0 (2579) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.util.concurrent.LinkedBlockingQueue.take(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: TimerQueue (22) of system
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.parkNanos(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(Unknown Source)
java.util.concurrent.DelayQueue.take(Unknown Source)
javax.swing.TimerQueue.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: org.openstreetmap.josm.gui.io.SaveLayersDialog$SaveAndUploadTask (2578) of main
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Unknown Source)
java.awt.EventQueue.invokeAndWait(Unknown Source)
java.awt.EventQueue.invokeAndWait(Unknown Source)
javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWait(GuiHelper.java:217)
org.openstreetmap.josm.gui.io.SaveLayersDialog$SaveAndUploadTask.run(SaveLayersDialog.java:664)
java.lang.Thread.run(Unknown Source)

Thread: AWT-Shutdown (20) of system
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Unknown Source)
sun.awt.AWTAutoShutdown.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Finalizer (3) of system
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.lang.ref.Finalizer$FinalizerThread.run(Unknown Source)

Thread: Java2D Disposer (14) of system
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
sun.java2d.Disposer.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Weak reference cleaner (25) of main
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.lang.ref.ReferenceQueue.remove(Unknown Source)
org.openstreetmap.josm.tools.ListenableWeakReference.clean(ListenableWeakReference.java:60)
org.openstreetmap.josm.tools.ListenableWeakReference$$Lambda$99/1552326679.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Reference Handler (2) of system
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Unknown Source)
java.lang.ref.Reference.tryHandlePending(Unknown Source)
java.lang.ref.Reference$ReferenceHandler.run(Unknown Source)

Thread: RemoteControl HTTP Server (38) of main
java.net.DualStackPlainSocketImpl.accept0(Native Method)
java.net.DualStackPlainSocketImpl.socketAccept(Unknown Source)
java.net.AbstractPlainSocketImpl.accept(Unknown Source)
java.net.PlainSocketImpl.accept(Unknown Source)
java.net.ServerSocket.implAccept(Unknown Source)
java.net.ServerSocket.accept(Unknown Source)
org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpServer.run(RemoteControlHttpServer.java:104)

Thread: AWT-EventQueue-0 (19) of main
Stacktrace see above.

Thread: Timer-1 (50) of main
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Unknown Source)
java.util.TimerThread.mainLoop(Unknown Source)
java.util.TimerThread.run(Unknown Source)

Thread: AWT-Windows (17) of system
sun.awt.windows.WToolkit.eventLoop(Native Method)
sun.awt.windows.WToolkit.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: Map Status Collector (53) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.util.concurrent.LinkedBlockingQueue.take(Unknown Source)
org.openstreetmap.josm.gui.MapStatus$Collector.run(MapStatus.java:412)
java.lang.Thread.run(Unknown Source)

Thread: D3D Screen Updater (24) of system
java.lang.Object.wait(Native Method)
sun.java2d.d3d.D3DScreenUpdateManager.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: main-worker-0 (48) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.util.concurrent.LinkedBlockingQueue.take(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Thread: WMS-downloader-15 (2424)
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.parkNanos(Unknown Source)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(Unknown Source)
java.util.concurrent.LinkedBlockingDeque.pollFirst(Unknown Source)
org.openstreetmap.josm.data.cache.HostLimitQueue.poll(HostLimitQueue.java:84)
org.openstreetmap.josm.data.cache.HostLimitQueue.poll(HostLimitQueue.java:30)
java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 22 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7282.

comment:2 Changed 22 months ago by Don-vip

Keywords: upload added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.