Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6792 closed defect (fixed)

validator: relation type boundary enhancements

Reported by: Larry0ua Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: Cc:

Description

The issue is that relation type=boundary is validated incorrectly.
Take into account:

  • role label should be point, optional and not more than one
  • role admin_centre should be point, optional and not more than one.

I think the next lines should be added to defaultpresets.xml instead of 4302:

<role key="admin_centre" text="Administration centre" requisite="optional" type="node" count="1" />
<role key="label" text="Label point" requisite="optional" type="node" count="1" />

wiki page: http://wiki.openstreetmap.org/wiki/Relation:boundary#Relation_Members

Attachments (1)

6792.patch (999 bytes) - added by Larry0ua 8 years ago.
patch for defaultpresets file modification

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Larry0ua

Attachment: 6792.patch added

patch for defaultpresets file modification

comment:1 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In [4424/josm]:

fix #6792 - relation type boundary enhancements (patch by Larry0ua)

comment:2 Changed 8 years ago by simon04

Ticket #6262 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.