Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6791 closed defect (duplicate)

Es kam ein Fenster ?

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-08-01 01:31:34
Last Changed Author: stoecker
Revision: 4279
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-07-31 23:52:49 +0200 (Sun, 31 Jul 2011)
Last Changed Rev: 4279

Identification: JOSM/1.5 (4279 de)
Memory Usage: 494 MB / 494 MB (141 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: AddrInterpolation (26530)
Plugin: ColumbusCSV (26174)
Plugin: CommandLine (26530)
Plugin: Create_grid_of_ways (26406)
Plugin: DirectDownload (26530)
Plugin: DirectUpload (26530)
Plugin: FixAddresses (26530)
Plugin: ImageWayPoint (26406)
Plugin: ImportImagePlugin (26530)
Plugin: ImproveWayAccuracy (26530)
Plugin: OpeningHoursEditor (26530)
Plugin: PicLayer (26530)
Plugin: RoadSigns (26406)
Plugin: SeaMapEditor (26527)
Plugin: SimplifyArea (26530)
Plugin: Tracer (26406)
Plugin: alignways (26530)
Plugin: buildings_tools (26530)
Plugin: cadastre-fr (26530)
Plugin: contourmerge (1001)
Plugin: czechaddress (26509)
Plugin: dataimport (26174)
Plugin: download_along (26530)
Plugin: editgpx (26406)
Plugin: epsg31287 (26174)
Plugin: ext_tools (26530)
Plugin: globalsat (26509)
Plugin: gpxfilter (26530)
Plugin: graphview (26530)
Plugin: irsrectify (26174)
Plugin: junctionchecking (26530)
Plugin: lakewalker (26530)
Plugin: mapdust (26406)
Plugin: mappinonosm (5)
Plugin: michigan_left (26406)
Plugin: multipoly-convert (26406)
Plugin: nearclick (26174)
Plugin: openstreetbugs (26530)
Plugin: pdfimport (26530)
Plugin: photo_geotagging (26530)
Plugin: plastic_laf (26174)
Plugin: proj4j (26509)
Plugin: public_transport (26530)
Plugin: reltoolbox (26530)
Plugin: restart (26406)
Plugin: reverter (26530)
Plugin: routes (26406)
Plugin: routing (26530)
Plugin: scripting (4)
Plugin: tageditor (26509)
Plugin: tagging-preset-tester (26406)
Plugin: terracer (26406)
Plugin: touchscreenhelper (26174)
Plugin: turnlanes (26530)
Plugin: turnrestrictions (26530)
Plugin: undelete (26530)
Plugin: utilsplugin2 (26530)
Plugin: walkingpapers (26530)
Plugin: waydownloader (26530)
Plugin: waypoint_search (26406)
Plugin: wayselector (26174)
Plugin: wms-turbo-challenge2 (26530)

java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
	at java.util.ArrayList.rangeCheck(ArrayList.java:571)
	at java.util.ArrayList.get(ArrayList.java:349)
	at org.openstreetmap.josm.gui.conflict.pair.tags.TagMergeModel.rememberDecision(TagMergeModel.java:136)
	at org.openstreetmap.josm.gui.conflict.pair.tags.TagMergeModel.decide(TagMergeModel.java:165)
	at org.openstreetmap.josm.gui.conflict.pair.tags.TagMerger$KeepMineAction.actionPerformed(TagMerger.java:283)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:253)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6203)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:5968)
	at java.awt.Container.processEvent(Container.java:2105)
	at java.awt.Component.dispatchEventImpl(Component.java:4564)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Component.dispatchEvent(Component.java:4390)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
	at java.awt.Container.dispatchEventImpl(Container.java:2149)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4390)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:649)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
	at java.awt.EventQueue$2.run(EventQueue.java:622)
	at java.awt.EventQueue$2.run(EventQueue.java:620)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1496)
	at java.awt.Component.setVisible(Component.java:1448)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.setVisible(ConflictResolutionDialog.java:62)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:150)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$000(ConflictDialog.java:58)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$1.mouseClicked(ConflictDialog.java:87)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
...<snip>...

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by Don-vip

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by Don-vip

Closed as duplicate of #5680.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.