Modify

Opened 11 years ago

Closed 9 years ago

#5639 closed defect (fixed)

active osmb-plugin via panel

Reported by: Luebeck Owned by: team
Priority: normal Milestone:
Component: Plugin openstreetbugs Version:
Keywords: Cc:

Description (last modified by Don-vip)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-11-15 02:31:31
Last Changed Author: bastiK
Revision: 3656
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-11-15 00:02:20 +0100 (Mon, 15 Nov 2010)
Last Changed Rev: 3656

Identification: JOSM/1.5 (3656 de)
Memory Usage: 61 MB / 989 MB (16 MB allocated, but free)
Java version: 1.6.0_21, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: AddrInterpolation (23420)
Plugin: FixAddresses (24232)
Plugin: OpeningHoursEditor (22850)
Plugin: PicLayer (22549)
Plugin: RoadSigns (22850)
Plugin: buildings_tools (23804)
Plugin: livegps (21706)
Plugin: openstreetbugs (23747)
Plugin: public_transport (22148)
Plugin: remotecontrol (22734)
Plugin: surveyor (21706)
Plugin: terracer (22169)
Plugin: touchscreenhelper (21576)
Plugin: turnrestrictions (24125)
Plugin: undelete (22365)
Plugin: utilsplugin2 (24236)
Plugin: walkingpapers (22549)
Plugin: wayselector (23103)
Plugin: wmsplugin (24221)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.MapView.getVisibleLayersInZOrder(MapView.java:417)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:452)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JSplitPane.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JLayeredPane.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at java.awt.GraphicsCallback$PaintCallback.run(Unknown Source)
	at sun.awt.SunGraphicsCallback.runOneComponent(Unknown Source)
	at sun.awt.SunGraphicsCallback.runComponents(Unknown Source)
	at java.awt.Container.paint(Unknown Source)
	at java.awt.Window.paint(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by bastiK

Component: CorePlugin openstreetbugs

Probably caused by OpenStreetBugs plugin, see #6030.

comment:2 Changed 9 years ago by Don-vip

Description: modified (diff)

Ticket #3949 has been marked as a duplicate of this ticket.
Ticket #4473 has been marked as a duplicate of this ticket.
Ticket #4779 has been marked as a duplicate of this ticket.
Ticket #4811 has been marked as a duplicate of this ticket.
Ticket #5409 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by Don-vip

Description: modified (diff)

comment:4 Changed 9 years ago by Don-vip

Resolution: fixed
Status: newclosed

Probably fixed in [o25518] with #6034 correction.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.