Modify

Opened 11 years ago

Closed 11 years ago

#6034 closed defect (fixed)

OpenStreetBugs layer appears 2 times in the Layers window

Reported by: jBeata Owned by: team
Priority: normal Milestone:
Component: Plugin openstreetbugs Version:
Keywords: Cc:

Description

After activating the OpenStreetBugs layer, the layer appears 2 times in the Layer window.

Attachments (1)

josm.png (542.5 KB) - added by jBeata 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by jBeata

Component: CorePlugin openstreetbugs

comment:2 Changed 11 years ago by hampelratte

Can you please describes the steps to reproduce this bug? I can't get JOSM to show two OSB layers.

comment:3 Changed 11 years ago by jBeata

Under Linux install JOSM editor. Download the Openstreetbugs plugin, and activate after a JOSM restart. In the layers window the Openstreetbugs layer appears two times.
I'm not sure if it is a Linux related issue or not. This issue happens only after a fresh install of JOSM under linux.

Changed 11 years ago by jBeata

Attachment: josm.png added

comment:4 Changed 11 years ago by anonymous

Ticket #6059 has been marked as a duplicate of this ticket.

comment:5 Changed 11 years ago by stoecker

Better description in #6059.

comment:6 Changed 11 years ago by hampelratte

Die Methode updateLayer, die dafür zuständig ist, den OsbLayer hinzuzufügen, wenn er noch nicht vorhanden ist, wurde von zwei unterschiedlichen Threads aufgerufen. Da lag eine race condition vor, so dass in manchen Fällen beide Threads bei der Überprüfung bemerkt haben, dass der OsbLayer nicht vorhanden ist und ihn deshalb auch beide angelegt haben. Ich habe die Methode jetzt synchronisiert, so dass diese race condition ausgeschlossen ist.

comment:7 Changed 11 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.