Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5074 closed defect (irreproducible)

autocompletion broken

Reported by: dieterdreist Owned by: dieterdreist
Priority: normal Milestone:
Component: Core Version: latest
Keywords: autocompletion Cc:

Description

Since today (at least, this was introduced lately but can also be in the last 4-5 days) autocompletion is broken: when you try to add text to an autocompleted text (tags or changeset comment) it will continue typing at the point _before_ autocompletion completed the text.

Attachments (0)

Change History (21)

comment:1 Changed 12 years ago by stoecker

Owner: changed from team to dieterdreist
Status: newneedinfo

I don't understand your text. I should be before autocompletion added texts. What do you expect?

comment:2 in reply to:  1 Changed 12 years ago by dieterdreist

Replying to stoecker:

I don't understand your text. I should be before autocompletion added texts. What do you expect?

sorry for not beeing clear:

  1. begin text
  2. autocompletion works and completes text
  3. text is not selected any more
  4. I add text to modify but then the already autocompleted text disappears again

This behaviour was different before, there is something changed.

comment:3 Changed 12 years ago by dieterdreist

Owner: changed from dieterdreist to stoecker
Status: needinfonew

comment:4 Changed 12 years ago by stoecker

Owner: changed from stoecker to bastiK

@bastiK:

I think this is your issue. I promised to never touch that code again.

comment:5 Changed 12 years ago by bastiK

Cannot reproduce.

Step 1-3 is clear. Could you descibe in more detail, under what circumstances the text disappears and what sequence of key strokes leads to this behaviour?

comment:6 Changed 12 years ago by anonymous

What OS do you use. I remember there have been big differences between operating systems.

comment:7 in reply to:  6 Changed 12 years ago by dieterdreist

Replying to anonymous:

What OS do you use. I remember there have been big differences between operating systems.

Linux 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux
Ubuntu 10.04

comment:8 Changed 12 years ago by bastiK

Owner: changed from bastiK to dieterdreist
Status: newneedinfo

Could you describe in more detail?

comment:9 Changed 12 years ago by stoecker

Ticket #4824 has been marked as a duplicate of this ticket.

comment:10 Changed 12 years ago by stoecker

See also #5074 for a good description.

comment:11 in reply to:  10 Changed 12 years ago by anonymous

Owner: changed from dieterdreist to stoecker
Status: needinfonew

Replying to stoecker:

See also #5074 for a good description.

I guess this is a typo, which No. did you mean?

comment:12 Changed 12 years ago by stoecker

Sorry - See #4824 I meant.

comment:13 Changed 12 years ago by bastiK

Owner: changed from stoecker to dieterdreist
Status: newneedinfo

Is it really the same issue?

I guess in #4824 the user complains that the longer form 'name:botanical' is used for autocompletion instead of 'name'. So you have to press delete.

comment:14 Changed 12 years ago by bastiK

The behaviour has changed in the "add or change tag" dialog , but I expect it to be the same in upload dialog / relation dialog after the recent changes.

comment:15 Changed 12 years ago by stoecker

I think the issue is, that sometimes clicking alone can lead to accepting of autocomplete suggestions. That probably should not happen. This seems very similar to this report, where also the handling of autocomplete suggestion does not do what is expected.

comment:16 Changed 12 years ago by stoecker

See also #3322. Probably also related.

comment:17 Changed 12 years ago by bastiK

@dieterdreist:
I cannot reproduce the problem you described. Apparently it is caused by my autocompletion changes, but without detailed info on what is actually wrong, I have to close as 'worksforme'.

comment:18 in reply to:  17 Changed 12 years ago by dieterdreist

Resolution: worksforme
Status: needinfoclosed

Replying to bastiK:

@dieterdreist:
I cannot reproduce the problem you described. Apparently it is caused by my autocompletion changes, but without detailed info on what is actually wrong, I have to close as 'worksforme'.

That's fine for me, because I can't reproduce it neither...
dD

comment:19 Changed 12 years ago by dieterdreist

Resolution: worksforme
Status: closedreopened

sorry, I reopen this because there are other users who seem to experience the same problem as described above (even if it seems currently to work for me).

comment:20 Changed 12 years ago by bastiK

Resolution: irreproducible
Status: reopenedclosed

I'd be happy to hear from these other users, closing for now.

comment:21 in reply to:  20 Changed 12 years ago by dieterdreist

Replying to bastiK:

I'd be happy to hear from these other users, closing for now.

http://josm.openstreetmap.de/ticket/4824
was the reference I was thinking about.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dieterdreist.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.