Modify

Opened 8 years ago

Last modified 11 months ago

#4925 new defect

Dialog are placed wrong on dual-head X11

Reported by: michael.letzgus@… Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: dual monitor Cc:

Description (last modified by stoecker)

Hi!

Dialogs like the "internal server error"-warning are placed wrong (in the center of the virtual screen) on dual-head X11.

Best regards,

Michael

Attachments (0)

Change History (14)

comment:1 Changed 6 years ago by stoecker

Description: modified (diff)
Priority: normalmajor

http://docs.oracle.com/javase/6/docs/api/java/awt/GraphicsDevice.html contains a description how to handle individual dual head screens. We should always create dialogs, startscreen and josm in a way, that it is displayed on a single screen, except the user chooses the size of josm.

comment:2 Changed 6 years ago by stoecker

Keywords: dual monitor added

comment:3 Changed 6 years ago by stoecker

Resolution: fixed
Status: newclosed

Should be fixed in r5015. Dialogs should appear on the screen, where JOSM main window is.

comment:4 Changed 6 years ago by rasher

Resolution: fixed
Status: closedreopened

On my setup, dialogs appear on my primary monitor (where JOSM was started), while JOSM is now on my secondary monitor, so it would appear this hasn't quite fixed it?

Although this is on Windows, so the situation might be slightly different. Running r5023.

comment:5 Changed 6 years ago by stoecker

Owner: changed from team to michael.letzgus@…
Status: reopenedneedinfo

Can you please recheck latest? When JOSM was moved to another monitor in full mode, then the screen settings have not been stored. I fixed that some time ago.

comment:6 Changed 6 years ago by michael.letzgus@…

With JOSM "latest" dialogs are always shown on the primary display - even if the mouse or the main window is on screen #2.

comment:7 Changed 6 years ago by stoecker

Owner: changed from michael.letzgus@… to team
Status: needinfonew

comment:8 Changed 6 years ago by stoecker

Hmpf, so some dialogs (all the warnings?) don't use these functions. Will have to check, when I have some coding time at a dual-screen setup.

Anyone wanting to donate two monitors for my home setup? :-)

comment:9 Changed 6 years ago by michael.letzgus@…

Update:
What I tested yesterday was the F1 Help Window.
Message boxes are displayed centered in the main app window.

comment:10 Changed 6 years ago by rasher

I've tested a bunch of different windows/dialogs and noted my results below.

This was done on Windows, with JOSM 5531, on a laptop with an external monitor attached. The laptop monitor is the primary monitor as far as Windows is concerned (it's labelled monitor 1 and has the process bar). JOSM was started there, and moved to the external monitor.

Incorrect

File > Download from OSM
File > Download from OSM mirror (plugin)
File > Upload Data
Edit > Preferences
Windows > Changeset manager
Help > Help
Edit relation dialog
Create relation dialog

Correct

File > Download object
File > Open location
File > Open
Edit > Search
Edit > Purge
Edit > Set buildings size (plugin)
View > History
View > Advanced info
Tools > Download along (plugin)
Presets > Search preset
Imagery > Imagery offset > New offset
Imagery > Rectified image (plugin?)
Help > About
Help > Show status report
Add tag dialog
Edit tag dialog
Add filter dialog
Edit filter dialog

comment:11 Changed 6 years ago by stoecker

Thanks for the list. Some of the (larger) dialogs should remember their position, so can you move the incorrect ones and retry after a JOSM restart? Or start with preferences cleaned, as in this case they should be initialized relative to main window.

Seems some of the dialogs don't use the new (approx 3 years old) WindowGeometry class yet.

comment:12 Changed 6 years ago by rasher

I'm not sure I understand why it should matter. Shouldn't spawned windows always appear on the monitor where JOSM is running? Seems a bit jarring that they adhere to something from an entirely different JOSM session - quite likely with a different monitor configuration.

Another window that doesn't show up right is the warning for unsaved changes. I'll add it in my previous comment.

comment:13 in reply to:  12 Changed 6 years ago by stoecker

Shouldn't spawned windows always appear on the monitor where JOSM is running?

No. Why do you have two monitors when using only one :-) Remember a setup, where main JOSM takes one screen and all additional windows open on the second. Perfectly fine way of working I would say.

Seems a bit jarring that they adhere to something from an entirely different JOSM session - quite likely with a different monitor configuration.

JOSM is designed to keep the running configuration also after beeing closed. While there are different concepts I don't think we will change that. At least it is ensured, that you will always see your windows, which is not true for all software I know, when changing from dual to single monitor setup .

comment:14 Changed 11 months ago by stoecker

Ticket #13166 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to michael.letzgus@uni-bielefeld.de
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from team to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.